summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-07-06 14:38:15 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-07-06 14:38:15 +0000
commita8355c1dd5941f915d4137773d371d44951e5a68 (patch)
tree11e955903f564897f3ed15a80280885121ce4b42 /x11-libs
parentMask app-arch/dczip for removal. See bug #502994. (diff)
downloadgentoo-2-a8355c1dd5941f915d4137773d371d44951e5a68.tar.gz
gentoo-2-a8355c1dd5941f915d4137773d371d44951e5a68.tar.bz2
gentoo-2-a8355c1dd5941f915d4137773d371d44951e5a68.zip
version bump, bug #553902
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libva/ChangeLog8
-rw-r--r--x11-libs/libva/libva-1.6.0.ebuild92
-rw-r--r--x11-libs/libva/libva-9999.ebuild5
3 files changed, 102 insertions, 3 deletions
diff --git a/x11-libs/libva/ChangeLog b/x11-libs/libva/ChangeLog
index 61dae02b3419..22d6c0bf8f07 100644
--- a/x11-libs/libva/ChangeLog
+++ b/x11-libs/libva/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libva
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/ChangeLog,v 1.69 2015/06/21 12:22:34 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/ChangeLog,v 1.70 2015/07/06 14:38:15 aballier Exp $
+
+*libva-1.6.0 (06 Jul 2015)
+
+ 06 Jul 2015; Alexis Ballier <aballier@gentoo.org> +libva-1.6.0.ebuild,
+ libva-9999.ebuild:
+ version bump, bug #553902
21 Jun 2015; Pacho Ramos <pacho@gentoo.org>
+files/libva-1.5.1-wayland-automagic.patch, libva-1.5.1.ebuild:
diff --git a/x11-libs/libva/libva-1.6.0.ebuild b/x11-libs/libva/libva-1.6.0.ebuild
new file mode 100644
index 000000000000..c8f442d006a7
--- /dev/null
+++ b/x11-libs/libva/libva-1.6.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/libva-1.6.0.ebuild,v 1.1 2015/07/06 14:38:15 aballier Exp $
+
+EAPI=5
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SCM=git-2
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="git://anongit.freedesktop.org/vaapi/libva"
+fi
+
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-multilib ${SCM} multilib
+
+DESCRIPTION="Video Acceleration (VA) API for Linux"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SRC_URI=""
+ S="${WORKDIR}/${PN}"
+else
+ SRC_URI="http://www.freedesktop.org/software/vaapi/releases/libva/${P}.tar.bz2"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+else
+ KEYWORDS=""
+fi
+IUSE="+drm egl opengl vdpau wayland X"
+REQUIRED_USE="|| ( drm wayland X )"
+
+VIDEO_CARDS="dummy nvidia intel fglrx nouveau"
+for x in ${VIDEO_CARDS}; do
+ IUSE+=" video_cards_${x}"
+done
+
+RDEPEND=">=x11-libs/libdrm-2.4.46[${MULTILIB_USEDEP}]
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+ )
+ egl? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] )
+ opengl? ( >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}] )
+ wayland? ( >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+PDEPEND="video_cards_nvidia? ( >=x11-libs/libva-vdpau-driver-0.7.4-r1[${MULTILIB_USEDEP}] )
+ video_cards_nouveau? ( >=x11-libs/libva-vdpau-driver-0.7.4-r3[${MULTILIB_USEDEP}] )
+ vdpau? ( >=x11-libs/libva-vdpau-driver-0.7.4-r1[${MULTILIB_USEDEP}] )
+ video_cards_fglrx? (
+ || ( >=x11-drivers/ati-drivers-14.12-r3[${MULTILIB_USEDEP}]
+ >=x11-libs/xvba-video-0.8.0-r1[${MULTILIB_USEDEP}] )
+ )
+ video_cards_intel? ( >=x11-libs/libva-intel-driver-1.2.2-r1[${MULTILIB_USEDEP}] )
+ "
+
+REQUIRED_USE="opengl? ( X )"
+
+DOCS=( NEWS )
+
+PATCHES=(
+ # Fix automagic depend, bug #529388
+ # https://bugs.freedesktop.org/show_bug.cgi?id=79478
+ "${FILESDIR}"/${PN}-1.5.1-wayland-automagic.patch
+)
+
+MULTILIB_WRAPPED_HEADERS=(
+/usr/include/va/va_backend_glx.h
+/usr/include/va/va_x11.h
+/usr/include/va/va_dri2.h
+/usr/include/va/va_dricommon.h
+/usr/include/va/va_glx.h
+)
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --with-drivers-path="${EPREFIX}/usr/$(get_libdir)/va/drivers"
+ $(use_enable video_cards_dummy dummy-driver)
+ $(use_enable opengl glx)
+ $(use_enable X x11)
+ $(use_enable wayland)
+ $(use_enable egl)
+ $(use_enable drm)
+ )
+ autotools-utils_src_configure
+}
diff --git a/x11-libs/libva/libva-9999.ebuild b/x11-libs/libva/libva-9999.ebuild
index 8b52b39328a7..a86979b8d931 100644
--- a/x11-libs/libva/libva-9999.ebuild
+++ b/x11-libs/libva/libva-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/libva-9999.ebuild,v 1.23 2015/01/06 19:33:30 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/libva-9999.ebuild,v 1.24 2015/07/06 14:38:15 aballier Exp $
EAPI=5
@@ -33,7 +33,7 @@ fi
IUSE="+drm egl opengl vdpau wayland X"
REQUIRED_USE="|| ( drm wayland X )"
-VIDEO_CARDS="dummy nvidia intel fglrx"
+VIDEO_CARDS="dummy nvidia intel fglrx nouveau"
for x in ${VIDEO_CARDS}; do
IUSE+=" video_cards_${x}"
done
@@ -51,6 +51,7 @@ RDEPEND=">=x11-libs/libdrm-2.4.46[${MULTILIB_USEDEP}]
DEPEND="${RDEPEND}
virtual/pkgconfig"
PDEPEND="video_cards_nvidia? ( >=x11-libs/libva-vdpau-driver-0.7.4-r1[${MULTILIB_USEDEP}] )
+ video_cards_nouveau? ( >=x11-libs/libva-vdpau-driver-0.7.4-r3[${MULTILIB_USEDEP}] )
vdpau? ( >=x11-libs/libva-vdpau-driver-0.7.4-r1[${MULTILIB_USEDEP}] )
video_cards_fglrx? (
|| ( >=x11-drivers/ati-drivers-14.12-r3[${MULTILIB_USEDEP}]