summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-03-10 23:23:56 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-03-10 23:23:56 +0000
commit998c3e4fc103b08d2f5a134cd39832b25e5ef224 (patch)
treeebae43127fd27a6051386e14c15246f8cc776bff /x11-libs
parentVersion bump (diff)
downloadgentoo-2-998c3e4fc103b08d2f5a134cd39832b25e5ef224.tar.gz
gentoo-2-998c3e4fc103b08d2f5a134cd39832b25e5ef224.tar.bz2
gentoo-2-998c3e4fc103b08d2f5a134cd39832b25e5ef224.zip
Version bump. Bug fixes and libglade dependency dropped for good.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/goffice/ChangeLog7
-rw-r--r--x11-libs/goffice/goffice-0.8.1.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/x11-libs/goffice/ChangeLog b/x11-libs/goffice/ChangeLog
index 8d7cec42b50f..8c38aa3a251c 100644
--- a/x11-libs/goffice/ChangeLog
+++ b/x11-libs/goffice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/goffice
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/ChangeLog,v 1.64 2010/03/03 22:00:36 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/ChangeLog,v 1.65 2010/03/10 23:23:56 eva Exp $
+
+*goffice-0.8.1 (10 Mar 2010)
+
+ 10 Mar 2010; Gilles Dartiguelongue <eva@gentoo.org> +goffice-0.8.1.ebuild:
+ Version bump. Bug fixes and libglade dependency dropped for good.
*goffice-0.8.0 (03 Mar 2010)
diff --git a/x11-libs/goffice/goffice-0.8.1.ebuild b/x11-libs/goffice/goffice-0.8.1.ebuild
new file mode 100644
index 000000000000..c1b1a9bb0bfc
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.8.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/goffice-0.8.1.ebuild,v 1.1 2010/03/10 23:23:56 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 flag-o-matic
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="http://freshmeat.net/projects/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.8"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="doc gnome"
+
+# Build fails with -gtk
+# FIXME: add lasem to tree
+RDEPEND=">=dev-libs/glib-2.16
+ >=gnome-extra/libgsf-1.14.9[gnome?]
+ >=dev-libs/libxml2-2.4.12
+ >=x11-libs/pango-1.8.1
+ >=x11-libs/cairo-1.2[svg]
+ x11-libs/libXext
+ x11-libs/libXrender
+ >=x11-libs/gtk+-2.16
+ gnome? ( >=gnome-base/gconf-2 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.18
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.11 )"
+
+DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --without-lasem
+ --with-gtk
+ $(use_with gnome gconf)"
+ filter-flags -ffast-math
+}
+
+src_install() {
+ gnome2_src_install
+ find "${D}" -name "*.la" -delete || die
+}