summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-05-28 12:57:47 +0000
committerJustin Lecher <jlec@gentoo.org>2012-05-28 12:57:47 +0000
commit8f6295b1ed00a1ea8e668db4078afe90f1f50d5f (patch)
tree57433d4efcc94189bd37f97faa1bb9669480de4b /x11-libs
parentInitial commit, ebuilds by idella4 and jtriley (diff)
downloadgentoo-2-8f6295b1ed00a1ea8e668db4078afe90f1f50d5f.tar.gz
gentoo-2-8f6295b1ed00a1ea8e668db4078afe90f1f50d5f.tar.bz2
gentoo-2-8f6295b1ed00a1ea8e668db4078afe90f1f50d5f.zip
x11-libs/libGLw: Version BUmp
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libGLw/ChangeLog7
-rw-r--r--x11-libs/libGLw/libGLw-8.0.0.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/x11-libs/libGLw/ChangeLog b/x11-libs/libGLw/ChangeLog
index 115215c013b9..d9daa4d18e12 100644
--- a/x11-libs/libGLw/ChangeLog
+++ b/x11-libs/libGLw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libGLw
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libGLw/ChangeLog,v 1.4 2012/05/17 15:50:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libGLw/ChangeLog,v 1.5 2012/05/28 12:57:47 jlec Exp $
+
+*libGLw-8.0.0 (28 May 2012)
+
+ 28 May 2012; Justin Lecher <jlec@gentoo.org> +libGLw-8.0.0.ebuild:
+ Version BUmp
*libGLw-1.0.0 (17 May 2012)
diff --git a/x11-libs/libGLw/libGLw-8.0.0.ebuild b/x11-libs/libGLw/libGLw-8.0.0.ebuild
new file mode 100644
index 000000000000..aff735948550
--- /dev/null
+++ b/x11-libs/libGLw/libGLw-8.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libGLw/libGLw-8.0.0.ebuild,v 1.1 2012/05/28 12:57:47 jlec Exp $
+
+EAPI=4
+
+MY_P=glw-"${PV}"
+
+inherit autotools-utils
+
+DESCRIPTION="Mesa GLw library"
+HOMEPAGE="http://mesa3d.sourceforge.net/"
+SRC_URI="ftp://ftp.freedesktop.org/pub/mesa/glw/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+motif static-libs"
+
+RDEPEND="
+ !media-libs/mesa[motif]
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/openmotif
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-motif
+ )
+ autotools-utils_src_configure
+}