summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2007-02-07 12:32:42 +0000
committerMart Raudsepp <leio@gentoo.org>2007-02-07 12:32:42 +0000
commit8d87a1ce31d27961fbd0b7297589c86bf79a4f50 (patch)
treeb7ff001571ac622c57c1906c509fb3dcc9a2efad /x11-libs
parentFixed the executable stack warnings with a patch from Vlastimil Babka <caster... (diff)
downloadgentoo-2-8d87a1ce31d27961fbd0b7297589c86bf79a4f50.tar.gz
gentoo-2-8d87a1ce31d27961fbd0b7297589c86bf79a4f50.tar.bz2
gentoo-2-8d87a1ce31d27961fbd0b7297589c86bf79a4f50.zip
Version bump
(Portage version: 2.1.2-r8)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/vte/ChangeLog7
-rw-r--r--x11-libs/vte/files/digest-vte-0.14.23
-rw-r--r--x11-libs/vte/vte-0.14.2.ebuild53
3 files changed, 62 insertions, 1 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index 522f2789b56a..60464cd8b082 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/vte
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.142 2007/01/18 23:04:02 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.143 2007/02/07 12:32:42 leio Exp $
+
+*vte-0.14.2 (07 Feb 2007)
+
+ 07 Feb 2007; Mart Raudsepp <leio@gentoo.org> +vte-0.14.2.ebuild:
+ Version bump
18 Jan 2007; Jeroen Roovers <jer@gentoo.org> vte-0.14.1.ebuild:
Stable for HPPA (bug #147751).
diff --git a/x11-libs/vte/files/digest-vte-0.14.2 b/x11-libs/vte/files/digest-vte-0.14.2
new file mode 100644
index 000000000000..755c0619f4c3
--- /dev/null
+++ b/x11-libs/vte/files/digest-vte-0.14.2
@@ -0,0 +1,3 @@
+MD5 eceafec1b564cc059fa3407f83631817 vte-0.14.2.tar.bz2 1031948
+RMD160 e580abbe747ff806d32973d463c909283fcc3b12 vte-0.14.2.tar.bz2 1031948
+SHA256 1ad92649f848064f903dd60a2d6d2b724d8fbe3c766bf5a4b6fcdbf1f2435088 vte-0.14.2.tar.bz2 1031948
diff --git a/x11-libs/vte/vte-0.14.2.ebuild b/x11-libs/vte/vte-0.14.2.ebuild
new file mode 100644
index 000000000000..432e1a14d8a2
--- /dev/null
+++ b/x11-libs/vte/vte-0.14.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.14.2.ebuild,v 1.1 2007/02/07 12:32:42 leio Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Xft powered terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc python opengl"
+
+RDEPEND=">=dev-libs/glib-2.9
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.1
+ >=media-libs/freetype-2.0.2
+ media-libs/fontconfig
+ sys-libs/ncurses
+ python? (
+ >=dev-python/pygtk-2.4
+ >=dev-lang/python-2.2
+ )
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )
+ || ( x11-libs/libX11 virtual/x11 )
+ virtual/xft"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="$(use_enable debug debugging) $(use_enable python) \
+ $(use_with opengl glX) --with-xft2 --with-pangox"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch "${FILESDIR}/${PN}-0.13.2-no-lazy-bindings.patch"
+ epatch "${FILESDIR}/${PN}-0.14.1-fbsd.patch"
+
+ cd ${S}/gnome-pty-helper
+ eautomake
+}