summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2009-05-24 12:08:37 +0000
committerTobias Klausmann <klausman@gentoo.org>2009-05-24 12:08:37 +0000
commit8be9bab8d500bcac063429fee5cbf2c7d72bb659 (patch)
tree9db31765101d103c4d6f8af10dfe80aad42454a7 /x11-libs
parentVersion bump for soname version. (diff)
downloadgentoo-2-8be9bab8d500bcac063429fee5cbf2c7d72bb659.tar.gz
gentoo-2-8be9bab8d500bcac063429fee5cbf2c7d72bb659.tar.bz2
gentoo-2-8be9bab8d500bcac063429fee5cbf2c7d72bb659.zip
Keyworded on alpha, bug #266201
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-webkit/ChangeLog10
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.5.1.ebuild8
2 files changed, 14 insertions, 4 deletions
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index 584818fc5791..e95cebd9f8ba 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/qt-webkit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.35 2009/05/14 23:45:37 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.36 2009/05/24 12:08:37 klausman Exp $
+
+ 24 May 2009; Tobias Klausmann <klausman@gentoo.org>
+ qt-webkit-4.5.1.ebuild:
+ Keyworded on alpha, bugs 266201 and 269739
+
+ 24 May 2009; Tobias Klausmann <klausman@gentoo.org>
+ qt-webkit-4.5.1.ebuild:
+ Added code to make linking work on alpha
14 May 2009; Ben de Groot <yngwin@gentoo.org> -qt-webkit-4.5.0.ebuild:
Remove old
diff --git a/x11-libs/qt-webkit/qt-webkit-4.5.1.ebuild b/x11-libs/qt-webkit/qt-webkit-4.5.1.ebuild
index bfb25a04b79e..edbdeda71267 100644
--- a/x11-libs/qt-webkit/qt-webkit-4.5.1.ebuild
+++ b/x11-libs/qt-webkit/qt-webkit-4.5.1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.5.1.ebuild,v 1.3 2009/05/15 18:14:28 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.5.1.ebuild,v 1.4 2009/05/24 12:08:37 klausman Exp $
EAPI="2"
-inherit qt4-build
+inherit qt4-build flag-o-matic
DESCRIPTION="The Webkit module for the Qt toolkit"
SLOT="4"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ppc ~ppc64 -sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ppc ~ppc64 -sparc ~x86 ~x86-fbsd"
IUSE=""
DEPEND="~x11-libs/qt-core-${PV}[debug=,ssl]
@@ -29,6 +29,8 @@ src_prepare() {
}
src_configure() {
+ # This fixes relocation overflows on alpha
+ use alpha && append-ldflags "-Wl,--no-relax"
myconf="${myconf} -webkit"
qt4-build_src_configure
}