summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-07-24 15:28:12 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-07-24 15:28:12 +0000
commit8b5450c051bed5d1fa79921d777fd3c9ac5142ef (patch)
tree7bcebb4790da4c299fb43dfdfd286be5526b4fb3 /x11-libs
parentRename local USE flag devices to global USE flag udisks, bug #517966. (diff)
downloadgentoo-2-8b5450c051bed5d1fa79921d777fd3c9ac5142ef.tar.gz
gentoo-2-8b5450c051bed5d1fa79921d777fd3c9ac5142ef.tar.bz2
gentoo-2-8b5450c051bed5d1fa79921d777fd3c9ac5142ef.zip
Fix compability with x11-libs/libvdpau >= 0.8 wrt #517778 by Justin Lecher
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libva-vdpau-driver/ChangeLog9
-rw-r--r--x11-libs/libva-vdpau-driver/files/libva-vdpau-driver-0.7.4-libvdpau-0.8.patch13
-rw-r--r--x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r2.ebuild44
3 files changed, 65 insertions, 1 deletions
diff --git a/x11-libs/libva-vdpau-driver/ChangeLog b/x11-libs/libva-vdpau-driver/ChangeLog
index 7365c812b417..aa355da6f16f 100644
--- a/x11-libs/libva-vdpau-driver/ChangeLog
+++ b/x11-libs/libva-vdpau-driver/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/libva-vdpau-driver
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva-vdpau-driver/ChangeLog,v 1.8 2014/07/15 15:47:32 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva-vdpau-driver/ChangeLog,v 1.9 2014/07/24 15:28:12 ssuominen Exp $
+
+*libva-vdpau-driver-0.7.4-r2 (24 Jul 2014)
+
+ 24 Jul 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +files/libva-vdpau-driver-0.7.4-libvdpau-0.8.patch,
+ +libva-vdpau-driver-0.7.4-r2.ebuild:
+ Fix compability with x11-libs/libvdpau >= 0.8 wrt #517778 by Justin Lecher
15 Jul 2014; Pacho Ramos <pacho@gentoo.org>
libva-vdpau-driver-0.7.4-r1.ebuild:
diff --git a/x11-libs/libva-vdpau-driver/files/libva-vdpau-driver-0.7.4-libvdpau-0.8.patch b/x11-libs/libva-vdpau-driver/files/libva-vdpau-driver-0.7.4-libvdpau-0.8.patch
new file mode 100644
index 000000000000..6d6d47ad0b06
--- /dev/null
+++ b/x11-libs/libva-vdpau-driver/files/libva-vdpau-driver-0.7.4-libvdpau-0.8.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/517778
+
+--- src/vdpau_decode.c
++++ src/vdpau_decode.c
+@@ -1289,7 +1289,7 @@
+ driver_data,
+ obj_context->vdp_decoder,
+ obj_surface->vdp_surface,
+- (VdpPictureInfo)&obj_context->vdp_picture_info,
++ (VdpPictureInfo *)&obj_context->vdp_picture_info,
+ obj_context->vdp_bitstream_buffers_count,
+ obj_context->vdp_bitstream_buffers
+ );
diff --git a/x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r2.ebuild b/x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r2.ebuild
new file mode 100644
index 000000000000..691b425e6bfa
--- /dev/null
+++ b/x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r2.ebuild,v 1.1 2014/07/24 15:28:12 ssuominen Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-multilib eutils
+
+DESCRIPTION="VDPAU Backend for Video Acceleration (VA) API"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
+SRC_URI="http://www.freedesktop.org/software/vaapi/releases/libva-vdpau-driver/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opengl"
+
+RDEPEND=">=x11-libs/libva-1.2.1-r1[X,opengl?,${MULTILIB_USEDEP}]
+ opengl? ( >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}] )
+ >=x11-libs/libvdpau-0.8[${MULTILIB_USEDEP}]
+ !x11-libs/vdpau-video"
+
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+DOCS=( NEWS README AUTHORS )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-glext-missing-definition.patch \
+ "${FILESDIR}"/${P}-VAEncH264VUIBufferType.patch \
+ "${FILESDIR}"/${P}-libvdpau-0.8.patch
+ sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die
+ autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable opengl glx)
+ )
+ autotools-utils_src_configure
+}