summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2005-06-04 12:18:48 +0000
committerCaleb Tennis <caleb@gentoo.org>2005-06-04 12:18:48 +0000
commit8880fcf3aa4032cad26235fcc00c6d7377bc5d57 (patch)
tree18ddf71f5a06343fde9c73ace42806bf2a14548c /x11-libs
parentstable on amd64 wrt #94913 (diff)
downloadgentoo-2-8880fcf3aa4032cad26235fcc00c6d7377bc5d57.tar.gz
gentoo-2-8880fcf3aa4032cad26235fcc00c6d7377bc5d57.tar.bz2
gentoo-2-8880fcf3aa4032cad26235fcc00c6d7377bc5d57.zip
Minor tweaks
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/qt-4.0.0_beta2-r3.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/x11-libs/qt/qt-4.0.0_beta2-r3.ebuild b/x11-libs/qt/qt-4.0.0_beta2-r3.ebuild
index b2547e260d1f..edd562a5d614 100644
--- a/x11-libs/qt/qt-4.0.0_beta2-r3.ebuild
+++ b/x11-libs/qt/qt-4.0.0_beta2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.0.0_beta2-r3.ebuild,v 1.2 2005/06/03 22:36:49 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.0.0_beta2-r3.ebuild,v 1.3 2005/06/04 12:18:48 caleb Exp $
inherit eutils flag-o-matic
@@ -107,8 +107,6 @@ src_compile() {
myconf="${myconf} $(qt_use accessibility) $(qt_use cups) $(qt_use xinerama)"
myconf="${myconf} $(qt_use opengl) $(qt_use nis)"
- [ $(get_libdir) != "lib" ] && myconf="${myconf} -L/usr/$(get_libdir)"
-
use nas && myconf="${myconf} -system-nas-sound"
use gif && myconf="${myconf} -qt-gif" || myconf="${myconf} -no-gif"
use png && myconf="${myconf} -system-libpng" || myconf="${myconf} -qt-libpng"
@@ -131,9 +129,6 @@ src_compile() {
-sysconfdir ${QTSYSCONFDIR} -translationdir ${QTTRANSDIR} ${myconf} || die
emake sub-tools-all-ordered || die
-# if use examples; then
-# emake sub-demos sub-examples sub-tutorial || die
-# fi
}
src_install() {
@@ -172,6 +167,9 @@ src_install() {
sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/pkgconfig/*.pc
sed -i -e "s:${S}:${QTBASEDIR}:g" ${D}/${QTLIBDIR}/pkgconfig/*.pc
+ # Don't need to install stray linguist files
+ rm -rf ${D}/${DATADIR}/phrasebooks/linguist
+
# List all the multilib libdirs
local libdirs
for libdir in $(get_all_libdirs); do