summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2008-12-09 03:33:48 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2008-12-09 03:33:48 +0000
commit872ba489a994164b2cd5f5e49b9320b54532c21d (patch)
treebc49353130b1ed129f167579b0412d4bd58194cf /x11-libs
parent(non maintainer commit) 64 bit fix as presented in bug #188160. Thanks to Ren... (diff)
downloadgentoo-2-872ba489a994164b2cd5f5e49b9320b54532c21d.tar.gz
gentoo-2-872ba489a994164b2cd5f5e49b9320b54532c21d.tar.bz2
gentoo-2-872ba489a994164b2cd5f5e49b9320b54532c21d.zip
Fix ascii null backspace in screen. bug #249618
(Portage version: 2.2_rc17/cvs/Linux 2.6.27-gentoo-r4 x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/vte/ChangeLog8
-rw-r--r--x11-libs/vte/files/vte-0.17.4-no-null-backspace.patch45
-rw-r--r--x11-libs/vte/vte-0.17.4-r3.ebuild54
3 files changed, 106 insertions, 1 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index ad1e6666a7c7..bd779f9a2356 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/vte
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.213 2008/11/13 19:04:24 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.214 2008/12/09 03:33:48 dang Exp $
+
+*vte-0.17.4-r3 (09 Dec 2008)
+
+ 09 Dec 2008; Daniel Gryniewicz <dang@gentoo.org>
+ +files/vte-0.17.4-no-null-backspace.patch, +vte-0.17.4-r3.ebuild:
+ - Fix ascii-null backspace in screen. Bug #249618
13 Nov 2008; Brent Baude <ranger@gentoo.org> vte-0.16.14.ebuild:
Marking vte-0.16.14 ppc64 stable for bug 236971
diff --git a/x11-libs/vte/files/vte-0.17.4-no-null-backspace.patch b/x11-libs/vte/files/vte-0.17.4-no-null-backspace.patch
new file mode 100644
index 000000000000..734e7b530ce4
--- /dev/null
+++ b/x11-libs/vte/files/vte-0.17.4-no-null-backspace.patch
@@ -0,0 +1,45 @@
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN vte-0.17.4.orig/src/vte.c vte-0.17.4/src/vte.c
+--- vte-0.17.4.orig/src/vte.c 2008-09-08 15:48:31.000000000 -0400
++++ vte-0.17.4/src/vte.c 2008-12-08 22:22:38.000000000 -0500
+@@ -4636,6 +4636,7 @@ vte_terminal_key_press(GtkWidget *widget
+
+ /* Now figure out what to send to the child. */
+ if ((event->type == GDK_KEY_PRESS) && !modifier) {
++ cc_t erase = VTE_VDISABLE;
+ handled = FALSE;
+ /* Map the key to a sequence name if we can. */
+ switch (keyval) {
+@@ -4661,11 +4662,15 @@ vte_terminal_key_press(GtkWidget *widget
+ if (terminal->pvt->pty_master != -1) {
+ if (tcgetattr(terminal->pvt->pty_master,
+ &tio) != -1) {
+- normal = g_strdup_printf("%c",
+- tio.c_cc[VERASE]);
+ normal_length = 1;
++ erase = tio.c_cc[VERASE];
+ }
+ }
++ if (erase == VTE_VDISABLE)
++ normal = g_strdup(""); /* Fallback value. */
++ else
++ normal = g_strdup_printf("%c", erase);
++ normal_length = 1;
+ suppress_meta_esc = FALSE;
+ break;
+ }
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN vte-0.17.4.orig/src/vte-private.h vte-0.17.4/src/vte-private.h
+--- vte-0.17.4.orig/src/vte-private.h 2008-09-08 15:48:31.000000000 -0400
++++ vte-0.17.4/src/vte-private.h 2008-12-08 22:22:38.000000000 -0500
+@@ -91,6 +91,12 @@ G_BEGIN_DECLS
+ #define VTE_MAX_PROCESS_TIME 100
+ #define VTE_CELL_BBOX_SLACK 1
+
++#ifdef _POSIX_VDISABLE /* From unistd.h */
++#define VTE_VDISABLE _POSIX_VDISABLE
++#else
++#define VTE_VDISABLE '\0'
++#endif
++
+ /* The structure we use to hold characters we're supposed to display -- this
+ * includes any supported visible attributes. */
+ struct vte_charcell {
diff --git a/x11-libs/vte/vte-0.17.4-r3.ebuild b/x11-libs/vte/vte-0.17.4-r3.ebuild
new file mode 100644
index 000000000000..10328d7a0059
--- /dev/null
+++ b/x11-libs/vte/vte-0.17.4-r3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.17.4-r3.ebuild,v 1.1 2008/12/09 03:33:48 dang Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Gnome terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+# pcre is broken in this release
+IUSE="debug doc python opengl"
+
+RDEPEND=">=dev-libs/glib-2.14
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.1
+ >=media-libs/freetype-2.0.2
+ media-libs/fontconfig
+ sys-libs/ncurses
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )
+ python? (
+ >=dev-python/pygtk-2.4
+ >=dev-lang/python-2.4.4-r5
+ )
+ x11-libs/libX11
+ virtual/xft"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable debug)
+ $(use_enable python)
+ $(use_with opengl glX)
+ --with-xft2 --with-pangox"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+ epatch "${FILESDIR}/${P}-fix-highlighting-on-activity.patch"
+ # Bug #249618
+ epatch "${FILESDIR}/${P}-no-null-backspace.patch"
+}