summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-12-31 21:34:02 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-12-31 21:34:02 +0000
commit8610c3106473293fbf1512b080fb3fb57148ee91 (patch)
treedd0a80e9206ee08c9f116ba42847a5f52cb60c64 /x11-libs
parentStable on ppc64; bug #158907 (diff)
downloadgentoo-2-8610c3106473293fbf1512b080fb3fb57148ee91.tar.gz
gentoo-2-8610c3106473293fbf1512b080fb3fb57148ee91.tar.bz2
gentoo-2-8610c3106473293fbf1512b080fb3fb57148ee91.zip
Adding cairo 1.3 snapshot. Including xcb via xcb USE flag
(Portage version: 2.1.2_rc4-r2)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/cairo/ChangeLog7
-rw-r--r--x11-libs/cairo/cairo-1.3.10.ebuild65
-rw-r--r--x11-libs/cairo/files/digest-cairo-1.3.103
3 files changed, 74 insertions, 1 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index 2a3b934351ec..899123f1cdb0 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/cairo
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.92 2006/12/07 03:30:17 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.93 2006/12/31 21:34:02 cardoe Exp $
+
+*cairo-1.3.10 (31 Dec 2006)
+
+ 31 Dec 2006; Doug Goldstein <cardoe@gentoo.org> +cairo-1.3.10.ebuild:
+ Adding cairo 1.3 snapshot. Including xcb via xcb USE flag
07 Dec 2006; Doug Goldstein <cardoe@gentoo.org> cairo-1.2.4.ebuild,
cairo-1.2.6.ebuild, -cairo-1.2.2.ebuild:
diff --git a/x11-libs/cairo/cairo-1.3.10.ebuild b/x11-libs/cairo/cairo-1.3.10.ebuild
new file mode 100644
index 000000000000..c9516b467843
--- /dev/null
+++ b/x11-libs/cairo/cairo-1.3.10.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.3.10.ebuild,v 1.1 2006/12/31 21:34:02 cardoe Exp $
+
+inherit eutils flag-o-matic debug
+
+DESCRIPTION="A vector graphics library with cross-device output support"
+HOMEPAGE="http://cairographics.org/"
+SRC_URI="http://cairographics.org/snapshots/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="directfb doc glitz png svg X xcb"
+
+# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
+RESTRICT="test"
+
+RDEPEND="media-libs/fontconfig
+ >=media-libs/freetype-2.1.4
+ media-libs/libpng
+ X? (
+ x11-libs/libXrender
+ x11-libs/libXext
+ x11-libs/libX11
+ virtual/xft
+ xcb? ( x11-libs/libxcb
+ x11-libs/xcb-util )
+ )
+ directfb? ( >=dev-libs/DirectFB-0.9.24 )
+ glitz? ( >=media-libs/glitz-0.5.1 )
+ svg? ( dev-libs/libxml2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.19
+ X? ( x11-proto/renderproto
+ xcb? ( x11-proto/xcb-proto ) )
+ doc? (
+ >=dev-util/gtk-doc-1.3
+ ~app-text/docbook-xml-dtd-4.2
+ )"
+
+src_compile() {
+ #gets rid of fbmmx.c inlining warnings
+ append-flags -finline-limit=1200
+
+ econf $(use_enable X xlib) $(use_enable doc gtk-doc) $(use_enable directfb) \
+ $(use_enable debug) $(use_enable svg) --enable-pdf \
+ $(use_enable glitz) --enable-png --enable-freetype --enable-ps \
+ $(use_enable xcb) \
+ || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ echo
+ ewarn "You will most likely need to run revdep-rebuild after emerging this"
+ echo
+}
diff --git a/x11-libs/cairo/files/digest-cairo-1.3.10 b/x11-libs/cairo/files/digest-cairo-1.3.10
new file mode 100644
index 000000000000..61b82abd538e
--- /dev/null
+++ b/x11-libs/cairo/files/digest-cairo-1.3.10
@@ -0,0 +1,3 @@
+MD5 78e1c1c57568f51e4da73f52cf57eadb cairo-1.3.10.tar.gz 2787973
+RMD160 eb40963c760be2e2c8f9dc743cf205c69136b399 cairo-1.3.10.tar.gz 2787973
+SHA256 2ed48e592c36bf3a2581cd9935bbe2d9cb6c4d6dbb91b794fb76c632ea1f3b98 cairo-1.3.10.tar.gz 2787973