summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2011-11-28 23:55:02 +0000
committerDavide Pesavento <pesa@gentoo.org>2011-11-28 23:55:02 +0000
commit83b8d4801b32e90b31b74b44792e35d4196e4d47 (patch)
tree0356a7a743b1dd0a51b4416879eb1abb72453609 /x11-libs
parentRemove Qt 4.7.3 (diff)
downloadgentoo-2-83b8d4801b32e90b31b74b44792e35d4196e4d47.tar.gz
gentoo-2-83b8d4801b32e90b31b74b44792e35d4196e4d47.tar.bz2
gentoo-2-83b8d4801b32e90b31b74b44792e35d4196e4d47.zip
Remove Qt 4.7.3
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-webkit/ChangeLog7
-rw-r--r--x11-libs/qt-webkit/files/30_webkit_unaligned_access.diff127
-rw-r--r--x11-libs/qt-webkit/files/qt-webkit-4.5.3-no-javascript-crash.patch23
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.7.3.ebuild49
4 files changed, 6 insertions, 200 deletions
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index 86b2c12685e4..e66009ab79a7 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-webkit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.125 2011/11/26 20:05:14 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.126 2011/11/28 23:55:02 pesa Exp $
+
+ 28 Nov 2011; Davide Pesavento <pesa@gentoo.org>
+ -files/30_webkit_unaligned_access.diff,
+ -files/qt-webkit-4.5.3-no-javascript-crash.patch, -qt-webkit-4.7.3.ebuild:
+ Remove Qt 4.7.3
26 Nov 2011; Robin H. Johnson <robbat2@gentoo.org> Manifest:
Bug 385719: upstream altered qt-everywhere-opensource-src-4.7.4.tar.gz, mass
diff --git a/x11-libs/qt-webkit/files/30_webkit_unaligned_access.diff b/x11-libs/qt-webkit/files/30_webkit_unaligned_access.diff
deleted file mode 100644
index 57cb5a73ba9e..000000000000
--- a/x11-libs/qt-webkit/files/30_webkit_unaligned_access.diff
+++ /dev/null
@@ -1,127 +0,0 @@
-From: Mike Hommey <glandium@debian.org>
-Date: Sun, 6 Jul 2008 08:37:28 +0000 (+0200)
-Subject: Fixed some alignment problems on sparc
-X-Git-Tag: debian/1.0.1-1~7
-X-Git-Url: http://git.debian.org/?p=pkg-webkit%2Fwebkit.git;a=commitdiff_plain;h=11c220f6d31898a7a1dfafd5d96619fefe6ba597;hp=1db04c3a5c8c3e9c990b93836d5bb09d43a47921
-
-Fixed some alignment problems on sparc
-
-(and some that might occur on arm, too).
-
-Some compiler warnings about alignment remain, but I don't know if they are
-a real problem yet.
----
-
---- a/src/3rdparty/webkit/JavaScriptCore/wtf/FastMalloc.cpp
-+++ b/src/3rdparty/webkit/JavaScriptCore/wtf/FastMalloc.cpp
-@@ -1936,13 +1936,13 @@ static TCMalloc_Central_FreeListPadded c
-
- // Page-level allocator
- static SpinLock pageheap_lock = SPINLOCK_INITIALIZER;
--static void* pageheap_memory[(sizeof(TCMalloc_PageHeap) + sizeof(void*) - 1) / sizeof(void*)];
-+static uint64_t pageheap_memory[(sizeof(TCMalloc_PageHeap) + sizeof(uint64_t) - 1) / sizeof(uint64_t)];
- static bool phinited = false;
-
- // Avoid extra level of indirection by making "pageheap" be just an alias
- // of pageheap_memory.
- typedef union {
-- void* m_memory;
-+ uint64_t* m_memory;
- TCMalloc_PageHeap* m_pageHeap;
- } PageHeapUnion;
-
---- a/src/3rdparty/webkit/JavaScriptCore/wtf/ListHashSet.h
-+++ b/src/3rdparty/webkit/JavaScriptCore/wtf/ListHashSet.h
-@@ -127,7 +127,7 @@ namespace WTF {
- : m_freeList(pool())
- , m_isDoneWithInitialFreeList(false)
- {
-- memset(m_pool.pool, 0, sizeof(m_pool.pool));
-+ memset(m_pool, 0, sizeof(m_pool));
- }
-
- Node* allocate()
-@@ -171,7 +171,7 @@ namespace WTF {
- }
-
- private:
-- Node* pool() { return reinterpret_cast<Node*>(m_pool.pool); }
-+ Node* pool() { return reinterpret_cast<Node*>(m_pool); }
- Node* pastPool() { return pool() + m_poolSize; }
-
- bool inPool(Node* node)
-@@ -182,10 +182,7 @@ namespace WTF {
- Node* m_freeList;
- bool m_isDoneWithInitialFreeList;
- static const size_t m_poolSize = 256;
-- union {
-- char pool[sizeof(Node) * m_poolSize];
-- double forAlignment;
-- } m_pool;
-+ uint32_t m_pool[(sizeof(Node) * m_poolSize + sizeof(uint32_t) - 1) / sizeof(uint32_t)];
- };
-
- template<typename ValueArg> struct ListHashSetNode {
---- a/src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h
-+++ b/src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h
-@@ -233,6 +233,23 @@
- # endif
- #endif
-
-+/* PLATFORM(SPARC) */
-+#if defined(__sparc__) \
-+ || defined(__sparc)
-+#define WTF_PLATFORM_SPARC 1
-+#define WTF_PLATFORM_BIG_ENDIAN 1
-+#endif
-+
-+/* For undefined platforms */
-+#if !defined(WTF_PLATFORM_BIG_ENDIAN) && !defined(WTF_PLATFORM_MIDDLE_ENDIAN)
-+#include <sys/param.h>
-+#if __BYTE_ORDER == __BIG_ENDIAN
-+#define WTF_PLATFORM_BIG_ENDIAN 1
-+#elif __BYTE_ORDER == __PDP_ENDIAN
-+#define WTF_PLATFORM_MIDDLE_ENDIAN 1
-+#endif
-+#endif
-+
- /* Compiler */
-
- /* COMPILER(MSVC) */
---- a/src/3rdparty/webkit/WebCore/platform/text/AtomicString.cpp
-+++ b/src/3rdparty/webkit/WebCore/platform/text/AtomicString.cpp
-@@ -101,7 +101,7 @@ static inline bool equal(StringImpl* str
- if (string->length() != length)
- return false;
-
--#if PLATFORM(ARM)
-+#if PLATFORM(ARM) || PLATFORM(SPARC)
- const UChar* stringCharacters = string->characters();
- for (unsigned i = 0; i != length; ++i) {
- if (*stringCharacters++ != *characters++)
---- a/src/3rdparty/webkit/WebCore/platform/text/StringHash.h
-+++ b/src/3rdparty/webkit/WebCore/platform/text/StringHash.h
-@@ -47,6 +47,15 @@ namespace WebCore {
- if (aLength != bLength)
- return false;
-
-+#if PLATFORM(ARM) || PLATFORM(SPARC)
-+ const UChar* aChars = a->characters();
-+ const UChar* bChars = b->characters();
-+ for (unsigned i = 0; i != aLength; ++i)
-+ if (*aChars++ != *bChars++)
-+ return false;
-+
-+ return true;
-+#else
- const uint32_t* aChars = reinterpret_cast<const uint32_t*>(a->characters());
- const uint32_t* bChars = reinterpret_cast<const uint32_t*>(b->characters());
-
-@@ -59,6 +68,7 @@ namespace WebCore {
- return false;
-
- return true;
-+#endif
- }
-
- static unsigned hash(const RefPtr<StringImpl>& key) { return key->hash(); }
diff --git a/x11-libs/qt-webkit/files/qt-webkit-4.5.3-no-javascript-crash.patch b/x11-libs/qt-webkit/files/qt-webkit-4.5.3-no-javascript-crash.patch
deleted file mode 100644
index b5a9b01bf140..000000000000
--- a/x11-libs/qt-webkit/files/qt-webkit-4.5.3-no-javascript-crash.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/src/3rdparty/webkit/WebKit/qt/Api/qwebframe.cpp
-+++ b/src/3rdparty/webkit/WebKit/qt/Api/qwebframe.cpp
-@@ -317,4 +317,6 @@
- javaScriptWindowObjectCleared() signal.
-
-+ If Javascript is not enabled for this page, then this method does nothing.
-+
- The \a object will never be explicitly deleted by QtWebKit.
- */
-@@ -339,8 +341,13 @@
- javaScriptWindowObjectCleared() signal.
-
-+ If Javascript is not enabled for this page, then this method does nothing.
-+
- The ownership of \a object is specified using \a own.
- */
- void QWebFrame::addToJavaScriptWindowObject(const QString &name, QObject *object, QScriptEngine::ValueOwnership ownership)
- {
-+ if (!page()->settings()->testAttribute(QWebSettings::JavascriptEnabled))
-+ return;
-+
- JSC::JSLock lock(false);
- JSDOMWindow* window = toJSDOMWindow(d->frame);
diff --git a/x11-libs/qt-webkit/qt-webkit-4.7.3.ebuild b/x11-libs/qt-webkit/qt-webkit-4.7.3.ebuild
deleted file mode 100644
index 840e62bfbdd6..000000000000
--- a/x11-libs/qt-webkit/qt-webkit-4.7.3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.7.3.ebuild,v 1.1 2011/05/10 20:09:22 tampakrap Exp $
-
-EAPI="3"
-inherit qt4-build
-
-DESCRIPTION="The Webkit module for the Qt toolkit"
-SLOT="4"
-KEYWORDS="~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="dbus +jit kde"
-
-DEPEND="
- dev-db/sqlite:3
- ~x11-libs/qt-core-${PV}[aqua=,debug=,ssl]
- ~x11-libs/qt-gui-${PV}[aqua=,dbus?,debug=]
- ~x11-libs/qt-xmlpatterns-${PV}[aqua=,debug=]
- dbus? ( ~x11-libs/qt-dbus-${PV}[aqua=,debug=] )
- !kde? ( || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[aqua=,dbus=,debug=]
- media-libs/phonon[aqua=] ) )
- kde? ( || ( media-libs/phonon[aqua=] ~x11-libs/qt-phonon-${PV}:${SLOT}[aqua=,dbus=,debug] ) )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- QT4_TARGET_DIRECTORIES="
- src/3rdparty/webkit/JavaScriptCore
- src/3rdparty/webkit/WebCore
- tools/designer/src/plugins/qwebview"
- QT4_EXTRACT_DIRECTORIES="
- include/
- src/
- tools/"
-
- QCONFIG_ADD="webkit"
- QCONFIG_DEFINE="QT_WEBKIT"
-
- qt4-build_pkg_setup
-}
-
-src_prepare() {
- [[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
-
- qt4-build_src_prepare
-}
-
-src_configure() {
- myconf="${myconf} -webkit -system-sqlite $(qt_use jit javascript-jit) $(qt_use dbus qdbus)"
- qt4-build_src_configure
-}