summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-11-12 10:54:24 +0000
committerMart Raudsepp <leio@gentoo.org>2008-11-12 10:54:24 +0000
commit79c37cfb46690a4a792a2a5f66c406cb1150929a (patch)
tree4d534f60caa17ddc5ff9492b184d581760012b9e /x11-libs
parentMention fixing of bug #243802 in the ChangeLog. (diff)
downloadgentoo-2-79c37cfb46690a4a792a2a5f66c406cb1150929a.tar.gz
gentoo-2-79c37cfb46690a4a792a2a5f66c406cb1150929a.tar.bz2
gentoo-2-79c37cfb46690a4a792a2a5f66c406cb1150929a.zip
Fix a QA warning regarding use_enable debug and missing IUSE=debug by removing it as it would do nothing useful that our CFLAGS can't do anyway, bug 246214
(Portage version: 2.2_rc13/cvs/Linux 2.6.27-gentoo-r1 x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtkmathview/ChangeLog7
-rw-r--r--x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild27
2 files changed, 19 insertions, 15 deletions
diff --git a/x11-libs/gtkmathview/ChangeLog b/x11-libs/gtkmathview/ChangeLog
index 96c8aa74cae4..a94500652d95 100644
--- a/x11-libs/gtkmathview/ChangeLog
+++ b/x11-libs/gtkmathview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/gtkmathview
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmathview/ChangeLog,v 1.30 2008/11/08 17:26:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmathview/ChangeLog,v 1.31 2008/11/12 10:54:24 leio Exp $
+
+ 12 Nov 2008; Mart Raudsepp <leio@gentoo.org> gtkmathview-0.8.0.ebuild:
+ Fix a QA warning regarding use_enable debug and missing IUSE=debug by
+ removing it as it would do nothing useful that our CFLAGS can't do anyway,
+ bug 246214
08 Nov 2008; Raúl Porcel <armin76@gentoo.org> gtkmathview-0.8.0.ebuild:
alpha/ia64/sparc stable wrt #245303
diff --git a/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild b/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild
index bf2279b72809..bd58878d4e70 100644
--- a/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild
+++ b/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild,v 1.6 2008/11/08 17:26:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild,v 1.7 2008/11/12 10:54:24 leio Exp $
inherit eutils
@@ -38,19 +38,18 @@ src_unpack() {
src_compile() {
# --disable-popt will build only the library and not the frontend
# TFM is needed for SVG, default value is 2
- econf $(use_enable debug) \
- $(use_enable gtk) $(use_enable gtk gmetadom) \
- $(use_enable svg) \
- $(use_with t1lib) \
- --enable-popt \
- --enable-libxml2 \
- --enable-libxml2-reader \
- --enable-ps \
- --enable-tfm=2 \
- --enable-builder-cache \
- --enable-breaks \
- --enable-boxml \
- || die "configure failed"
+ econf $(use_enable gtk) $(use_enable gtk gmetadom) \
+ $(use_enable svg) \
+ $(use_with t1lib) \
+ --enable-popt \
+ --enable-libxml2 \
+ --enable-libxml2-reader \
+ --enable-ps \
+ --enable-tfm=2 \
+ --enable-builder-cache \
+ --enable-breaks \
+ --enable-boxml \
+ || die "configure failed"
emake || die "make failed"
}