summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-06-11 21:29:51 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-06-11 21:29:51 +0000
commit71ae181db305fccd81a1f721e34543be3b4323ba (patch)
tree7145760c04f8c918ffa6f8b7dba1886250fa6107 /x11-libs
parentupdated gnome2 eclass to use debug eclass (diff)
downloadgentoo-2-71ae181db305fccd81a1f721e34543be3b4323ba.tar.gz
gentoo-2-71ae181db305fccd81a1f721e34543be3b4323ba.tar.bz2
gentoo-2-71ae181db305fccd81a1f721e34543be3b4323ba.zip
new libzvt version that uses libtool and debug eclassess
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libzvt/files/digest-libzvt-1.99999.01
-rw-r--r--x11-libs/libzvt/libzvt-1.99999.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-libs/libzvt/files/digest-libzvt-1.99999.0 b/x11-libs/libzvt/files/digest-libzvt-1.99999.0
new file mode 100644
index 000000000000..5ec3a8b347b1
--- /dev/null
+++ b/x11-libs/libzvt/files/digest-libzvt-1.99999.0
@@ -0,0 +1 @@
+MD5 a4485c3091e0c23b81184bc224a6dbb1 libzvt-1.99999.0.tar.bz2 251186
diff --git a/x11-libs/libzvt/libzvt-1.99999.0.ebuild b/x11-libs/libzvt/libzvt-1.99999.0.ebuild
new file mode 100644
index 000000000000..46860aa67182
--- /dev/null
+++ b/x11-libs/libzvt/libzvt-1.99999.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libzvt/libzvt-1.99999.0.ebuild,v 1.1 2002/06/11 21:29:51 spider Exp $
+
+inherit debug
+inherit libtool
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Zed's Virtual Terminal Library"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/libzvt/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+
+RDEPEND=">=dev-libs/glib-2.0.0
+ >=x11-libs/gtk+-2.0.0
+ >=media-libs/libart_lgpl-2.3.8-r1"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+
+src_compile() {
+ elibtoolize
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --enable-debug=yes || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc ABOUT* AUTHORS COPY* ChangeLog INSTALL NEWS README
+ docinto libzvt
+ dodoc libzvt/AUTHORS libzvt/BUGS libzvt/README libzvt/TODO
+}
+
+
+
+
+