summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-03-03 15:54:12 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-03-03 15:54:12 +0000
commit68b6cd56bfe80d3f369a06865cfdd28f9e673aab (patch)
treee74fe132cc5138d3e999e2810c253be418f87724 /x11-libs
parentBumping the .19 series to its latest stable release (2.6.19.7). (diff)
downloadgentoo-2-68b6cd56bfe80d3f369a06865cfdd28f9e673aab.tar.gz
gentoo-2-68b6cd56bfe80d3f369a06865cfdd28f9e673aab.tar.bz2
gentoo-2-68b6cd56bfe80d3f369a06865cfdd28f9e673aab.zip
rev bump to 1.4.0 release candidate
(Portage version: 2.1.2-r12)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/cairo/ChangeLog7
-rw-r--r--x11-libs/cairo/cairo-1.3.16.ebuild67
-rw-r--r--x11-libs/cairo/files/digest-cairo-1.3.163
3 files changed, 76 insertions, 1 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index 1034709953bd..b469aad0becd 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/cairo
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.107 2007/02/22 00:30:22 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.108 2007/03/03 15:54:12 cardoe Exp $
+
+*cairo-1.3.16 (03 Mar 2007)
+
+ 03 Mar 2007; Doug Goldstein <cardoe@gentoo.org> +cairo-1.3.16.ebuild:
+ rev bump to 1.4.0 release candidate
22 Feb 2007; Jason Wever <weeve@gentoo.org> cairo-1.2.6.ebuild:
Stable on SPARC wrt bug #167573.
diff --git a/x11-libs/cairo/cairo-1.3.16.ebuild b/x11-libs/cairo/cairo-1.3.16.ebuild
new file mode 100644
index 000000000000..7bd239599fec
--- /dev/null
+++ b/x11-libs/cairo/cairo-1.3.16.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.3.16.ebuild,v 1.1 2007/03/03 15:54:12 cardoe Exp $
+
+inherit eutils flag-o-matic libtool
+
+DESCRIPTION="A vector graphics library with cross-device output support"
+HOMEPAGE="http://cairographics.org/"
+SRC_URI="http://cairographics.org/snapshots/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug directfb doc glitz svg X xcb"
+
+# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
+RESTRICT="test"
+
+RDEPEND="media-libs/fontconfig
+ >=media-libs/freetype-2.1.4
+ media-libs/libpng
+ X? (
+ x11-libs/libXrender
+ x11-libs/libXext
+ x11-libs/libX11
+ virtual/xft
+ xcb? ( x11-libs/libxcb
+ x11-libs/xcb-util )
+ )
+ directfb? ( >=dev-libs/DirectFB-0.9.24 )
+ glitz? ( >=media-libs/glitz-0.5.1 )
+ svg? ( dev-libs/libxml2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.19
+ X? ( x11-proto/renderproto
+ xcb? ( x11-proto/xcb-proto ) )
+ doc? (
+ >=dev-util/gtk-doc-1.3
+ ~app-text/docbook-xml-dtd-4.2
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # We need to run elibtoolize to ensure correct so versioning on FreeBSD
+ elibtoolize
+}
+
+src_compile() {
+ #gets rid of fbmmx.c inlining warnings
+ append-flags -finline-limit=1200
+
+ econf $(use_enable X xlib) $(use_enable doc gtk-doc) $(use_enable directfb) \
+ $(use_enable svg) $(use_enable glitz) \
+ $(use_enable debug test-surfaces) --enable-pdf --enable-png \
+ --enable-freetype --enable-ps $(use_enable xcb) \
+ || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/x11-libs/cairo/files/digest-cairo-1.3.16 b/x11-libs/cairo/files/digest-cairo-1.3.16
new file mode 100644
index 000000000000..8aeb731171b3
--- /dev/null
+++ b/x11-libs/cairo/files/digest-cairo-1.3.16
@@ -0,0 +1,3 @@
+MD5 149a8006181a07c1447559058a3750df cairo-1.3.16.tar.gz 4156967
+RMD160 23ae73ad7f7e9548cacb9ec7d0f735cb4d081d67 cairo-1.3.16.tar.gz 4156967
+SHA256 8120b653e6f298ca2508ba8a82448e9b8a0b2a598a50d9db4184548e36781d1b cairo-1.3.16.tar.gz 4156967