summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-04-20 21:06:05 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-04-20 21:06:05 +0000
commit680fa019c280567af5235d84caa2811633ba6888 (patch)
tree8b4faf2297ffa0bd423b8dbbaabf371331f5e966 /x11-libs
parentInclude missing inherit, bug #315187 (diff)
downloadgentoo-2-680fa019c280567af5235d84caa2811633ba6888.tar.gz
gentoo-2-680fa019c280567af5235d84caa2811633ba6888.tar.bz2
gentoo-2-680fa019c280567af5235d84caa2811633ba6888.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libxcb/ChangeLog8
-rw-r--r--x11-libs/libxcb/libxcb-1.6.ebuild31
2 files changed, 38 insertions, 1 deletions
diff --git a/x11-libs/libxcb/ChangeLog b/x11-libs/libxcb/ChangeLog
index d66f9706a678..d181e6a5898f 100644
--- a/x11-libs/libxcb/ChangeLog
+++ b/x11-libs/libxcb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libxcb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.56 2010/04/18 20:40:40 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.57 2010/04/20 21:06:05 chithanh Exp $
+
+*libxcb-1.6 (20 Apr 2010)
+
+ 20 Apr 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +libxcb-1.6.ebuild:
+ Version bump.
18 Apr 2010; Markus Meier <maekke@gentoo.org> libxcb-1.5.ebuild:
arm stable, bug #308521
diff --git a/x11-libs/libxcb/libxcb-1.6.ebuild b/x11-libs/libxcb/libxcb-1.6.ebuild
new file mode 100644
index 000000000000..71a760a64b71
--- /dev/null
+++ b/x11-libs/libxcb/libxcb-1.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.6.ebuild,v 1.1 2010/04/20 21:06:05 chithanh Exp $
+
+EAPI=3
+inherit xorg-2
+
+DESCRIPTION="X C-language Bindings library"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/libxcb"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc selinux"
+
+RDEPEND="x11-libs/libXau
+ x11-libs/libXdmcp
+ dev-libs/libpthread-stubs"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-libs/libxslt
+ >=x11-proto/xcb-proto-1.6
+ >=dev-lang/python-2.5[xml]"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+ CONFIGURE_OPTIONS="$(use_enable doc build-docs)
+ $(use_enable selinux)
+ --enable-xinput"
+}