summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-09-09 18:23:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-09-09 18:23:59 +0000
commit5c00c44932ab7ee4636e8a6985ec36e3d1c79cfe (patch)
treef4a89acf568239115e710f4e935ab817e0619e3e /x11-libs
parentMarking libIDL-0.8.14 ppc64 for bug 329963 (diff)
downloadgentoo-2-5c00c44932ab7ee4636e8a6985ec36e3d1c79cfe.tar.gz
gentoo-2-5c00c44932ab7ee4636e8a6985ec36e3d1c79cfe.tar.bz2
gentoo-2-5c00c44932ab7ee4636e8a6985ec36e3d1c79cfe.zip
Version bump wrt #336631 by "hal".
(Portage version: 2.2_rc78/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libvdpau/ChangeLog8
-rw-r--r--x11-libs/libvdpau/libvdpau-0.4.1.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/x11-libs/libvdpau/ChangeLog b/x11-libs/libvdpau/ChangeLog
index 1056c19a99db..5252a6588fe6 100644
--- a/x11-libs/libvdpau/ChangeLog
+++ b/x11-libs/libvdpau/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libvdpau
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libvdpau/ChangeLog,v 1.12 2010/07/07 12:24:27 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libvdpau/ChangeLog,v 1.13 2010/09/09 18:23:59 ssuominen Exp $
+
+*libvdpau-0.4.1 (09 Sep 2010)
+
+ 09 Sep 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +libvdpau-0.4.1.ebuild:
+ Version bump wrt #336631 by "hal".
07 Jul 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> libvdpau-0.4.ebuild:
x86 stable wrt bug #299395
diff --git a/x11-libs/libvdpau/libvdpau-0.4.1.ebuild b/x11-libs/libvdpau/libvdpau-0.4.1.ebuild
new file mode 100644
index 000000000000..f5cf96a37f26
--- /dev/null
+++ b/x11-libs/libvdpau/libvdpau-0.4.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libvdpau/libvdpau-0.4.1.ebuild,v 1.1 2010/09/09 18:23:59 ssuominen Exp $
+
+EAPI=2
+inherit multilib
+
+DESCRIPTION="VDPAU wrapper and trace libraries"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/VDPAU"
+SRC_URI="http://people.freedesktop.org/~aplattner/vdpau/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="doc"
+
+#unfortunately, there's driver versions in between that this works with
+RDEPEND="x11-libs/libX11
+ !=x11-drivers/nvidia-drivers-180.29
+ !=x11-drivers/nvidia-drivers-180.60
+ !=x11-drivers/nvidia-drivers-185.18.14
+ !=x11-drivers/nvidia-drivers-185.18.29
+ !=x11-drivers/nvidia-drivers-185.18.31
+ !=x11-drivers/nvidia-drivers-185.18.36
+ !=x11-drivers/nvidia-drivers-190.18
+ !=x11-drivers/nvidia-drivers-190.25
+ !=x11-drivers/nvidia-drivers-190.32
+ !=x11-drivers/nvidia-drivers-190.36
+ !=x11-drivers/nvidia-drivers-190.40"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xproto
+ doc? ( app-doc/doxygen
+ media-gfx/graphviz
+ dev-tex/pdftex )"
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-dependency-tracking \
+ --with-module-dir=/usr/$(get_libdir)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog
+}