summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-03-19 16:17:27 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-03-19 16:17:27 +0000
commit510ce04a3379a1281e694d042e5d43965f66ce81 (patch)
treeeff2c17e4dbfeea84423f9472f10e97619923805 /x11-libs
parentRemove flawed USE="symlink" logic for /usr/bin/notify-send and convert to app... (diff)
downloadgentoo-2-510ce04a3379a1281e694d042e5d43965f66ce81.tar.gz
gentoo-2-510ce04a3379a1281e694d042e5d43965f66ce81.tar.bz2
gentoo-2-510ce04a3379a1281e694d042e5d43965f66ce81.zip
Remove flawed USE="symlink" logic for /usr/bin/notify-send and convert to app-admin/eselect-notify-send wrt #379941 by Michał Górny
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libnotify/ChangeLog9
-rw-r--r--x11-libs/libnotify/libnotify-0.7.5-r1.ebuild64
2 files changed, 72 insertions, 1 deletions
diff --git a/x11-libs/libnotify/ChangeLog b/x11-libs/libnotify/ChangeLog
index eb4ebca2aa5d..3506705f8c3c 100644
--- a/x11-libs/libnotify/ChangeLog
+++ b/x11-libs/libnotify/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/libnotify
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/ChangeLog,v 1.92 2013/03/19 15:47:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/ChangeLog,v 1.93 2013/03/19 16:17:27 ssuominen Exp $
+
+*libnotify-0.7.5-r1 (19 Mar 2013)
+
+ 19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +libnotify-0.7.5-r1.ebuild:
+ Remove flawed USE="symlink" logic for /usr/bin/notify-send and convert to
+ app-admin/eselect-notify-send wrt #379941 by Michał Górny
19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> libnotify-0.7.5.ebuild:
Use new EAPI to gain --disable-silent-rules for econf wrt #462320 by Agostino
diff --git a/x11-libs/libnotify/libnotify-0.7.5-r1.ebuild b/x11-libs/libnotify/libnotify-0.7.5-r1.ebuild
new file mode 100644
index 000000000000..a71e7910afa8
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.7.5-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/libnotify-0.7.5-r1.ebuild,v 1.1 2013/03/19 16:17:27 ssuominen Exp $
+
+EAPI=5
+inherit autotools gnome.org
+
+DESCRIPTION="A library for sending desktop notifications"
+HOMEPAGE="http://git.gnome.org/browse/libnotify"
+SRC_URI="${SRC_URI}
+ http://dev.gentoo.org/~ssuominen/introspection-1.34.2.m4.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc +introspection test"
+
+RDEPEND="app-admin/eselect-notify-send
+ >=dev-libs/glib-2.26
+ x11-libs/gdk-pixbuf:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12 )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.14 )
+ test? ( x11-libs/gtk+:3 )"
+PDEPEND="virtual/notification-daemon"
+
+DOCS=( AUTHORS ChangeLog NEWS )
+
+src_prepare() {
+ sed -i -e 's:noinst_PROG:check_PROG:' tests/Makefile.am || die
+
+ if ! use test; then
+ sed -i -e '/PKG_CHECK_MODULES(TESTS/d' configure.ac || die
+ fi
+
+ if ! has_version dev-libs/gobject-introspection; then
+ mv -f "${WORKDIR}"/introspection-1.34.2.m4 m4/introspection.m4 || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable introspection)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ mv "${ED}"/usr/bin/{,libnotify-}notify-send #379941
+}
+
+pkg_postinst() {
+ eselect notify-send update ifunset
+}
+
+pkg_postrm() {
+ eselect notify-send update ifunset
+}