summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-12-05 03:42:20 +0000
committerBen de Groot <yngwin@gentoo.org>2012-12-05 03:42:20 +0000
commit4fbfc1c867783686203345a453a913d0b4487200 (patch)
treee4d8af84820b287bb7ee2b250a5b2e173a9cad1d /x11-libs
parentQt 4.8.4 version bump (diff)
downloadgentoo-2-4fbfc1c867783686203345a453a913d0b4487200.tar.gz
gentoo-2-4fbfc1c867783686203345a453a913d0b4487200.tar.bz2
gentoo-2-4fbfc1c867783686203345a453a913d0b4487200.zip
Qt 4.8.4 version bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-svg/ChangeLog7
-rw-r--r--x11-libs/qt-svg/qt-svg-4.8.4.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/x11-libs/qt-svg/ChangeLog b/x11-libs/qt-svg/ChangeLog
index d7a7dbb84720..bdc7777a958b 100644
--- a/x11-libs/qt-svg/ChangeLog
+++ b/x11-libs/qt-svg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-svg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.124 2012/10/14 17:21:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.125 2012/12/05 03:42:20 yngwin Exp $
+
+*qt-svg-4.8.4 (05 Dec 2012)
+
+ 05 Dec 2012; Ben de Groot <yngwin@gentoo.org> +qt-svg-4.8.4.ebuild:
+ Qt 4.8.4 version bump
14 Oct 2012; Raúl Porcel <armin76@gentoo.org> qt-svg-4.8.2.ebuild:
alpha/ia64/sparc stable wrt #424625
diff --git a/x11-libs/qt-svg/qt-svg-4.8.4.ebuild b/x11-libs/qt-svg/qt-svg-4.8.4.ebuild
new file mode 100644
index 000000000000..135fda66af67
--- /dev/null
+++ b/x11-libs/qt-svg/qt-svg-4.8.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.8.4.ebuild,v 1.1 2012/12/05 03:42:20 yngwin Exp $
+
+EAPI=4
+
+inherit qt4-build
+
+DESCRIPTION="The SVG module for the Qt toolkit"
+SLOT="4"
+if [[ ${QT4_BUILD_TYPE} == live ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+IUSE="+accessibility"
+
+DEPEND="
+ sys-libs/zlib
+ ~x11-libs/qt-core-${PV}[aqua=,debug=]
+ ~x11-libs/qt-gui-${PV}[accessibility=,aqua=,debug=]
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/svg
+ src/plugins/imageformats/svg
+ src/plugins/iconengines/svgiconengine"
+
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/QtSvg
+ include/Qt
+ include/QtGui
+ include/QtCore
+ include/QtXml
+ src/corelib
+ src/gui
+ src/plugins
+ src/xml
+ src/3rdparty"
+
+ QCONFIG_ADD="svg"
+ QCONFIG_DEFINE="QT_SVG"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf+="
+ -svg
+ $(qt_use accessibility)
+ -no-xkb -no-xrender
+ -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
+ -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
+ -no-fontconfig -no-glib -no-gtkstyle"
+
+ qt4-build_src_configure
+}