summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-01 04:14:59 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-01 04:14:59 +0000
commit4ee30848d00c0dea8877773f95a912e56d2d8d36 (patch)
tree0ef9b05534436720b4b77a540fe5d52a16a041f9 /x11-libs
parentinitial commit - ebuild submitted by Matija Suklje via bug #93056 (diff)
downloadgentoo-2-4ee30848d00c0dea8877773f95a912e56d2d8d36.tar.gz
gentoo-2-4ee30848d00c0dea8877773f95a912e56d2d8d36.tar.bz2
gentoo-2-4ee30848d00c0dea8877773f95a912e56d2d8d36.zip
Fix bogus version warnings with patch from upstream CVS #94479 by Alexander Jenisch.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libast/ChangeLog9
-rw-r--r--x11-libs/libast/files/digest-libast-0.6.1-r11
-rw-r--r--x11-libs/libast/files/libast-0.6.1-config-warning.patch150
-rw-r--r--x11-libs/libast/libast-0.6.1-r1.ebuild41
4 files changed, 200 insertions, 1 deletions
diff --git a/x11-libs/libast/ChangeLog b/x11-libs/libast/ChangeLog
index 6fcff6d305e6..cb1d9969a9c3 100644
--- a/x11-libs/libast/ChangeLog
+++ b/x11-libs/libast/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/libast
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/ChangeLog,v 1.16 2005/04/18 23:52:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/ChangeLog,v 1.17 2005/06/01 04:14:59 vapier Exp $
+
+*libast-0.6.1-r1 (01 Jun 2005)
+
+ 01 Jun 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/libast-0.6.1-config-warning.patch, +libast-0.6.1-r1.ebuild:
+ Fix bogus version warnings with patch from upstream CVS #94479 by Alexander
+ Jenisch.
*libast-9999 (18 Apr 2005)
diff --git a/x11-libs/libast/files/digest-libast-0.6.1-r1 b/x11-libs/libast/files/digest-libast-0.6.1-r1
new file mode 100644
index 000000000000..0d9f22391cea
--- /dev/null
+++ b/x11-libs/libast/files/digest-libast-0.6.1-r1
@@ -0,0 +1 @@
+MD5 1cbbf86a0afb74a5905dc92982117250 libast-0.6.1.tar.gz 356881
diff --git a/x11-libs/libast/files/libast-0.6.1-config-warning.patch b/x11-libs/libast/files/libast-0.6.1-config-warning.patch
new file mode 100644
index 000000000000..0fe749b22bd8
--- /dev/null
+++ b/x11-libs/libast/files/libast-0.6.1-config-warning.patch
@@ -0,0 +1,150 @@
+Grab fix from upstream CVS to address
+http://bugs.gentoo.org/94479
+
+----------------------------------------------------------------------
+Mon Mar 7 17:28:00 2005 Michael Jennings (mej)
+
+Finally found and fixed that stupid "Config file is designed for a
+newer version of FOO" bullshit warning.
+----------------------------------------------------------------------
+
+Index: src/conf.c
+===================================================================
+RCS file: /cvsroot/enlightenment/eterm/libast/src/conf.c,v
+retrieving revision 1.25
+retrieving revision 1.26
+diff -u -r1.25 -r1.26
+--- src/conf.c 21 Oct 2004 20:03:16 -0000 1.25
++++ src/conf.c 7 Mar 2005 22:29:07 -0000 1.26
+@@ -827,10 +827,12 @@
+ /* Check version number against current application version. */
+ begin_ptr = SPIF_STR_STR(ver_str) + spif_str_index(ver_str, SPIF_CAST(char) '-') + 1;
+ end_ptr = SPIF_STR_STR(ver_str) + spif_str_index(ver_str, SPIF_CAST(char) '>');
++ D_CONF(("Begin pointer is %10p (%s), end pointer is %10p (%s), length is %d, buffer size is %d\n",
++ begin_ptr, begin_ptr, end_ptr, end_ptr, SPIF_CAST_C(int) (end_ptr - begin_ptr), sizeof(buff)));
+ if (SPIF_PTR_ISNULL(end_ptr)) {
+ spiftool_safe_strncpy(buff, begin_ptr, sizeof(buff));
+ } else {
+- testlen = MAX(SPIF_CAST_C(int) sizeof(buff), SPIF_CAST_C(int) (end_ptr - begin_ptr));
++ testlen = MIN(SPIF_CAST_C(int) sizeof(buff), SPIF_CAST_C(int) (end_ptr - begin_ptr + 1));
+ spiftool_safe_strncpy(buff, begin_ptr, testlen);
+ }
+ ver = spiftool_version_compare(buff, libast_program_version);
+Index: src/strings.c
+===================================================================
+RCS file: /cvsroot/enlightenment/eterm/libast/src/strings.c,v
+retrieving revision 1.24
+retrieving revision 1.25
+diff -u -r1.24 -r1.25
+--- src/strings.c 23 Jul 2004 21:38:39 -0000 1.24
++++ src/strings.c 7 Mar 2005 22:29:07 -0000 1.25
+@@ -710,21 +710,24 @@
+ {
+ spif_char_t buff1[128], buff2[128];
+
++ D_CONF(("Comparing version strings \"%s\" and \"%s\"\n", NONULL(v1), NONULL(v2)));
+ SPIF_COMP_CHECK_NULL(v1, v2);
+
+ for (; *v1 && *v2; ) {
++ D_CONF((" -> Looking at \"%s\" and \"%s\"\n", v1, v2));
+ if (isalpha(*v1) && isalpha(*v2)) {
+ spif_charptr_t p1 = buff1, p2 = buff2;
+ spif_int8_t ival1 = 6, ival2 = 6;
+
+ /* Compare words. First, copy each word into buffers. */
+- for (; isalpha(*v1); v1++, p1++) *p1 = *v1;
+- for (; isalpha(*v2); v2++, p2++) *p2 = *v2;
++ for (; *v1 && isalpha(*v1); v1++, p1++) *p1 = *v1;
++ for (; *v2 && isalpha(*v2); v2++, p2++) *p2 = *v2;
+ *p1 = *p2 = 0;
+
+ /* Change the buffered strings to lowercase for easier comparison. */
+ spiftool_downcase_str(buff1);
+ spiftool_downcase_str(buff2);
++ D_CONF((" -> Comparing as words \"%s\" vs. \"%s\"\n", buff1, buff2));
+
+ /* Some strings require special handling. */
+ if (!strcmp(SPIF_CHARPTR_C(buff1), "snap")) {
+@@ -751,12 +754,14 @@
+ }
+ if (ival1 != ival2) {
+ /* If the values are different, compare them. */
++ D_CONF((" -> %d\n", (int) SPIF_CMP_FROM_INT(ival1 - ival2)));
+ return SPIF_CMP_FROM_INT(ival1 - ival2);
+ } else if (ival1 == 6) {
+ int c;
+
+ /* Two arbitrary strings. Compare them too. */
+ if ((c = strcmp(SPIF_CHARPTR_C(buff1), SPIF_CHARPTR_C(buff2))) != 0) {
++ D_CONF((" -> %d\n", (int) SPIF_CMP_FROM_INT(c)));
+ return SPIF_CMP_FROM_INT(c);
+ }
+ }
+@@ -766,17 +771,19 @@
+ spif_cmp_t c;
+
+ /* Compare numbers. First, copy each number into buffers. */
+- for (; isdigit(*v1); v1++, p1++) *p1 = *v1;
+- for (; isdigit(*v2); v2++, p2++) *p2 = *v2;
++ for (; *v1 && isdigit(*v1); v1++, p1++) *p1 = *v1;
++ for (; *v2 && isdigit(*v2); v2++, p2++) *p2 = *v2;
+ *p1 = *p2 = 0;
+
+ /* Convert the strings into actual integers. */
+ ival1 = SPIF_CAST(int32) strtol(SPIF_CHARPTR_C(buff1), (char **) NULL, 10);
+ ival2 = SPIF_CAST(int32) strtol(SPIF_CHARPTR_C(buff2), (char **) NULL, 10);
++ D_CONF((" -> Comparing as integers %d vs. %d\n", SPIF_CAST_C(int) ival1, SPIF_CAST_C(int) ival2));
+
+ /* Compare the integers and return if not equal. */
+ c = SPIF_CMP_FROM_INT(ival1 - ival2);
+ if (!SPIF_CMP_IS_EQUAL(c)) {
++ D_CONF((" -> %d\n", (int) c));
+ return c;
+ }
+ } else if (!isalnum(*v1) && !isalnum(*v2)) {
+@@ -784,15 +791,19 @@
+ spif_cmp_t c;
+
+ /* Compare non-alphanumeric strings. */
+- for (; !isalnum(*v1); v1++, p1++) *p1 = *v1;
+- for (; !isalnum(*v2); v2++, p2++) *p2 = *v2;
++ for (; *v1 && !isalnum(*v1); v1++, p1++) *p1 = *v1;
++ for (; *v2 && !isalnum(*v2); v2++, p2++) *p2 = *v2;
+ *p1 = *p2 = 0;
+
++ D_CONF((" -> Comparing as non-alphanumeric strings \"%s\" vs. \"%s\"\n", buff1, buff2));
+ c = SPIF_CMP_FROM_INT(strcasecmp(SPIF_CHARPTR_C(buff1), SPIF_CHARPTR_C(buff2)));
+ if (!SPIF_CMP_IS_EQUAL(c)) {
++ D_CONF((" -> %d\n", (int) c));
+ return c;
+ }
+ } else {
++ D_CONF((" -> Comparing as alphanumeric strings \"%s\" vs. \"%s\"\n", buff1, buff2));
++ D_CONF((" -> %d\n", (int) SPIF_CMP_FROM_INT(strcasecmp(SPIF_CHARPTR_C(buff1), SPIF_CHARPTR_C(buff2)))));
+ return SPIF_CMP_FROM_INT(strcasecmp(SPIF_CHARPTR_C(buff1), SPIF_CHARPTR_C(buff2)));
+ }
+ }
+@@ -801,18 +812,23 @@
+ if (*v1) {
+ if (!BEG_STRCASECMP(SPIF_CHARPTR_C(v1), "snap") || !BEG_STRCASECMP(SPIF_CHARPTR_C(v1), "pre")
+ || !BEG_STRCASECMP(SPIF_CHARPTR_C(v1), "alpha") || !BEG_STRCASECMP(SPIF_CHARPTR_C(v1), "beta")) {
++ D_CONF((" -> <\n"));
+ return SPIF_CMP_LESS;
+ } else {
++ D_CONF((" -> >\n"));
+ return SPIF_CMP_GREATER;
+ }
+ } else if (*v2) {
+ if (!BEG_STRCASECMP(SPIF_CHARPTR_C(v2), "snap") || !BEG_STRCASECMP(SPIF_CHARPTR_C(v2), "pre")
+ || !BEG_STRCASECMP(SPIF_CHARPTR_C(v2), "alpha") || !BEG_STRCASECMP(SPIF_CHARPTR_C(v2), "beta")) {
++ D_CONF((" -> >\n"));
+ return SPIF_CMP_GREATER;
+ } else {
++ D_CONF((" -> <\n"));
+ return SPIF_CMP_LESS;
+ }
+ }
++ D_CONF((" -> ==\n"));
+ return SPIF_CMP_EQUAL;
+ }
+
diff --git a/x11-libs/libast/libast-0.6.1-r1.ebuild b/x11-libs/libast/libast-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..348c39ec103f
--- /dev/null
+++ b/x11-libs/libast/libast-0.6.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.6.1-r1.ebuild,v 1.1 2005/06/01 04:14:59 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="LIBrary of Assorted Spiffy Things"
+HOMEPAGE="http://www.eterm.org/download/"
+SRC_URI="http://www.eterm.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="imlib mmx pcre"
+
+DEPEND="virtual/x11
+ =media-libs/freetype-2*
+ imlib? ( media-libs/imlib2 )
+ pcre? ( dev-libs/libpcre )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-config-warning.patch #94479
+}
+
+src_compile() {
+ local myregexp="posix"
+ use pcre && myregexp="pcre"
+ econf \
+ $(use_with imlib) \
+ $(use_enable mmx) \
+ --with-regexp=${myregexp} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README DESIGN ChangeLog
+}