summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-08-03 22:58:35 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-08-03 22:58:35 +0000
commit4d4a292f8c7447e8a58b82425c1d9a3a81921bce (patch)
treeb82beee46427ecd8a6fdc9f61550e1045796b070 /x11-libs
parentNew version, masked for testing (diff)
downloadgentoo-2-4d4a292f8c7447e8a58b82425c1d9a3a81921bce.tar.gz
gentoo-2-4d4a292f8c7447e8a58b82425c1d9a3a81921bce.tar.bz2
gentoo-2-4d4a292f8c7447e8a58b82425c1d9a3a81921bce.zip
New version, masked for testing.
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/ChangeLog8
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-2.0.61
-rw-r--r--x11-libs/gtk+/gtk+-2.0.6.ebuild85
3 files changed, 93 insertions, 1 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index ae7542d02a3f..9631bc5c2b4b 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.20 2002/07/16 00:06:06 owen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.21 2002/08/03 22:58:35 stroke Exp $
+
+*gtk+-2.0.6 (04 Jul 2002)
+
+ 04 Jul 2002; Gabriele Giorgetti <stroke@gentoo.org> gtk+-2.0.6.ebuild:
+
+ New version.
*gtk+-2.0.5-r2 (15 Jul 2002)
diff --git a/x11-libs/gtk+/files/digest-gtk+-2.0.6 b/x11-libs/gtk+/files/digest-gtk+-2.0.6
new file mode 100644
index 000000000000..257c87d6a275
--- /dev/null
+++ b/x11-libs/gtk+/files/digest-gtk+-2.0.6
@@ -0,0 +1 @@
+MD5 5f9c1b54abea95408155045c661a5adf gtk+-2.0.6.tar.bz2 6118141
diff --git a/x11-libs/gtk+/gtk+-2.0.6.ebuild b/x11-libs/gtk+/gtk+-2.0.6.ebuild
new file mode 100644
index 000000000000..718e8564b29a
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.0.6.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.0.6.ebuild,v 1.1 2002/08/03 22:58:35 stroke Exp $
+
+inherit libtool
+
+SLOT="2"
+KEYWORDS="x86"
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gimp ToolKit + "
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.0/${P}.tar.bz2
+ directfb? ( mirror://gentoo//${PN}-directfb-${PV}-gentoo.patch.bz2 )"
+HOMEPAGE="http://www.gtk.org/"
+LICENSE="LGPL-2.1"
+
+RDEPEND="virtual/x11
+ >=dev-libs/glib-2.0.6
+ >=dev-libs/atk-1.0.3
+ >=x11-libs/pango-1.0.4
+ >=media-libs/libpng-1.2.1
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ directfb? ( dev-libs/DirectFB )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+src_unpack() {
+
+ unpack ${P}.tar.bz2
+ cd ${S}
+ use directfb && ( \
+ ( bzcat ${DISTDIR}/${PN}-directfb-${PV}-gentoo.patch.bz2 \
+ | patch -p1 ) || die
+ )
+}
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+ use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+ use jpeg || myconf="${myconf} --without-libjpeg"
+ use tiff || myconf="${myconf} --without-libtiff"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-gdktarget=x11 \
+ ${myconf} \
+ --enable-debug || die
+# enable debug since glib fails if we disable it
+
+# gtk+ isn't multithread friendly due to some obscure code generation bug
+# make || die
+}
+
+src_install() {
+ dodir /etc/gtk-2.0
+ make DESTDIR=${D} \
+ prefix=/usr \
+ sysconfdir=/etc \
+ infodir=/usr/share/info \
+ mandir=/usr/share/man \
+ install || die
+ dodoc AUTHORS COPYING ChangeLog* HACKING* INSTALL NEWS* README* TODO
+}
+
+
+pkg_postinst() {
+ gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
+}
+