summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2004-12-28 21:12:56 +0000
committerCaleb Tennis <caleb@gentoo.org>2004-12-28 21:12:56 +0000
commit4bd4328fe0c75d5d2e8437a8091f687e40ccf1ce (patch)
tree34ef9468348c588550c1fb8a521cfd85bea02f3b /x11-libs
parentMoved hdf and hdf5 from dev-libs to sci-libs (diff)
downloadgentoo-2-4bd4328fe0c75d5d2e8437a8091f687e40ccf1ce.tar.gz
gentoo-2-4bd4328fe0c75d5d2e8437a8091f687e40ccf1ce.tar.bz2
gentoo-2-4bd4328fe0c75d5d2e8437a8091f687e40ccf1ce.zip
make qt_use a little simpler
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/qt-4.0.0_beta1-r1.ebuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/x11-libs/qt/qt-4.0.0_beta1-r1.ebuild b/x11-libs/qt/qt-4.0.0_beta1-r1.ebuild
index fcf0ff50897c..b3681fe1199e 100644
--- a/x11-libs/qt/qt-4.0.0_beta1-r1.ebuild
+++ b/x11-libs/qt/qt-4.0.0_beta1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.0.0_beta1-r1.ebuild,v 1.3 2004/12/28 20:56:28 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.0.0_beta1-r1.ebuild,v 1.4 2004/12/28 21:12:56 caleb Exp $
inherit eutils flag-o-matic
@@ -47,11 +47,7 @@ export QTDIR=${S}
export PLATFORM=linux-g++
qt_use() {
- if useq $1; then
- echo "-${1}"
- else
- echo "-no-${1}"
- fi
+ useq ${1} && echo "-${1}" || echo "-no-${1}"
return 0
}
@@ -64,8 +60,6 @@ src_unpack() {
cp configure configure.orig
sed -e 's:read acceptance:acceptance=yes:' configure.orig > configure
-# epatch ${FILESDIR}/qt-no-rpath-uic.patch
-
cd mkspecs/linux-g++
# set c/xxflags and ldflags
strip-flags