summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-06-15 21:50:52 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-06-15 21:50:52 +0000
commit472440d6d1260bd861a67109afc95a71af0d3e9e (patch)
tree47ba157177d65a631becdff10053704274d03371 /x11-libs
parentpmask dev-java/javahelp-bin and remove mask for dev-util/jcvs and dev-java/j2... (diff)
downloadgentoo-2-472440d6d1260bd861a67109afc95a71af0d3e9e.tar.gz
gentoo-2-472440d6d1260bd861a67109afc95a71af0d3e9e.tar.bz2
gentoo-2-472440d6d1260bd861a67109afc95a71af0d3e9e.zip
upstream patches for bug #156367 and bug #181707, which should solve several user issues
(Portage version: 2.1.3_rc2)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libX11/ChangeLog11
-rw-r--r--x11-libs/libX11/files/digest-libX11-1.1.2-r13
-rw-r--r--x11-libs/libX11/files/libX11-1.1.2-XGetMotionEvents-order-fix.patch15
-rw-r--r--x11-libs/libX11/files/libX11-1.1.2-XimGetWindowEventmask-fix.patch28
-rw-r--r--x11-libs/libX11/libX11-1.1.2-r1.ebuild34
5 files changed, 90 insertions, 1 deletions
diff --git a/x11-libs/libX11/ChangeLog b/x11-libs/libX11/ChangeLog
index 944eacfe0424..c928e941c32e 100644
--- a/x11-libs/libX11/ChangeLog
+++ b/x11-libs/libX11/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-libs/libX11
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/ChangeLog,v 1.73 2007/06/05 23:40:23 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/ChangeLog,v 1.74 2007/06/15 21:50:52 cardoe Exp $
+
+*libX11-1.1.2-r1 (15 Jun 2007)
+
+ 15 Jun 2007; Doug Goldstein <cardoe@gentoo.org>
+ +files/libX11-1.1.2-XGetMotionEvents-order-fix.patch,
+ +files/libX11-1.1.2-XimGetWindowEventmask-fix.patch,
+ +libX11-1.1.2-r1.ebuild:
+ upstream patches for bug #156367 and bug #181707, which should solve several
+ user issues
*libX11-1.1.2 (05 Jun 2007)
diff --git a/x11-libs/libX11/files/digest-libX11-1.1.2-r1 b/x11-libs/libX11/files/digest-libX11-1.1.2-r1
new file mode 100644
index 000000000000..c5e04ff282c9
--- /dev/null
+++ b/x11-libs/libX11/files/digest-libX11-1.1.2-r1
@@ -0,0 +1,3 @@
+MD5 710bf38a9477a5a1b235bc94f1d0593c libX11-1.1.2.tar.bz2 1523644
+RMD160 c722e1eaa04a3d753660496d4e527b695c68db38 libX11-1.1.2.tar.bz2 1523644
+SHA256 b77e4fd2bbd4092e7e78d0964760ad8ab160caccd4bc6d7d0c87a23febaea85e libX11-1.1.2.tar.bz2 1523644
diff --git a/x11-libs/libX11/files/libX11-1.1.2-XGetMotionEvents-order-fix.patch b/x11-libs/libX11/files/libX11-1.1.2-XGetMotionEvents-order-fix.patch
new file mode 100644
index 000000000000..75e886384f17
--- /dev/null
+++ b/x11-libs/libX11/files/libX11-1.1.2-XGetMotionEvents-order-fix.patch
@@ -0,0 +1,15 @@
+diff --git a/src/GetMoEv.c b/src/GetMoEv.c
+index 2aa6c1a..dac1bfc 100644
+--- a/src/GetMoEv.c
++++ b/src/GetMoEv.c
+@@ -33,9 +33,9 @@ in this Software without prior written authorization from The Open Group.
+
+ XTimeCoord *XGetMotionEvents(
+ register Display *dpy,
++ Window w,
+ Time start,
+ Time stop,
+- Window w,
+ int *nEvents) /* RETURN */
+ {
+ xGetMotionEventsReply rep;
diff --git a/x11-libs/libX11/files/libX11-1.1.2-XimGetWindowEventmask-fix.patch b/x11-libs/libX11/files/libX11-1.1.2-XimGetWindowEventmask-fix.patch
new file mode 100644
index 000000000000..fbd51e7a6bb3
--- /dev/null
+++ b/x11-libs/libX11/files/libX11-1.1.2-XimGetWindowEventmask-fix.patch
@@ -0,0 +1,28 @@
+From: Jamey Sharp <jamey@minilop.net>
+Date: Sun, 10 Jun 2007 23:19:59 +0000 (-0700)
+Subject: Fix locking in _XimGetWindowEventmask.
+X-Git-Url: http://gitweb.freedesktop.org/?p=xorg/lib/libX11.git;a=commitdiff;h=c2f88cdf5cd9c94b77e5bfdac572b5ac06ab4aa8
+
+Fix locking in _XimGetWindowEventmask.
+
+Now that XFilterEvent drops the Display lock before invoking callback
+functions, _XimGetWindowEventmask is called without the lock held. So
+when it called _XGetWindowAttributes, a variant of XGetWindowAttributes
+that does not lock the Display, Xlib/XCB would assert:
+
+xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
+
+Should fix Gentoo #156367, Ubuntu #87947, Debian #427296. And others?
+---
+
+--- a/modules/im/ximcp/imDefLkup.c
++++ b/modules/im/ximcp/imDefLkup.c
+@@ -466,7 +466,7 @@ _XimGetWindowEventmask(
+ Xim im = (Xim )ic->core.im;
+ XWindowAttributes atr;
+
+- if (!_XGetWindowAttributes(im->core.display, ic->core.focus_window, &atr))
++ if (!XGetWindowAttributes(im->core.display, ic->core.focus_window, &atr))
+ return 0;
+ return (EVENTMASK)atr.your_event_mask;
+ }
diff --git a/x11-libs/libX11/libX11-1.1.2-r1.ebuild b/x11-libs/libX11/libX11-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..96a65bde6d1e
--- /dev/null
+++ b/x11-libs/libX11/libX11-1.1.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.1.2-r1.ebuild,v 1.1 2007/06/15 21:50:52 cardoe Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org X11 library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 xcb"
+RDEPEND=">=x11-libs/xtrans-1.0.1
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-proto/kbproto
+ >=x11-proto/xproto-7.0.6
+ xcb? ( >=x11-libs/libxcb-1.0 )"
+DEPEND="${RDEPEND}
+ x11-proto/xf86bigfontproto
+ x11-proto/bigreqsproto
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xcmiscproto
+ >=x11-misc/util-macros-0.99.0_p20051007"
+
+CONFIGURE_OPTIONS="$(use_enable ipv6)
+ $(use_with xcb)"
+# xorg really doesn't like xlocale disabled.
+# $(use_enable nls xlocale)
+
+PATCHES="${FILESDIR}/libX11-1.1.2-XGetMotionEvents-order-fix.patch
+ ${FILESDIR}/libX11-1.1.2-XimGetWindowEventmask-fix.patch"