summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-07-09 07:21:38 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-07-09 07:21:38 +0000
commit454affc612f1364c22899bb0cdbbbee5bf2e7dac (patch)
treeb050090a15d35ca96e124b4ea4d043895d30bfee /x11-libs
parentx86/ppc stable. (diff)
downloadgentoo-2-454affc612f1364c22899bb0cdbbbee5bf2e7dac.tar.gz
gentoo-2-454affc612f1364c22899bb0cdbbbee5bf2e7dac.tar.bz2
gentoo-2-454affc612f1364c22899bb0cdbbbee5bf2e7dac.zip
add notice about revdep-rebuild. add DirectFB backend support. Clean up warnings.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/cairo/ChangeLog5
-rw-r--r--x11-libs/cairo/cairo-1.2.0.ebuild25
2 files changed, 17 insertions, 13 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index 62ab420dfba2..5aa7380e8277 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/cairo
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.74 2006/07/01 08:06:29 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.75 2006/07/09 07:21:38 cardoe Exp $
+
+ 09 Jul 2006; Doug Goldstein <cardoe@gentoo.org> cairo-1.2.0.ebuild:
+ add notice about revdep-rebuild. add DirectFB backend support. Clean up warnings.
*cairo-1.2.0 (01 Jul 2006)
diff --git a/x11-libs/cairo/cairo-1.2.0.ebuild b/x11-libs/cairo/cairo-1.2.0.ebuild
index aeaf97b4baa0..bd6fc1c5cfba 100644
--- a/x11-libs/cairo/cairo-1.2.0.ebuild
+++ b/x11-libs/cairo/cairo-1.2.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.2.0.ebuild,v 1.1 2006/07/01 08:06:29 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.2.0.ebuild,v 1.2 2006/07/09 07:21:38 cardoe Exp $
-inherit eutils autotools
+inherit eutils flag-o-matic
DESCRIPTION="A vector graphics library with cross-device output support"
HOMEPAGE="http://cairographics.org/"
@@ -11,7 +11,7 @@ SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="doc glitz pdf png svg X"
+IUSE="directfb doc glitz pdf png svg X"
RDEPEND="media-libs/fontconfig
>=media-libs/freetype-2.1.4
@@ -23,6 +23,7 @@ RDEPEND="media-libs/fontconfig
)
virtual/xft
)
+ directfb? ( dev-libs/DirectFB )
glitz? ( >=media-libs/glitz-0.5.1 )
png? ( media-libs/libpng )
pdf? ( >=app-text/poppler-bindings-0.4.1
@@ -37,16 +38,10 @@ DEPEND="${RDEPEND}
~app-text/docbook-xml-dtd-4.2 )"
src_compile() {
- echo
- echo
- echo
- ewarn "This compiles but with tons of warnings.. but some Gentoo devs want this in masked.."
- echo
- echo
- echo
- echo
+ #gets rid of fbmmx.c inlining warnings
+ append-flags -finline-limit=1200
- econf $(use_enable X xlib) $(use_enable doc gtk-doc) \
+ econf $(use_enable X xlib) $(use_enable doc gtk-doc) $(use_enable directfb) \
$(use_enable png) $(use_enable svg) $(use_enable pdf) \
$(use_enable glitz) --enable-freetype --enable-ps \
|| die "configure failed"
@@ -58,3 +53,9 @@ src_install() {
make DESTDIR="${D}" install || die "Installation failed"
dodoc AUTHORS ChangeLog NEWS README TODO
}
+
+pkg_postinst() {
+ echo
+ ewarn "You will most likely need to run revdep-rebuild after emerging this"
+ echo
+}