summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-08-05 20:58:18 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-08-05 20:58:18 +0000
commit34eb8760ef27a3b6a783c6892b5ac21ac411c84a (patch)
tree0bbcd4d86aa4a2288dba68f11485c75f3a70b98a /x11-libs
parentAdd bug number. (diff)
downloadgentoo-2-34eb8760ef27a3b6a783c6892b5ac21ac411c84a.tar.gz
gentoo-2-34eb8760ef27a3b6a783c6892b5ac21ac411c84a.tar.bz2
gentoo-2-34eb8760ef27a3b6a783c6892b5ac21ac411c84a.zip
Added static-libs. Simplified ebuild for EAPI4
(Portage version: 2.1.10.10/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xpa/ChangeLog5
-rw-r--r--x11-libs/xpa/xpa-2.1.13.ebuild28
2 files changed, 16 insertions, 17 deletions
diff --git a/x11-libs/xpa/ChangeLog b/x11-libs/xpa/ChangeLog
index da10b4bc6569..639e95f74e1e 100644
--- a/x11-libs/xpa/ChangeLog
+++ b/x11-libs/xpa/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/xpa
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpa/ChangeLog,v 1.8 2011/05/03 17:25:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpa/ChangeLog,v 1.9 2011/08/05 20:58:18 bicatali Exp $
+
+ 05 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> xpa-2.1.13.ebuild:
+ Added static-libs. Simplified ebuild for EAPI4
*xpa-2.1.13 (03 May 2011)
diff --git a/x11-libs/xpa/xpa-2.1.13.ebuild b/x11-libs/xpa/xpa-2.1.13.ebuild
index 148c667fe9df..507be16e83a9 100644
--- a/x11-libs/xpa/xpa-2.1.13.ebuild
+++ b/x11-libs/xpa/xpa-2.1.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpa/xpa-2.1.13.ebuild,v 1.1 2011/05/03 17:25:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpa/xpa-2.1.13.ebuild,v 1.2 2011/08/05 20:58:18 bicatali Exp $
EAPI=4
@@ -13,17 +13,16 @@ SRC_URI="http://hea-www.harvard.edu/saord/download/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc"
+IUSE="doc static-libs"
-RDEPEND="
- dev-lang/tcl
+RDEPEND="dev-lang/tcl
x11-libs/libXt
!<sci-astronomy/ds9-5.3"
DEPEND="${RDEPEND}"
src_prepare() {
epatch "${FILESDIR}"/${PN}-2.1.8-makefile.patch
- sed -i -e "s:\${LINK}:\${LINK} ${LDFLAGS}:" mklib
+ sed -i -e "s:\${LINK}:\${LINK} ${LDFLAGS}:" mklib || die
eautoconf
}
@@ -37,22 +36,19 @@ src_configure() {
}
src_compile() {
- emake shlib tclxpa || die "emake failed"
+ emake shlib tclxpa
}
src_install () {
dodir /usr/$(get_libdir)
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ emake INSTALL_ROOT="${D}" install
insinto /usr/$(get_libdir)/tclxpa
doins pkgIndex.tcl
- mv "${D}"/usr/$(get_libdir)/libtclxpa* "${D}"/usr/$(get_libdir)/tclxpa/
-
+ mv "${ED}"/usr/$(get_libdir)/libtclxpa* \
+ "${ED}"/usr/$(get_libdir)/tclxpa/ || die
dodoc README
- if use doc; then
- cd doc
- insinto /usr/share/doc/${PF}
- doins *.pdf || die
- insinto /usr/share/doc/${PF}/html
- doins *.html || die
- fi
+ use doc && dodoc doc/*.pdf && dohtml doc/*.html
+ # build system so crappy not worth patching to a non respondant upstream
+ # and builds static with PIC
+ use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.a
}