summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2003-06-25 18:29:25 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2003-06-25 18:29:25 +0000
commit326b5926664ff88ea9f7ca87fe7b1256880c6fce (patch)
tree2eacb8483a84c09e17efc57491d801c8acae3989 /x11-libs
parenttweaks (diff)
downloadgentoo-2-326b5926664ff88ea9f7ca87fe7b1256880c6fce.tar.gz
gentoo-2-326b5926664ff88ea9f7ca87fe7b1256880c6fce.tar.bz2
gentoo-2-326b5926664ff88ea9f7ca87fe7b1256880c6fce.zip
Added xinerama config option.
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libxfcegui4/Manifest2
-rw-r--r--x11-libs/libxfcegui4/libxfcegui4-3.91.0.ebuild15
2 files changed, 14 insertions, 3 deletions
diff --git a/x11-libs/libxfcegui4/Manifest b/x11-libs/libxfcegui4/Manifest
index af87b4e8db43..a19e84429593 100644
--- a/x11-libs/libxfcegui4/Manifest
+++ b/x11-libs/libxfcegui4/Manifest
@@ -1,5 +1,5 @@
MD5 0fa850ae114565176fd4095956ba9314 libxfcegui4-3.90.0.ebuild 806
-MD5 0f6daf051d6d9ac247db35ebf13f998e libxfcegui4-3.91.0.ebuild 806
+MD5 04a00492cfe9e5418baeb8bc2282c6b7 libxfcegui4-3.91.0.ebuild 994
MD5 a0e9fc3b1833f2371482100001df7d95 ChangeLog 474
MD5 9e9a544fbe3561c6057d89f44a942f90 files/digest-libxfcegui4-3.90.0 70
MD5 3b273ddbeb474ebed4fdfca2674a1881 files/digest-libxfcegui4-3.91.0 70
diff --git a/x11-libs/libxfcegui4/libxfcegui4-3.91.0.ebuild b/x11-libs/libxfcegui4/libxfcegui4-3.91.0.ebuild
index 2ddf5f3d0448..b516c26e6d46 100644
--- a/x11-libs/libxfcegui4/libxfcegui4-3.91.0.ebuild
+++ b/x11-libs/libxfcegui4/libxfcegui4-3.91.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxfcegui4/libxfcegui4-3.91.0.ebuild,v 1.1 2003/06/25 05:44:27 bcowan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxfcegui4/libxfcegui4-3.91.0.ebuild,v 1.2 2003/06/25 18:29:08 bcowan Exp $
-IUSE=""
+IUSE="xinerama X"
S=${WORKDIR}/${P}
DESCRIPTION="Library's for XFCE4"
@@ -18,6 +18,17 @@ DEPEND=">=x11-libs/gtk+-2.0.6
dev-libs/libxml2
=x11-libs/libxfce4util-3.91.0"
+src_compile() {
+ local myconf
+ myconf=""
+
+ use xinerama && myconf="${myconf} --enable-xinerama"
+ use X && myconf="${myconf} --with-x"
+
+ econf ${myconf} || die
+ emake || die
+}
+
src_install() {
make DESTDIR=${D} install || die