summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-10-04 10:25:33 +0000
committerAlex Alexander <wired@gentoo.org>2009-10-04 10:25:33 +0000
commit3041eac0653983bbefb1a138a9a6d009529fc9ba (patch)
tree26299602849e8fb4f596acc0af5b617a6ca3bbf5 /x11-libs
parentversion bump (diff)
downloadgentoo-2-3041eac0653983bbefb1a138a9a6d009529fc9ba.tar.gz
gentoo-2-3041eac0653983bbefb1a138a9a6d009529fc9ba.tar.bz2
gentoo-2-3041eac0653983bbefb1a138a9a6d009529fc9ba.zip
version bump
(Portage version: 2.2_rc43/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-svg/ChangeLog7
-rw-r--r--x11-libs/qt-svg/qt-svg-4.5.3.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/x11-libs/qt-svg/ChangeLog b/x11-libs/qt-svg/ChangeLog
index 96dfa0f5adc0..d2bec6364829 100644
--- a/x11-libs/qt-svg/ChangeLog
+++ b/x11-libs/qt-svg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-svg
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.37 2009/06/30 15:13:26 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.38 2009/10/04 10:25:33 wired Exp $
+
+*qt-svg-4.5.3 (04 Oct 2009)
+
+ 04 Oct 2009; Alex Alexander <wired@gentoo.org> +qt-svg-4.5.3.ebuild:
+ version bump
30 Jun 2009; Raúl Porcel <armin76@gentoo.org> qt-svg-4.5.1-r1.ebuild:
ia64/sparc stable wrt #266201
diff --git a/x11-libs/qt-svg/qt-svg-4.5.3.ebuild b/x11-libs/qt-svg/qt-svg-4.5.3.ebuild
new file mode 100644
index 000000000000..e519903f7a51
--- /dev/null
+++ b/x11-libs/qt-svg/qt-svg-4.5.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.5.3.ebuild,v 1.1 2009/10/04 10:25:33 wired Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The SVG module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="iconv"
+
+DEPEND="~x11-libs/qt-gui-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/svg
+src/plugins/imageformats/svg
+src/plugins/iconengines/svgiconengine"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/QtSvg/
+include/Qt/
+include/QtGui/
+include/QtCore/
+include/QtXml/
+src/corelib/
+src/gui/
+src/plugins/
+src/xml
+src/3rdparty"
+
+QCONFIG_ADD="svg"
+QCONFIG_DEFINE="QT_SVG"
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -svg -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -v -no-fontconfig -no-glib -no-opengl -no-gtkstyle -continue"
+ qt4-build_src_configure
+}