summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-08-06 16:47:54 +0000
committerSven Wegener <swegener@gentoo.org>2005-08-06 16:47:54 +0000
commit2d8eeb8380b1b0c3fbf5e55681f4aade5045a8aa (patch)
tree019be1fd8b1fa53be5d67a86adb9028ed451c688 /x11-libs
parentStable on alpha. (diff)
downloadgentoo-2-2d8eeb8380b1b0c3fbf5e55681f4aade5045a8aa.tar.gz
gentoo-2-2d8eeb8380b1b0c3fbf5e55681f4aade5045a8aa.tar.bz2
gentoo-2-2d8eeb8380b1b0c3fbf5e55681f4aade5045a8aa.zip
remove default src_compile
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/nucleo/nucleo-0.1-r1.ebuild9
-rw-r--r--x11-libs/nucleo/nucleo-0.1_p20041130.ebuild13
-rw-r--r--x11-libs/nucleo/nucleo-0.1_p20041216.ebuild13
3 files changed, 10 insertions, 25 deletions
diff --git a/x11-libs/nucleo/nucleo-0.1-r1.ebuild b/x11-libs/nucleo/nucleo-0.1-r1.ebuild
index eeaad991a0d7..bf890b851e31 100644
--- a/x11-libs/nucleo/nucleo-0.1-r1.ebuild
+++ b/x11-libs/nucleo/nucleo-0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/nucleo/nucleo-0.1-r1.ebuild,v 1.5 2005/02/10 08:39:16 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/nucleo/nucleo-0.1-r1.ebuild,v 1.6 2005/08/06 16:45:37 swegener Exp $
IUSE=""
@@ -20,12 +20,7 @@ SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="x86 ppc"
-src_compile() {
- econf || die "configure failed"
- emake || die "make failed"
-}
-
src_install() {
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
dodoc README ChangeLog AUTHORS NEWS
}
diff --git a/x11-libs/nucleo/nucleo-0.1_p20041130.ebuild b/x11-libs/nucleo/nucleo-0.1_p20041130.ebuild
index 053ca89dd640..3fe2aa80d437 100644
--- a/x11-libs/nucleo/nucleo-0.1_p20041130.ebuild
+++ b/x11-libs/nucleo/nucleo-0.1_p20041130.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/nucleo/nucleo-0.1_p20041130.ebuild,v 1.3 2005/02/10 08:39:16 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/nucleo/nucleo-0.1_p20041130.ebuild,v 1.4 2005/08/06 16:45:37 swegener Exp $
inherit eutils
@@ -24,16 +24,11 @@ S="${WORKDIR}/${P/_p*/}"
src_unpack() {
unpack ${A}
- cd ${S}/nucleo/gl/texture
- epatch ${FILESDIR}/${P/_p*/}-nv.patch
-}
-
-src_compile() {
- econf || die "configure failed"
- emake || die "make failed"
+ cd "${S}"/nucleo/gl/texture
+ epatch "${FILESDIR}"/${P/_p*/}-nv.patch
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
dodoc README ChangeLog AUTHORS NEWS
}
diff --git a/x11-libs/nucleo/nucleo-0.1_p20041216.ebuild b/x11-libs/nucleo/nucleo-0.1_p20041216.ebuild
index ce80ff26f22b..7427a0b02322 100644
--- a/x11-libs/nucleo/nucleo-0.1_p20041216.ebuild
+++ b/x11-libs/nucleo/nucleo-0.1_p20041216.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/nucleo/nucleo-0.1_p20041216.ebuild,v 1.3 2005/04/23 00:36:43 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/nucleo/nucleo-0.1_p20041216.ebuild,v 1.4 2005/08/06 16:45:37 swegener Exp $
inherit eutils
@@ -24,16 +24,11 @@ S="${WORKDIR}/${P/_p*/}"
src_unpack() {
unpack ${A}
- cd ${S}/nucleo/gl/texture
- epatch ${FILESDIR}/${P/_p*/}-nv.patch
-}
-
-src_compile() {
- econf || die "configure failed"
- emake || die "make failed"
+ cd "${S}"/nucleo/gl/texture
+ epatch "${FILESDIR}"/${P/_p*/}-nv.patch
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
dodoc README ChangeLog AUTHORS NEWS
}