summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-04-27 19:47:51 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-04-27 19:47:51 +0000
commit2aa444d98752b09dda08e0b89f062322991584f2 (patch)
treef5de7a462e4fb320b0bb0c7c7d40dadc70290aad /x11-libs
parentQt 4.5.1 release version bump (diff)
downloadgentoo-2-2aa444d98752b09dda08e0b89f062322991584f2.tar.gz
gentoo-2-2aa444d98752b09dda08e0b89f062322991584f2.tar.bz2
gentoo-2-2aa444d98752b09dda08e0b89f062322991584f2.zip
Qt 4.5.1 release version bump
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-script/ChangeLog8
-rw-r--r--x11-libs/qt-script/qt-script-4.5.1.ebuild31
2 files changed, 38 insertions, 1 deletions
diff --git a/x11-libs/qt-script/ChangeLog b/x11-libs/qt-script/ChangeLog
index cdefb0eb869d..065a9d1eeb13 100644
--- a/x11-libs/qt-script/ChangeLog
+++ b/x11-libs/qt-script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-script
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.28 2009/03/18 22:29:16 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.29 2009/04/27 19:47:51 hwoarang Exp $
+
+*qt-script-4.5.1 (27 Apr 2009)
+
+ 27 Apr 2009; Markos Chandras <hwoarang@gentoo.org>
+ +qt-script-4.5.1.ebuild:
+ Version bump to 4.5.1
18 Mar 2009; Markos Chandras <hwoarang@gentoo.org>
-qt-script-4.5.0_rc1.ebuild:
diff --git a/x11-libs/qt-script/qt-script-4.5.1.ebuild b/x11-libs/qt-script/qt-script-4.5.1.ebuild
new file mode 100644
index 000000000000..b4e24d79b924
--- /dev/null
+++ b/x11-libs/qt-script/qt-script-4.5.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/qt-script-4.5.1.ebuild,v 1.1 2009/04/27 19:47:51 hwoarang Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The ECMAScript module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+iconv"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/script/"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/Qt/
+include/QtCore/
+include/QtScript/
+src/corelib/"
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-svg -no-gtkstyle"
+ qt4-build_src_configure
+}