summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-12-23 02:05:19 +0000
committerMarinus Schraal <foser@gentoo.org>2002-12-23 02:05:19 +0000
commit28189c1be813d3526d3da93588164c05a19203fc (patch)
tree106c422765508c872297c8b73235447c870af037 /x11-libs
parentadd --print-environ; other fixes (diff)
downloadgentoo-2-28189c1be813d3526d3da93588164c05a19203fc.tar.gz
gentoo-2-28189c1be813d3526d3da93588164c05a19203fc.tar.bz2
gentoo-2-28189c1be813d3526d3da93588164c05a19203fc.zip
Added slighthint patch
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pango/ChangeLog3
-rw-r--r--x11-libs/pango/files/pango-1.2.0-slighthint-gentoo.patch54
-rw-r--r--x11-libs/pango/pango-1.2.0.ebuild7
3 files changed, 60 insertions, 4 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index 0afe8940434a..1d2ddcd8aaae 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,11 +1,12 @@
# ChangeLog for x11-libs/pango
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.26 2002/12/22 23:35:13 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.27 2002/12/23 02:05:19 foser Exp $
*pango-1.2.0.ebuild (22 Dec 2002)
22 Dec 2002; foser <foser@gentoo.org> pango-1.2.0.ebuild :
New stable version
+ Adapted the slighthint patch to work with it
14 Dec 2002; Aron Griffis <agriffis@gentoo.org> pango-1.1.3.ebuild :
REALLY commented out the slighthinting patch, for the same reason as Bart
diff --git a/x11-libs/pango/files/pango-1.2.0-slighthint-gentoo.patch b/x11-libs/pango/files/pango-1.2.0-slighthint-gentoo.patch
new file mode 100644
index 000000000000..b9ca0606e8fd
--- /dev/null
+++ b/x11-libs/pango/files/pango-1.2.0-slighthint-gentoo.patch
@@ -0,0 +1,54 @@
+--- pango-1.2.0/pango/pangoft2.c 2002-12-07 07:05:48.000000000 +0100
++++ pango-1.2.0.slighthint/pango/pangoft2.c 2002-12-23 02:37:38.000000000 +0100
+@@ -204,6 +204,8 @@
+ FcPattern *pattern;
+ FcChar8 *filename;
+ FcBool hinting, autohint;
++ FT_ULong hint_flags;
++ int hintstyle;
+ int id;
+
+ pattern = ft2font->font_pattern;
+@@ -219,8 +221,22 @@
+ if (FcPatternGetBool (pattern, FC_HINTING, 0, &hinting) != FcResultMatch)
+ hinting = FcTrue;
+
+- if (!hinting)
+- ft2font->load_flags |= FT_LOAD_NO_HINTING;
++ if (FcPatternGetInteger (pattern, FC_HINT_STYLE, 0, &hintstyle) != FcResultMatch)
++ hintstyle = FC_HINT_FULL;
++
++ if (!hinting || hintstyle == FC_HINT_NONE)
++ ft2font->load_flags |= FT_LOAD_NO_HINTING;
++
++ switch (hintstyle) {
++ case FC_HINT_SLIGHT:
++ hint_flags = FT_HINT_NO_INTEGER_STEM | FT_HINT_NO_VSTEM_ALIGN;
++ break;
++ case FC_HINT_MEDIUM:
++ hint_flags = FT_HINT_NO_INTEGER_STEM;
++ break;
++ default:
++ hint_flags = 0;
++ }
+
+ /* force autohinting if requested */
+ if (FcPatternGetBool (pattern, FC_AUTOHINT, 0, &autohint) != FcResultMatch)
+@@ -244,7 +260,7 @@
+ }
+
+ g_assert (ft2font->face);
+-
++
+ if (!set_unicode_charmap (ft2font->face))
+ {
+ g_warning ("Unable to load unicode charmap from font file %s", filename);
+@@ -261,6 +277,8 @@
+ 0, 0);
+ if (error)
+ g_warning ("Error in FT_Set_Char_Size: %d", error);
++
++ FT_Set_Hint_Flags (ft2font->face, hint_flags);
+ }
+
+ return ft2font->face;
diff --git a/x11-libs/pango/pango-1.2.0.ebuild b/x11-libs/pango/pango-1.2.0.ebuild
index 6d4a523cbdff..ed7481b13c7d 100644
--- a/x11-libs/pango/pango-1.2.0.ebuild
+++ b/x11-libs/pango/pango-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.2.0.ebuild,v 1.1 2002/12/22 23:35:13 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.2.0.ebuild,v 1.2 2002/12/23 02:05:19 foser Exp $
inherit eutils libtool
@@ -18,7 +18,7 @@ RDEPEND="virtual/x11
virtual/xft
>=dev-libs/glib-2.1.3
>=media-libs/fontconfig-2
- >=media-libs/freetype-2.0.1"
+ >=media-libs/freetype-2.1.2-r2"
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.12.0
@@ -31,7 +31,8 @@ src_unpack() {
cd ${S}
# Some enhancements from Redhat
epatch ${FILESDIR}/pango-1.0.99.020606-xfonts.patch
- #epatch ${FILESDIR}/pango-1.1.0-slighthint.patch
+ # patch adapted from RH initial patch by <foser@gentoo.org>
+ epatch ${FILESDIR}/${P}-slighthint-gentoo.patch
}
src_compile() {