summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-06-28 08:46:27 +0000
committerUlrich Müller <ulm@gentoo.org>2008-06-28 08:46:27 +0000
commit260a9b6290db88cb70991c28e9833629af8981f2 (patch)
tree7204eb627dd1fb2008b1fa148850b3fcd39381fe /x11-libs
parentbump to 7.14.4, bug #229073; old (diff)
downloadgentoo-2-260a9b6290db88cb70991c28e9833629af8981f2.tar.gz
gentoo-2-260a9b6290db88cb70991c28e9833629af8981f2.tar.bz2
gentoo-2-260a9b6290db88cb70991c28e9833629af8981f2.zip
Add missing conditional for USE=-xft in XmRenderT.c, bug 229779.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r4 i686)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/openmotif/ChangeLog6
-rw-r--r--x11-libs/openmotif/files/openmotif-2.3.1-XmRenderT-no-xft.patch18
-rw-r--r--x11-libs/openmotif/openmotif-2.3.1.ebuild7
3 files changed, 29 insertions, 2 deletions
diff --git a/x11-libs/openmotif/ChangeLog b/x11-libs/openmotif/ChangeLog
index fb9c62a388b0..c159fd1a1f70 100644
--- a/x11-libs/openmotif/ChangeLog
+++ b/x11-libs/openmotif/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/openmotif
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.188 2008/06/27 11:17:37 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.189 2008/06/28 08:46:27 ulm Exp $
+
+ 28 Jun 2008; Ulrich Mueller <ulm@gentoo.org>
+ +files/openmotif-2.3.1-XmRenderT-no-xft.patch, openmotif-2.3.1.ebuild:
+ Add missing conditional for USE=-xft in XmRenderT.c, fixes bug 229779.
*openmotif-2.3.1 (27 Jun 2008)
diff --git a/x11-libs/openmotif/files/openmotif-2.3.1-XmRenderT-no-xft.patch b/x11-libs/openmotif/files/openmotif-2.3.1-XmRenderT-no-xft.patch
new file mode 100644
index 000000000000..8508dbbb9d65
--- /dev/null
+++ b/x11-libs/openmotif/files/openmotif-2.3.1-XmRenderT-no-xft.patch
@@ -0,0 +1,18 @@
+--- openmotif-2.3.1-orig/lib/Xm/XmRenderT.c 2008-04-23 16:58:27.000000000 +0200
++++ openmotif-2.3.1/lib/Xm/XmRenderT.c 2008-06-28 10:05:58.000000000 +0200
+@@ -1979,6 +1979,7 @@
+ }
+
+ #ifdef FIX_1414
++#ifdef USE_XFT
+ static int
+ GetSameRenditions(XmRendition *rend_cache, XmRendition rend, int count_rend)
+ {
+@@ -2009,6 +2010,7 @@
+
+ }
+ #endif
++#endif
+
+ /* Make sure all the font related resources make sense together and */
+ /* then load the font specified by fontName if necessary. */
diff --git a/x11-libs/openmotif/openmotif-2.3.1.ebuild b/x11-libs/openmotif/openmotif-2.3.1.ebuild
index a0512e4a09b1..3a47f24ce239 100644
--- a/x11-libs/openmotif/openmotif-2.3.1.ebuild
+++ b/x11-libs/openmotif/openmotif-2.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.1.ebuild,v 1.1 2008/06/27 11:17:37 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.1.ebuild,v 1.2 2008/06/28 08:46:27 ulm Exp $
inherit eutils flag-o-matic multilib autotools
@@ -60,8 +60,13 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
+
+ # fix linking problem on FreeBSD, bug 219040
epatch "${FILESDIR}/${PN}-2.3.0-freebsd-libiconv.patch"
+ # add missing conditional for USE=-xft, bug 229779
+ epatch "${FILESDIR}/${P}-XmRenderT-no-xft.patch"
+
# disable compilation of demo binaries
sed -i -e '/^SUBDIRS/{:x;/\\$/{N;bx;};s/[ \t\n\\]*demos//;}' Makefile.am