summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-11-28 20:48:25 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-11-28 20:48:25 +0000
commit2590211403344c218e6efa6bd9a2dc2a75bce3e0 (patch)
treed8a7866c4b0e00a54fd455db404ed16d8a824fbf /x11-libs
parentForce newer version of boto to match what upstream expects. (diff)
downloadgentoo-2-2590211403344c218e6efa6bd9a2dc2a75bce3e0.tar.gz
gentoo-2-2590211403344c218e6efa6bd9a2dc2a75bce3e0.tar.bz2
gentoo-2-2590211403344c218e6efa6bd9a2dc2a75bce3e0.zip
Backport patch from Qt 4.8 to fix crash in LibreOffice, as pointed out by scarabeus. FreeDesktop bug 40298
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-core/ChangeLog9
-rw-r--r--x11-libs/qt-core/files/qt-core-4.7.4-fix-libreoffice-crash.patch46
-rw-r--r--x11-libs/qt-core/qt-core-4.7.4-r1.ebuild184
3 files changed, 238 insertions, 1 deletions
diff --git a/x11-libs/qt-core/ChangeLog b/x11-libs/qt-core/ChangeLog
index d81ad66a33a3..3de94d262111 100644
--- a/x11-libs/qt-core/ChangeLog
+++ b/x11-libs/qt-core/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/qt-core
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.145 2011/11/26 19:59:35 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.146 2011/11/28 20:48:24 tampakrap Exp $
+
+*qt-core-4.7.4-r1 (28 Nov 2011)
+
+ 28 Nov 2011; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-core-4.7.4-r1.ebuild, +files/qt-core-4.7.4-fix-libreoffice-crash.patch:
+ Backport patch from Qt 4.8 to fix crash in LibreOffice, as pointed out by
+ scarabeus. FreeDesktop bug 40298
26 Nov 2011; Robin H. Johnson <robbat2@gentoo.org> Manifest:
Bug 385719: upstream altered qt-everywhere-opensource-src-4.7.4.tar.gz, mass
diff --git a/x11-libs/qt-core/files/qt-core-4.7.4-fix-libreoffice-crash.patch b/x11-libs/qt-core/files/qt-core-4.7.4-fix-libreoffice-crash.patch
new file mode 100644
index 000000000000..0350183f8a95
--- /dev/null
+++ b/x11-libs/qt-core/files/qt-core-4.7.4-fix-libreoffice-crash.patch
@@ -0,0 +1,46 @@
+--- src/corelib/global/qnamespace.qdoc.sav 2011-08-23 14:02:27.000000000 +0200
++++ src/corelib/global/qnamespace.qdoc 2011-11-22 13:06:00.879288001 +0100
+@@ -167,6 +167,10 @@
+ attribute is true. This attribute must be set after QApplication is
+ constructed. This is only supported in Symbian^3 and later Symbian releases.
+
++ \value AA_X11InitThreads Calls XInitThreads() as part of the QApplication
++ construction in order to make Xlib calls thread-safe.
++
++
+ \omitvalue AA_AttributeCount
+ */
+
+--- src/corelib/global/qnamespace.h.sav 2011-08-23 14:02:27.000000000 +0200
++++ src/corelib/global/qnamespace.h 2011-11-22 13:07:35.925288002 +0100
+@@ -544,6 +544,7 @@ public:
+ AA_MacDontSwapCtrlAndMeta = 7,
+ AA_S60DontConstructApplicationPanes = 8,
+ AA_S60DisablePartialScreenInputMode = 9,
++ AA_X11InitThreads = 10,
+
+ // Add new attributes before this line
+ AA_AttributeCount
+--- src/gui/kernel/qapplication_x11.cpp.sav 2011-08-23 14:02:27.000000000 +0200
++++ src/gui/kernel/qapplication_x11.cpp 2011-11-22 13:06:00.881288001 +0100
+@@ -1739,6 +1739,9 @@ void qt_init(QApplicationPrivate *priv,
+ } else {
+ // Qt controls everything (default)
+
++ if (QApplication::testAttribute(Qt::AA_X11InitThreads))
++ XInitThreads();
++
+ // Set application name and class
+ char *app_class = 0;
+ if (argv && argv[0]) {
+--- src/gui/image/qpixmap.cpp.sav 2011-08-23 14:02:27.000000000 +0200
++++ src/gui/image/qpixmap.cpp 2011-11-22 13:06:39.723288001 +0100
+@@ -99,7 +99,7 @@ static bool qt_pixmap_thread_test()
+ return false;
+ }
+ #ifndef Q_WS_WIN
+- if (qApp->thread() != QThread::currentThread()) {
++ if (!QApplication::testAttribute(Qt::AA_X11InitThreads) && qApp->thread() != QThread::currentThread()) {
+ qWarning("QPixmap: It is not safe to use pixmaps outside the GUI thread");
+ return false;
+ }
diff --git a/x11-libs/qt-core/qt-core-4.7.4-r1.ebuild b/x11-libs/qt-core/qt-core-4.7.4-r1.ebuild
new file mode 100644
index 000000000000..ff3ef1baf5cc
--- /dev/null
+++ b/x11-libs/qt-core/qt-core-4.7.4-r1.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.7.4-r1.ebuild,v 1.1 2011/11/28 20:48:24 tampakrap Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The Qt toolkit is a comprehensive C++ application development framework"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="+glib iconv +jit optimized-qmake private-headers qt3support ssl"
+
+DEPEND="sys-libs/zlib
+ glib? ( dev-libs/glib )
+ ssl? ( dev-libs/openssl )
+ !<x11-libs/qt-4.4.0:4"
+RDEPEND="${DEPEND}"
+PDEPEND="qt3support? ( ~x11-libs/qt-gui-${PV}[aqua=,glib=,qt3support] )"
+
+PATCHES=(
+ # bug #382171
+ "${FILESDIR}/blacklist-diginotar-certs.diff"
+ "${FILESDIR}/${P}-fix-libreoffice-crash.patch"
+)
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/tools/bootstrap
+ src/tools/moc
+ src/tools/rcc
+ src/tools/uic
+ src/corelib
+ src/xml
+ src/network
+ src/plugins/codecs
+ tools/linguist/lconvert
+ tools/linguist/lrelease
+ tools/linguist/lupdate"
+
+ QT4_EXTRACT_DIRECTORIES="
+ include/Qt
+ include/QtCore
+ include/QtDeclarative
+ include/QtGui
+ include/QtNetwork
+ include/QtScript
+ include/QtXml
+ src/plugins/plugins.pro
+ src/plugins/qpluginbase.pri
+ src/src.pro
+ src/3rdparty/des
+ src/3rdparty/harfbuzz
+ src/3rdparty/md4
+ src/3rdparty/md5
+ src/3rdparty/sha1
+ src/3rdparty/easing
+ src/3rdparty/zlib_dependency.pri
+ src/declarative
+ src/gui
+ src/script
+ tools/shared
+ tools/linguist/shared
+ translations"
+ qt4-build_pkg_setup
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ ${QT4_EXTRACT_DIRECTORIES}"
+}
+
+src_prepare() {
+ # Don't pre-strip, bug 235026
+ for i in kr jp cn tw ; do
+ echo "CONFIG+=nostrip" >> "${S}"/src/plugins/codecs/${i}/${i}.pro
+ done
+
+ qt4-build_src_prepare
+
+ # bug 172219
+ sed -i -e "s:CXXFLAGS.*=:CXXFLAGS=${CXXFLAGS} :" \
+ "${S}/qmake/Makefile.unix" || die "sed qmake/Makefile.unix CXXFLAGS failed"
+ sed -i -e "s:LFLAGS.*=:LFLAGS=${LDFLAGS} :" \
+ "${S}/qmake/Makefile.unix" || die "sed qmake/Makefile.unix LDFLAGS failed"
+}
+
+src_configure() {
+ unset QMAKESPEC
+
+ myconf="${myconf}
+ $(qt_use glib)
+ $(qt_use iconv)
+ $(qt_use optimized-qmake)
+ $(qt_use ssl openssl)
+ $(qt_use qt3support)
+ $(qt_use jit javascript-jit)"
+
+ myconf="${myconf} -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-gif -no-libpng
+ -no-libmng -no-libjpeg -system-zlib -no-webkit -no-phonon -no-xmlpatterns
+ -no-freetype -no-libtiff -no-accessibility -no-fontconfig -no-opengl
+ -no-svg -no-gtkstyle -no-phonon-backend -no-script -no-scripttools
+ -no-cups -no-xsync -no-xinput -no-multimedia"
+ qt4-build_src_configure
+}
+
+src_compile() {
+ # bug 259736
+ unset QMAKESPEC
+ qt4-build_src_compile
+}
+
+src_install() {
+ dobin "${S}"/bin/{qmake,moc,rcc,uic,lconvert,lrelease,lupdate} || die "dobin failed"
+
+ install_directories src/{corelib,xml,network,plugins/codecs}
+
+ emake INSTALL_ROOT="${D}" install_mkspecs || die "emake install_mkspecs failed"
+
+ #install private headers
+ if use private-headers; then
+ insinto "${QTHEADERDIR#${EPREFIX}}"/QtCore/private
+ find "${S}"/src/corelib -type f -name "*_p.h" -exec doins {} \;
+ fi
+ # use freshly built libraries
+ local DYLD_FPATH=
+ [[ -d "${S}"/lib/QtCore.framework ]] \
+ && DYLD_FPATH=$(for x in "${S}/lib/"*.framework; do echo -n ":$x"; done)
+ DYLD_LIBRARY_PATH="${S}/lib${DYLD_FPATH}" \
+ LD_LIBRARY_PATH="${S}/lib" "${S}"/bin/lrelease translations/*.ts \
+ || die "generating translations faied"
+ insinto "${QTTRANSDIR#${EPREFIX}}"
+ doins translations/*.qm || die "doins translations failed"
+
+ setqtenv
+ fix_library_files
+
+ # List all the multilib libdirs
+ local libdirs=
+ for libdir in $(get_all_libdirs); do
+ libdirs+=":${EPREFIX}/usr/${libdir}/qt4"
+ done
+
+ cat <<-EOF > "${T}/44qt4"
+ LDPATH="${libdirs:1}"
+ EOF
+ doenvd "${T}/44qt4"
+
+ dodir "${QTDATADIR#${EPREFIX}}"/mkspecs/gentoo || die "dodir failed"
+ mv "${D}/${QTDATADIR}"/mkspecs/qconfig.pri "${D}${QTDATADIR}"/mkspecs/gentoo \
+ || die "Failed to move qconfig.pri"
+
+ # Framework hacking
+ if use aqua && [[ ${CHOST#*-darwin} -ge 9 ]] ; then
+ #TODO do this better
+ sed -i -e '2a#include <QtCore/Gentoo/gentoo-qconfig.h>\n' \
+ "${D}${QTLIBDIR}"/QtCore.framework/Headers/qconfig.h \
+ || die "sed for qconfig.h failed."
+ dosym "${QTHEADERDIR#${EPREFIX}}"/Gentoo "${QTLIBDIR#${EPREFIX}}"/QtCore.framework/Headers/Gentoo ||
+ die "dosym failed"
+ else
+ sed -i -e '2a#include <Gentoo/gentoo-qconfig.h>\n' \
+ "${D}${QTHEADERDIR}"/QtCore/qconfig.h \
+ "${D}${QTHEADERDIR}"/Qt/qconfig.h \
+ || die "sed for qconfig.h failed"
+ fi
+
+ if use glib; then
+ QCONFIG_DEFINE="$(use glib && echo QT_GLIB)
+ $(use ssl && echo QT_OPENSSL)"
+ install_qconfigs
+ fi
+ # remove .la files
+ find "${D}${QTLIBDIR}" -name "*.la" -print0 | xargs -0 rm
+
+ # remove some unnecessary headers
+ rm -f "${D}${QTHEADERDIR}"/{Qt,QtCore}/{\
+qatomic_windows.h,\
+qatomic_windowsce.h,\
+qt_windows.h}
+
+ keepdir "${QTSYSCONFDIR#${EPREFIX}}"
+
+ # Framework magic
+ fix_includes
+}