summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-04-04 16:14:23 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-04-04 16:14:23 +0000
commit1b0eb327592a3b0a940f93e6a608a5bac3a5673a (patch)
tree3e0cb90b395afb4097ce6c1b4c0356c46497f545 /x11-libs
parentAdd texi2html-5 patch by Michael (kensington, bug #410767). Reinstate LINGUAS... (diff)
downloadgentoo-2-1b0eb327592a3b0a940f93e6a608a5bac3a5673a.tar.gz
gentoo-2-1b0eb327592a3b0a940f93e6a608a5bac3a5673a.tar.bz2
gentoo-2-1b0eb327592a3b0a940f93e6a608a5bac3a5673a.zip
Bump to a more recent snapshot from git, since upstream has stopped doing tarball releases.
Fixes compilation against Qt 4.8 (bug 408305). Run 'emake docs' to fix bug 405953. Various code cleanups. (Portage version: 2.2.0_alpha99/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-mobility/ChangeLog10
-rw-r--r--x11-libs/qt-mobility/qt-mobility-1.2.2_p20120403.ebuild164
2 files changed, 173 insertions, 1 deletions
diff --git a/x11-libs/qt-mobility/ChangeLog b/x11-libs/qt-mobility/ChangeLog
index 873092be4c26..bf808eb14c10 100644
--- a/x11-libs/qt-mobility/ChangeLog
+++ b/x11-libs/qt-mobility/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/qt-mobility
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-mobility/ChangeLog,v 1.3 2012/04/04 15:43:36 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-mobility/ChangeLog,v 1.4 2012/04/04 16:14:23 pesa Exp $
+
+*qt-mobility-1.2.2_p20120403 (04 Apr 2012)
+
+ 04 Apr 2012; Davide Pesavento <pesa@gentoo.org>
+ +qt-mobility-1.2.2_p20120403.ebuild:
+ Bump to a more recent snapshot from git, since upstream has stopped doing
+ tarball releases. Fixes compilation against Qt 4.8 (bug 408305). Run 'emake
+ docs' to fix bug 405953. Various code cleanups.
04 Apr 2012; Davide Pesavento <pesa@gentoo.org> qt-mobility-1.2.0.ebuild:
Restrict qt deps to 4.7.x only, qt-mobility doesn't build against qt 4.8.
diff --git a/x11-libs/qt-mobility/qt-mobility-1.2.2_p20120403.ebuild b/x11-libs/qt-mobility/qt-mobility-1.2.2_p20120403.ebuild
new file mode 100644
index 000000000000..97adfa73c88f
--- /dev/null
+++ b/x11-libs/qt-mobility/qt-mobility-1.2.2_p20120403.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-mobility/qt-mobility-1.2.2_p20120403.ebuild,v 1.1 2012/04/04 16:14:23 pesa Exp $
+
+EAPI=4
+
+inherit multilib qt4-r2 toolchain-funcs
+
+DESCRIPTION="Additional Qt APIs for mobile devices and desktop platforms"
+HOMEPAGE="http://qt.nokia.com/products/qt-addons/mobility"
+SRC_URI="http://dev.gentoo.org/~pesa/distfiles/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+QT_MOBILITY_MODULES=(bearer connectivity contacts feedback gallery
+ location messaging multimedia organizer publishsubscribe
+ sensors serviceframework systeminfo versit)
+IUSE="bluetooth debug doc networkmanager pulseaudio qml +tools
+ ${QT_MOBILITY_MODULES[@]}"
+
+REQUIRED_USE="
+ || ( ${QT_MOBILITY_MODULES[@]#[+-]} )
+ versit? ( contacts )
+"
+
+RDEPEND="
+ >=x11-libs/qt-core-4.7.0:4
+ bearer? (
+ networkmanager? (
+ net-misc/networkmanager
+ >=x11-libs/qt-dbus-4.7.0:4
+ )
+ )
+ connectivity? (
+ >=x11-libs/qt-dbus-4.7.0:4
+ bluetooth? ( net-wireless/bluez )
+ )
+ gallery? ( >=x11-libs/qt-dbus-4.7.0:4 )
+ location? (
+ >=x11-libs/qt-declarative-4.7.0:4
+ >=x11-libs/qt-gui-4.7.0:4
+ >=x11-libs/qt-sql-4.7.0:4[sqlite]
+ )
+ messaging? ( >=net-libs/qmf-2.0_p201209 )
+ multimedia? (
+ media-libs/alsa-lib
+ >=media-libs/gstreamer-0.10.19:0.10
+ >=media-libs/gst-plugins-bad-0.10.19
+ >=media-libs/gst-plugins-base-0.10.19:0.10
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXv
+ >=x11-libs/qt-gui-4.8.0-r4:4[xv]
+ >=x11-libs/qt-opengl-4.8.0:4
+ pulseaudio? ( media-sound/pulseaudio[alsa] )
+ )
+ publishsubscribe? (
+ tools? ( >=x11-libs/qt-gui-4.7.0:4 )
+ )
+ qml? ( >=x11-libs/qt-declarative-4.7.0:4 )
+ serviceframework? (
+ >=x11-libs/qt-dbus-4.7.0:4
+ >=x11-libs/qt-sql-4.7.0:4[sqlite]
+ tools? ( >=x11-libs/qt-gui-4.7.0:4 )
+ )
+ systeminfo? (
+ sys-apps/util-linux
+ sys-fs/udev
+ x11-libs/libX11
+ x11-libs/libXrandr
+ >=x11-libs/qt-dbus-4.7.0:4
+ >=x11-libs/qt-gui-4.7.0:4
+ bluetooth? ( net-wireless/bluez )
+ networkmanager? ( net-misc/networkmanager )
+ )
+ versit? ( >=x11-libs/qt-gui-4.7.0:4 )
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ multimedia? (
+ sys-kernel/linux-headers
+ x11-proto/videoproto
+ )
+ systeminfo? ( sys-kernel/linux-headers )
+"
+PDEPEND="
+ connectivity? (
+ bluetooth? ( app-mobilephone/obexd )
+ )
+"
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ # disable building of code snippets in doc/
+ # and translations (they aren't actually translated)
+ sed -i -re '/SUBDIRS \+= (doc|translations)/d' qtmobility.pro || die
+
+ # fix automagic dependency on qt-declarative
+ if ! use qml; then
+ sed -i -e '/SUBDIRS += declarative/d' plugins/plugins.pro || die
+ fi
+}
+
+src_configure() {
+ # figure out which modules to build
+ local modules=
+ for mod in "${QT_MOBILITY_MODULES[@]#[+-]}"; do
+ use ${mod} && modules+="${mod} "
+ done
+
+ if use messaging; then
+ # tell qmake where QMF is installed
+ export QMF_INCLUDEDIR=$($(tc-getPKG_CONFIG) --variable includedir qmfclient)
+ export QMF_LIBDIR=$($(tc-getPKG_CONFIG) --variable libdir qmfclient)
+ fi
+
+ # custom configure script
+ local myconf=(
+ ./configure
+ -prefix "${EPREFIX}/usr"
+ -headerdir "${EPREFIX}/usr/include/qt4"
+ -libdir "${EPREFIX}/usr/$(get_libdir)/qt4"
+ -plugindir "${EPREFIX}/usr/$(get_libdir)/qt4/plugins"
+ $(use debug && echo -debug || echo -release)
+ $(use doc || echo -no-docs)
+ $(use tools || echo -no-tools)
+ -modules "${modules}"
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die "configure failed"
+
+ # fix automagic dependency on bluez
+ if ! use bluetooth; then
+ sed -i -e '/^bluez_enabled =/s:yes:no:' config.pri || die
+ fi
+ # fix automagic dependency on networkmanager
+ if ! use networkmanager; then
+ sed -i -e '/^networkmanager_enabled =/s:yes:no:' config.pri || die
+ fi
+ # fix automagic dependency on pulseaudio
+ if ! use pulseaudio; then
+ sed -i -e '/^pulseaudio_enabled =/s:yes:no:' config.pri || die
+ fi
+
+ eqmake4 -recursive
+}
+
+src_compile() {
+ qt4-r2_src_compile
+
+ use doc && emake docs
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ if use doc; then
+ dohtml -r doc/html/*
+ dodoc doc/qch/qtmobility.qch
+ docompress -x /usr/share/doc/${PF}/qtmobility.qch
+ fi
+}