summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-01 20:56:43 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-01 20:56:43 +0000
commit1809780b1705519bbacd2ab642f46e435d552045 (patch)
tree9fa9624059f1ec0f22c79ad4cdc13628257c6ac9 /x11-libs
parentUpdated libpixman dependency. Bug # 75185. (Manifest recommit) (diff)
downloadgentoo-2-1809780b1705519bbacd2ab642f46e435d552045.tar.gz
gentoo-2-1809780b1705519bbacd2ab642f46e435d552045.tar.bz2
gentoo-2-1809780b1705519bbacd2ab642f46e435d552045.zip
fix USE=static usage and lib install
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xclass/xclass-0.8.2-r1.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/x11-libs/xclass/xclass-0.8.2-r1.ebuild b/x11-libs/xclass/xclass-0.8.2-r1.ebuild
index 6c1a79dfc7c3..7fcf3d02076e 100644
--- a/x11-libs/xclass/xclass-0.8.2-r1.ebuild
+++ b/x11-libs/xclass/xclass-0.8.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xclass/xclass-0.8.2-r1.ebuild,v 1.4 2004/06/28 19:45:27 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xclass/xclass-0.8.2-r1.ebuild,v 1.5 2005/01/01 20:56:43 vapier Exp $
DESCRIPTION="a C++ GUI toolkit for the X windows environment"
HOMEPAGE="http://xclass.sourceforge.net/"
@@ -9,7 +9,7 @@ SRC_URI="ftp://mitac11.uia.ac.be/pub/xclass/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha"
-IUSE="static"
+IUSE=""
DEPEND="virtual/x11
virtual/libc
@@ -31,32 +31,28 @@ src_unpack() {
src_compile() {
econf --enable-shared=yes --with-x || die
- if use static ; then
- emake || die "'emake' failed"
- else
- emake shared || die "'emake shared' failed"
- fi
+ emake || die "'emake' failed"
}
src_install() {
rm -rf `find . -name 'Makefile*'`
- dobin config/xc-config || die
+ dobin config/xc-config || die "xc-config failed"
insinto /etc
- doins doc/xclassrc || die
+ doins doc/xclassrc || die "xclassrc failed"
newins doc/mime.types xclass.mime.types || die
dodoc doc/*
dodir /usr/share/icons/xclass
insinto /usr/share/icons/xclass
- mv "icons/Lock screen.s.xpm" ${D}/usr/share/icons/xclass/
- doins icons/*.xpm || die
+ doins icons/*.xpm || die "icons failed"
dodir /usr/include/xclass
insinto /usr/include/xclass
- doins include/xclass/*.h || die
+ doins include/xclass/*.h || die "include failed"
- dolib lib/libxclass/lib* || die
+ cd lib/libxclass
+ dolib libxclass* || die "lib failed"
}