summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 15:57:58 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 15:57:58 +0000
commit1703eb3620f0c0d74ba98219341374951ada7c08 (patch)
treee5d41a24c101ab7810cbe6bd4413828f48db0193 /x11-libs
parentStable for arm, wrt bug #458984 (diff)
downloadgentoo-2-1703eb3620f0c0d74ba98219341374951ada7c08.tar.gz
gentoo-2-1703eb3620f0c0d74ba98219341374951ada7c08.tar.bz2
gentoo-2-1703eb3620f0c0d74ba98219341374951ada7c08.zip
Version bump
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gdk-pixbuf/ChangeLog7
-rw-r--r--x11-libs/gdk-pixbuf/gdk-pixbuf-2.28.0.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/x11-libs/gdk-pixbuf/ChangeLog b/x11-libs/gdk-pixbuf/ChangeLog
index f581f3b969eb..00032d6e6f09 100644
--- a/x11-libs/gdk-pixbuf/ChangeLog
+++ b/x11-libs/gdk-pixbuf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/gdk-pixbuf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gdk-pixbuf/ChangeLog,v 1.81 2013/03/03 09:02:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gdk-pixbuf/ChangeLog,v 1.82 2013/03/28 15:57:58 pacho Exp $
+
+*gdk-pixbuf-2.28.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +gdk-pixbuf-2.28.0.ebuild:
+ Version bump
03 Mar 2013; Mike Frysinger <vapier@gentoo.org> gdk-pixbuf-2.26.4.ebuild,
gdk-pixbuf-2.26.5.ebuild:
diff --git a/x11-libs/gdk-pixbuf/gdk-pixbuf-2.28.0.ebuild b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.28.0.ebuild
new file mode 100644
index 000000000000..83b786a72bd7
--- /dev/null
+++ b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.28.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gdk-pixbuf/gdk-pixbuf-2.28.0.ebuild,v 1.1 2013/03/28 15:57:58 pacho Exp $
+
+EAPI="5"
+inherit eutils gnome.org multilib libtool
+
+DESCRIPTION="Image loading library for GTK+"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+X debug +introspection jpeg jpeg2k tiff test"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.34.0:2
+ >=media-libs/libpng-1.4:0=
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3 )
+ jpeg? ( virtual/jpeg:= )
+ jpeg2k? ( media-libs/jasper:= )
+ tiff? ( >=media-libs/tiff-3.9.2:0= )
+ X? ( x11-libs/libX11 )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.11
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig"
+# librsvg blocker is for the new pixbuf loader API, you lose icons otherwise
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gail-1000
+ !<gnome-base/librsvg-2.31.0
+ !<x11-libs/gtk+-2.21.3:2
+ !<x11-libs/gtk+-2.90.4:3"
+
+src_prepare() {
+ # This will avoid polluting the pkg-config file with versioned libpng,
+ # which is causing problems with libpng14 -> libpng15 upgrade
+ # See upstream bug #667068
+ sed -e 's:libpng15:libpng libpng15:' \
+ -i configure || die
+ default
+ elibtoolize # for Darwin modules
+}
+
+src_configure() {
+ # png always on to display icons (foser)
+ econf \
+ $(usex debug --enable-debug=yes "") \
+ $(use_with jpeg libjpeg) \
+ $(use_with jpeg2k libjasper) \
+ $(use_with tiff libtiff) \
+ $(use_enable introspection) \
+ $(use_with X x11) \
+ --with-libpng
+}
+
+src_install() {
+ default
+ dodoc AUTHORS NEWS* README*
+ prune_libtool_files --modules
+}
+
+pkg_postinst() {
+ # causes segfault if set, see bug 375615
+ unset __GL_NO_DSO_FINALIZER
+
+ tmp_file=$(mktemp -t tmp_gdk_pixbuf_ebuild.XXXXXXXXXX)
+ # be atomic!
+ gdk-pixbuf-query-loaders > "${tmp_file}"
+ if [ "${?}" = "0" ]; then
+ cat "${tmp_file}" > "${EROOT}usr/$(get_libdir)/gdk-pixbuf-2.0/2.10.0/loaders.cache"
+ else
+ ewarn "Cannot update loaders.cache, gdk-pixbuf-query-loaders failed to run"
+ fi
+ rm "${tmp_file}"
+
+ if [ -e "${EROOT}"usr/lib/gtk-2.0/2.*/loaders ]; then
+ elog "You need to rebuild ebuilds that installed into" "${EROOT}"usr/lib/gtk-2.0/2.*/loaders
+ elog "to do that you can use qfile from portage-utils:"
+ elog "emerge -va1 \$(qfile -qC ${EPREFIX}/usr/lib/gtk-2.0/2.*/loaders)"
+ fi
+}