summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-11-21 09:29:11 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-11-21 09:29:11 +0000
commit0b2191e140911c2f8f43b74d9363d3f69e625656 (patch)
tree9541dabab0b7151b7d4d355dab0d633c153c7ca7 /x11-libs
parentBump, fixes #293915 (diff)
downloadgentoo-2-0b2191e140911c2f8f43b74d9363d3f69e625656.tar.gz
gentoo-2-0b2191e140911c2f8f43b74d9363d3f69e625656.tar.bz2
gentoo-2-0b2191e140911c2f8f43b74d9363d3f69e625656.zip
Version bump.
(Portage version: 2.2_rc50/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pixman/ChangeLog8
-rw-r--r--x11-libs/pixman/pixman-0.17.2.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/x11-libs/pixman/ChangeLog b/x11-libs/pixman/ChangeLog
index bd47bd7e34bb..8cb6b0258db4 100644
--- a/x11-libs/pixman/ChangeLog
+++ b/x11-libs/pixman/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/pixman
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/ChangeLog,v 1.51 2009/10/26 21:04:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/ChangeLog,v 1.52 2009/11/21 09:29:11 scarabeus Exp $
+
+*pixman-0.17.2 (21 Nov 2009)
+
+ 21 Nov 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +pixman-0.17.2.ebuild:
+ Version bump.
26 Oct 2009; Jeroen Roovers <jer@gentoo.org> pixman-0.16.0.ebuild:
Stable for HPPA (bug #282290).
diff --git a/x11-libs/pixman/pixman-0.17.2.ebuild b/x11-libs/pixman/pixman-0.17.2.ebuild
new file mode 100644
index 000000000000..b0eadc8ea7e2
--- /dev/null
+++ b/x11-libs/pixman/pixman-0.17.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/pixman-0.17.2.ebuild,v 1.1 2009/11/21 09:29:11 scarabeus Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular toolchain-funcs versionator
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/pixman"
+DESCRIPTION="Low-level pixel manipulation routines"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="altivec mmx sse2"
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="
+ $(use_enable altivec vmx)
+ --disable-gtk"
+
+ local enable_mmx="$(use mmx && echo 1 || echo 0)"
+ local enable_sse2="$(use sse2 && echo 1 || echo 0)"
+
+ # this block fixes bug #260287
+ if use x86; then
+ if use sse2 && ! $(version_is_at_least "4.2" "$(gcc-version)"); then
+ ewarn "SSE2 instructions require GCC 4.2 or higher."
+ ewarn "pixman will be built *without* SSE2 support"
+ enable_sse2="0"
+ fi
+ fi
+
+ # this block fixes bug #236558
+ case "$enable_mmx,$enable_sse2" in
+ '1,1')
+ CONFIGURE_OPTIONS="${CONFIGURE_OPTIONS} --enable-mmx --enable-sse2" ;;
+ '1,0')
+ CONFIGURE_OPTIONS="${CONFIGURE_OPTIONS} --enable-mmx --disable-sse2" ;;
+ '0,1')
+ ewarn "You enabled SSE2 but have MMX disabled. This is an invalid."
+ ewarn "pixman will be built *without* MMX/SSE2 support."
+ CONFIGURE_OPTIONS="${CONFIGURE_OPTIONS} --disable-mmx --disable-sse2" ;;
+ '0,0')
+ CONFIGURE_OPTIONS="${CONFIGURE_OPTIONS} --disable-mmx --disable-sse2" ;;
+ esac
+}