summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-07-25 22:20:56 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-07-25 22:20:56 +0000
commit0a8257cfb3b1de40a8694491f806099c17bb5714 (patch)
tree8d778d4b53f5755543b867c6314107314fcfde7c /x11-libs
parentFix compilation with gcc-4.4; bug #276742 (diff)
downloadgentoo-2-0a8257cfb3b1de40a8694491f806099c17bb5714.tar.gz
gentoo-2-0a8257cfb3b1de40a8694491f806099c17bb5714.tar.bz2
gentoo-2-0a8257cfb3b1de40a8694491f806099c17bb5714.zip
Fix compilation with gcc-4.4; bug #272417
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qwtplot3d/ChangeLog6
-rw-r--r--x11-libs/qwtplot3d/files/qwtplot3d-gcc44.patch12
-rw-r--r--x11-libs/qwtplot3d/qwtplot3d-0.2.7-r1.ebuild3
3 files changed, 19 insertions, 2 deletions
diff --git a/x11-libs/qwtplot3d/ChangeLog b/x11-libs/qwtplot3d/ChangeLog
index f41c5376eefb..8cfaa81c2a55 100644
--- a/x11-libs/qwtplot3d/ChangeLog
+++ b/x11-libs/qwtplot3d/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qwtplot3d
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtplot3d/ChangeLog,v 1.16 2009/04/08 07:57:55 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtplot3d/ChangeLog,v 1.17 2009/07/25 22:20:56 halcy0n Exp $
+
+ 25 Jul 2009; Mark Loeser <halcy0n@gentoo.org>
+ +files/qwtplot3d-gcc44.patch, qwtplot3d-0.2.7-r1.ebuild:
+ Fix compilation with gcc-4.4; bug #272417
08 Apr 2009; Sébastien Fabbro <bicatali@gentoo.org>
files/qwtplot3d-sys-gl2ps.patch:
diff --git a/x11-libs/qwtplot3d/files/qwtplot3d-gcc44.patch b/x11-libs/qwtplot3d/files/qwtplot3d-gcc44.patch
new file mode 100644
index 000000000000..a76fe831ab91
--- /dev/null
+++ b/x11-libs/qwtplot3d/files/qwtplot3d-gcc44.patch
@@ -0,0 +1,12 @@
+diff -ur qwtplot3d-orig/include/qwt3d_function.h qwtplot3d/include/qwt3d_function.h
+--- qwtplot3d-orig/include/qwt3d_function.h 2009-07-25 18:18:58.000000000 -0400
++++ qwtplot3d/include/qwt3d_function.h 2009-07-25 18:19:19.000000000 -0400
+@@ -2,6 +2,7 @@
+ #define qwt3d_function_h__2004_03_05_13_51_begin_guarded_code
+
+ #include "qwt3d_gridmapping.h"
++#include <cstdio>
+
+ namespace Qwt3D
+ {
+Only in qwtplot3d/tmp: qwt3d_function.o
diff --git a/x11-libs/qwtplot3d/qwtplot3d-0.2.7-r1.ebuild b/x11-libs/qwtplot3d/qwtplot3d-0.2.7-r1.ebuild
index 1b505fa2223a..7df585a399ad 100644
--- a/x11-libs/qwtplot3d/qwtplot3d-0.2.7-r1.ebuild
+++ b/x11-libs/qwtplot3d/qwtplot3d-0.2.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtplot3d/qwtplot3d-0.2.7-r1.ebuild,v 1.1 2009/04/07 18:51:30 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtplot3d/qwtplot3d-0.2.7-r1.ebuild,v 1.2 2009/07/25 22:20:56 halcy0n Exp $
EAPI=2
inherit eutils qt4
@@ -27,6 +27,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-examples.patch
epatch "${FILESDIR}"/${PN}-doxygen.patch
epatch "${FILESDIR}"/${PN}-sys-gl2ps.patch
+ epatch "${FILESDIR}"/${PN}-gcc44.patch
cat >> ${PN}.pro <<-EOF
target.path = /usr/$(get_libdir)
headers.path = /usr/include/${PN}