summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-22 09:44:42 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-22 09:44:42 +0000
commit0a3f040d550d563239169162505c1704cb0eb9ab (patch)
treef1d27dee2e6efb38dd9d99b31e2171427d77b88b /x11-libs
parentInitial import (bug #359587). (diff)
downloadgentoo-2-0a3f040d550d563239169162505c1704cb0eb9ab.tar.gz
gentoo-2-0a3f040d550d563239169162505c1704cb0eb9ab.tar.bz2
gentoo-2-0a3f040d550d563239169162505c1704cb0eb9ab.zip
Backport fltk-config --includedir from 1.3.0, thanks rei4dan pointing on this
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/fltk/ChangeLog8
-rw-r--r--x11-libs/fltk/files/fltk-1.1.10-includedir.patch45
-rw-r--r--x11-libs/fltk/fltk-1.1.10-r2.ebuild140
3 files changed, 192 insertions, 1 deletions
diff --git a/x11-libs/fltk/ChangeLog b/x11-libs/fltk/ChangeLog
index 0d0e5692b334..d875a3ef2267 100644
--- a/x11-libs/fltk/ChangeLog
+++ b/x11-libs/fltk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/fltk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.174 2011/03/20 19:52:10 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.175 2011/03/22 09:44:42 jlec Exp $
+
+*fltk-1.1.10-r2 (22 Mar 2011)
+
+ 22 Mar 2011; Justin Lecher <jlec@gentoo.org> +fltk-1.1.10-r2.ebuild,
+ +files/fltk-1.1.10-includedir.patch:
+ Backport fltk-config --includedir from 1.3.0, thanks rei4dan pointing on this
20 Mar 2011; Justin Lecher <jlec@gentoo.org> fltk-1.1.9-r1.ebuild,
fltk-1.1.9-r2.ebuild, fltk-1.1.10-r1.ebuild, fltk-1.3.0_rc3-r1.ebuild:
diff --git a/x11-libs/fltk/files/fltk-1.1.10-includedir.patch b/x11-libs/fltk/files/fltk-1.1.10-includedir.patch
new file mode 100644
index 000000000000..dac9e755ed45
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.1.10-includedir.patch
@@ -0,0 +1,45 @@
+ fltk-config.in | 17 +++++++++++++++++
+ 1 files changed, 17 insertions(+), 0 deletions(-)
+
+diff --git a/fltk-config.in b/fltk-config.in
+index b716d35..2251734 100755
+--- a/fltk-config.in
++++ b/fltk-config.in
+@@ -118,6 +118,8 @@ Options telling what information we request:
+ [--ldstaticflags] return flags to link against static FLTK library
+ even if there are DSOs installed
+ [--libs] return FLTK libraries full path for dependencies
++ [--prefix] return FLTK install time --prefix directory
++ [--includedir] return FLTK install time include directory
+
+ Option to compile and link an application:
+ [-g] compile the program with debugging information
+@@ -189,6 +191,12 @@ do
+ --libs)
+ echo_libs=yes
+ ;;
++ --prefix)
++ echo_prefix=yes
++ ;;
++ --includedir)
++ echo_includedir=yes
++ ;;
+ -g)
+ debug=-g
+ ;;
+@@ -337,6 +345,15 @@ if test "$echo_libs" = "yes"; then
+ fi
+ done
+ fi
++ echo $USELIBS
++fi
++
++if test "$echo_prefix" = "yes"; then
++ echo $prefix
++fi
++
++if test "$echo_includedir" = "yes"; then
++ echo $includedir
+ fi
+
+ #
diff --git a/x11-libs/fltk/fltk-1.1.10-r2.ebuild b/x11-libs/fltk/fltk-1.1.10-r2.ebuild
new file mode 100644
index 000000000000..8a05f55fe0a1
--- /dev/null
+++ b/x11-libs/fltk/fltk-1.1.10-r2.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.1.10-r2.ebuild,v 1.1 2011/03/22 09:44:42 jlec Exp $
+
+EAPI=3
+
+inherit eutils autotools versionator fdo-mime
+
+DESCRIPTION="C++ user interface toolkit for X and OpenGL"
+HOMEPAGE="http://www.fltk.org/"
+SRC_URI="mirror://easysw/${PN}/${PV}/${P}-source.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="FLTK LGPL-2"
+
+SLOT="1"
+
+IUSE="debug doc examples games opengl threads xft xinerama"
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXt
+ virtual/jpeg
+ media-libs/libpng
+ sys-libs/zlib
+ opengl? ( virtual/opengl )
+ xinerama? ( x11-libs/libXinerama )
+ xft? ( x11-libs/libXft )
+ !prefix? ( >=sys-libs/glibc-2.10 )" # glibc-2.10 patch breaks with 2.9, bug 276695
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ doc? ( app-text/htmldoc )
+ xinerama? ( x11-proto/xineramaproto )"
+
+INCDIR=${EPREFIX}/usr/include/fltk-${SLOT}
+LIBDIR=${EPREFIX}/usr/$(get_libdir)/fltk-${SLOT}
+
+src_prepare() {
+ # backported from 1.3.0
+ epatch "${FILESDIR}"/${P}-includedir.patch
+ epatch "${FILESDIR}"/fltk-1.1.9-share.patch
+ #epatch "${FILESDIR}"/${P}-fromdebian.patch
+ epatch "${FILESDIR}"/${PN}-1.1.9-desktop.patch
+ epatch "${FILESDIR}"/${PN}-1.1.9-as-needed.patch
+ # prevent to run twice configure (needs eautoconf), to compile tests,
+ # remove forced -Os compile
+ epatch "${FILESDIR}"/${PN}-1.1.9-conf-tests.patch
+ # fix stricter c++ handling in glibc-2.10/gcc-4.4 (bug 270487)
+ epatch "${FILESDIR}"/${PN}-1.1.9-glibc2.10-scandir.patch
+ # remove forced flags from fltk-config
+ sed -i \
+ -e '/C\(XX\)\?FLAGS=/s:@C\(XX\)\?FLAGS@::' \
+ -e '/^LDFLAGS=/d' \
+ "${S}/fltk-config.in" || die
+ # some fixes introduced because slotting
+ sed -i \
+ -e '/RANLIB/s:$(libdir)/\(.*LIBNAME)\):$(libdir)/`basename \1`:g' \
+ src/Makefile || die
+ # docs in proper docdir
+ sed -i \
+ -e "/^docdir/s:fltk:${PF}/html:" \
+ makeinclude.in || die
+ sed -e "s/7/$(get_version_component_range 3)/" \
+ "${FILESDIR}"/FLTKConfig.cmake > CMake/FLTKConfig.cmake
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ --includedir=${INCDIR}\
+ --libdir=${LIBDIR} \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --enable-largefile \
+ --enable-shared \
+ --enable-xdbe \
+ --disable-localjpeg \
+ --disable-localpng \
+ --disable-localzlib \
+ $(use_enable debug) \
+ $(use_enable opengl gl) \
+ $(use_enable threads) \
+ $(use_enable xft) \
+ $(use_enable xinerama)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ cd "${S}"/documentation
+ emake alldocs || die "emake doc failed"
+ fi
+ if use games; then
+ cd "${S}"/test
+ emake blocks checkers sudoku || die "emake games failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ emake -C fluid \
+ DESTDIR="${D}" install-linux || die "emake install fluid failed"
+ if use doc; then
+ emake -C documentation \
+ DESTDIR="${D}" install || die "emake install doc failed"
+ fi
+ local apps="fluid"
+ if use games; then
+ emake -C test \
+ DESTDIR="${D}" install-linux || die "emake install games failed"
+ emake -C documentation \
+ DESTDIR="${D}" install-linux || die "emake install doc games failed"
+ apps="${apps} sudoku blocks checkers"
+ fi
+ for app in ${apps}; do
+ dosym /usr/share/icons/hicolor/32x32/apps/${app}.png \
+ /usr/share/pixmaps/${app}.png
+ done
+ dodoc CHANGES README CREDITS ANNOUNCEMENT
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins test/*.{h,cxx,fl} test/demo.menu
+ fi
+
+ insinto /usr/share/cmake/Modules
+ doins CMake/FLTK*.cmake
+
+ echo "LDPATH=${LIBDIR}" > 99fltk-${SLOT}
+ echo "FLTK_DOCDIR=${EPREFIX}/usr/share/doc/${PF}/html" >> 99fltk-${SLOT}
+ doenvd 99fltk-${SLOT}
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}