summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-11-30 00:56:39 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-11-30 00:56:39 +0000
commit09927965f3613e4ddd9d0c6118e7026ca25c873d (patch)
tree4e5dfa914ea91bfb867e2007490e8745fd8c3e63 /x11-libs
parentReadding pch local USE flag to x11-libs/wxGTK. (diff)
downloadgentoo-2-09927965f3613e4ddd9d0c6118e7026ca25c873d.tar.gz
gentoo-2-09927965f3613e4ddd9d0c6118e7026ca25c873d.tar.bz2
gentoo-2-09927965f3613e4ddd9d0c6118e7026ca25c873d.zip
Re-add local pch USE flag.
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/wxGTK/ChangeLog6
-rw-r--r--x11-libs/wxGTK/wxGTK-2.6.4.0-r2.ebuild6
-rw-r--r--x11-libs/wxGTK/wxGTK-2.8.6.1.ebuild6
3 files changed, 11 insertions, 7 deletions
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index 344d4c9da101..5d5f6a2af8e1 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.163 2007/11/29 01:48:29 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.164 2007/11/30 00:56:39 dirtyepic Exp $
+
+ 30 Nov 2007; Ryan Hill <dirtyepic@gentoo.org> wxGTK-2.6.4.0-r2.ebuild,
+ wxGTK-2.8.6.1.ebuild:
+ Re-add local pch USE flag.
*wxGTK-2.8.6.1 (29 Nov 2007)
diff --git a/x11-libs/wxGTK/wxGTK-2.6.4.0-r2.ebuild b/x11-libs/wxGTK/wxGTK-2.6.4.0-r2.ebuild
index 51014de10e3c..5aa1fc61e83f 100644
--- a/x11-libs/wxGTK/wxGTK-2.6.4.0-r2.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.6.4.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.6.4.0-r2.ebuild,v 1.3 2007/11/24 16:14:18 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.6.4.0-r2.ebuild,v 1.4 2007/11/30 00:56:39 dirtyepic Exp $
inherit eutils versionator flag-o-matic
@@ -16,7 +16,7 @@ SRC_URI="mirror://sourceforge/wxpython/wxPython-src-${PV}.tar.bz2
doc? ( mirror://sourceforge/wxwindows/wxWidgets-${BASE_PV}-HTML.tar.gz )"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="X doc debug gnome odbc opengl sdl unicode"
+IUSE="X doc debug gnome odbc opengl pch sdl unicode"
RDEPEND="
dev-libs/expat
@@ -86,7 +86,7 @@ src_compile() {
--with-regex=builtin
--with-zlib=sys
--with-expat
- --disable-precomp-headers
+ $(use_enable pch precomp-headers)
$(use_with sdl)
$(use_with odbc)"
diff --git a/x11-libs/wxGTK/wxGTK-2.8.6.1.ebuild b/x11-libs/wxGTK/wxGTK-2.8.6.1.ebuild
index 56af14055d07..b50a32a0777c 100644
--- a/x11-libs/wxGTK/wxGTK-2.8.6.1.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.8.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.8.6.1.ebuild,v 1.1 2007/11/29 01:48:30 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.8.6.1.ebuild,v 1.2 2007/11/30 00:56:39 dirtyepic Exp $
EAPI=1
@@ -18,7 +18,7 @@ SRC_URI="mirror://sourceforge/wxpython/wxPython-src-${PV}.tar.bz2
doc? ( mirror://sourceforge/wxwindows/wxWidgets-${BASE_PV}-HTML.zip )"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="X doc debug gnome gstreamer odbc opengl sdl"
+IUSE="X doc debug gnome gstreamer odbc opengl pch sdl"
RDEPEND="
dev-libs/expat
@@ -88,8 +88,8 @@ src_compile() {
--with-regex=builtin
--with-zlib=sys
--with-expat
- --disable-precomp-headers
$(use_enable debug)
+ $(use_enable pch precomp-headers)
$(use_with sdl)
$(use_with odbc)"