summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-24 00:21:30 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-24 00:21:30 +0000
commit070b9fff87d206963d3768642db6c730c4e6f28c (patch)
tree1416b3241b6fc956e892c85c0f57e6118f50b7b0 /x11-libs
parentQA - fix use invocation, run gnuconfig_update everywhere instead of select ar... (diff)
downloadgentoo-2-070b9fff87d206963d3768642db6c730c4e6f28c.tar.gz
gentoo-2-070b9fff87d206963d3768642db6c730c4e6f28c.tar.bz2
gentoo-2-070b9fff87d206963d3768642db6c730c4e6f28c.zip
QA - fix use invocation
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-embedded/ChangeLog6
-rw-r--r--x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild8
-rw-r--r--x11-libs/qt-embedded/qt-embedded-3.1.2.ebuild8
-rw-r--r--x11-libs/wxGTK/ChangeLog6
-rw-r--r--x11-libs/wxGTK/wxGTK-2.4.0.ebuild6
-rw-r--r--x11-libs/wxGTK/wxGTK-2.4.1-r1.ebuild6
-rw-r--r--x11-libs/wxGTK/wxGTK-2.5.1.ebuild13
7 files changed, 32 insertions, 21 deletions
diff --git a/x11-libs/qt-embedded/ChangeLog b/x11-libs/qt-embedded/ChangeLog
index 948ae39fb7db..ff8ffa570904 100644
--- a/x11-libs/qt-embedded/ChangeLog
+++ b/x11-libs/qt-embedded/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-embedded
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-embedded/ChangeLog,v 1.4 2004/04/17 23:02:17 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-embedded/ChangeLog,v 1.5 2004/06/24 00:20:49 agriffis Exp $
+
+ 23 Jun 2004; Aron Griffis <agriffis@gentoo.org> qt-embedded-3.0.5.ebuild,
+ qt-embedded-3.1.2.ebuild:
+ QA - fix use invocation
17 Apr 2004; Daniel Ahlberg <aliz@gentoo.org> qt-embedded-3.0.5.ebuild,
qt-embedded-3.1.2.ebuild:
diff --git a/x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild b/x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild
index 247d474f9b1c..76f1b0c7f378 100644
--- a/x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild
+++ b/x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild,v 1.11 2004/04/17 23:02:17 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild,v 1.12 2004/06/24 00:20:49 agriffis Exp $
DESCRIPTION="QT version ${PV}"
HOMEPAGE="http://www.trolltech.com/"
@@ -29,7 +29,7 @@ QTBASE=/usr/qt/3-embedded
export QTDIR=${S}
pkg_setup() {
- if [ `use build` ] ; then
+ if use build ; then
return 0
else
ewarn "Note: this will build a rather bloated qt/e, with all features enabled."
@@ -54,7 +54,7 @@ src_compile() {
export YACC='byacc -d'
export LDFLAGS="-ldl"
- if [ -z "`use build`" ]; then
+ if ! use build; then
# ordinary setup, rather bloated
use gif && myconf="${myconf} -qt-gif"
use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
@@ -62,7 +62,7 @@ src_compile() {
use odbc && myconf="${myconf} -plugin-sql-odbc"
use debug && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
- if [ "`use x86`" ]; then
+ if use x86; then
myconf="$myconf -embedded x86" # -xplatform linux-g++ -platform linux-g++"
else
# and i've no idea if it'll work
diff --git a/x11-libs/qt-embedded/qt-embedded-3.1.2.ebuild b/x11-libs/qt-embedded/qt-embedded-3.1.2.ebuild
index 9228aeaf87b2..c0fea1e616b8 100644
--- a/x11-libs/qt-embedded/qt-embedded-3.1.2.ebuild
+++ b/x11-libs/qt-embedded/qt-embedded-3.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-embedded/qt-embedded-3.1.2.ebuild,v 1.6 2004/04/17 23:02:17 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-embedded/qt-embedded-3.1.2.ebuild,v 1.7 2004/06/24 00:20:49 agriffis Exp $
DESCRIPTION="QT version ${PV}"
HOMEPAGE="http://www.trolltech.com/"
@@ -29,7 +29,7 @@ QTBASE=/usr/qt/3-embedded
export QTDIR=${S}
pkg_setup() {
- if [ `use build` ] ; then
+ if use build ; then
return 0
else
ewarn "Note: this will build a rather bloated qt/e, with all features enabled."
@@ -54,7 +54,7 @@ src_compile() {
export YACC='byacc -d'
export LDFLAGS="-ldl"
- if [ -z "`use build`" ]; then
+ if ! use build; then
# ordinary setup, rather bloated
use gif && myconf="${myconf} -qt-gif"
use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
@@ -62,7 +62,7 @@ src_compile() {
use odbc && myconf="${myconf} -plugin-sql-odbc"
use debug && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
- if [ "`use x86`" ]; then
+ if use x86; then
myconf="$myconf -embedded x86" # -xplatform linux-g++ -platform linux-g++"
else
# and i've no idea if it'll work
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index 0e1eeaf36b39..cb5445383ff1 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.51 2004/06/23 05:41:53 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.52 2004/06/24 00:19:16 agriffis Exp $
+
+ 23 Jun 2004; Aron Griffis <agriffis@gentoo.org> wxGTK-2.4.0.ebuild,
+ wxGTK-2.4.1-r1.ebuild, wxGTK-2.5.1.ebuild:
+ QA - fix use invocation
*wxGTK-2.4.2-r1 (22 Jun 2004)
diff --git a/x11-libs/wxGTK/wxGTK-2.4.0.ebuild b/x11-libs/wxGTK/wxGTK-2.4.0.ebuild
index 9a1d10bf2994..9d0fea5e797b 100644
--- a/x11-libs/wxGTK/wxGTK-2.4.0.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.4.0.ebuild,v 1.16 2004/04/26 14:43:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.4.0.ebuild,v 1.17 2004/06/24 00:19:16 agriffis Exp $
DESCRIPTION="GTK+ version of wxWindows, a cross-platform C++ GUI toolkit."
SRC_URI="mirror://sourceforge/wxwindows/${P}.tar.bz2"
@@ -58,9 +58,9 @@ src_compile() {
# We only use --enable-unicode (if at all) when we use
# gtk2.
- if [ `use odbc` ] && [ ! `use gtk2` ]; then
+ if use odbc && ! use gtk2; then
myconf="${myconf} --with-odbc"
- elif [ `use odbc` ] && [ `use gtk2` ]; then
+ elif use odbc && use gtk2; then
ewarn ""
einfo "you cannot specify both odbc and gtk2"
einfo "Choosing gtk2 over odbc"
diff --git a/x11-libs/wxGTK/wxGTK-2.4.1-r1.ebuild b/x11-libs/wxGTK/wxGTK-2.4.1-r1.ebuild
index 34a4d0e6a59e..21c9fd697f17 100644
--- a/x11-libs/wxGTK/wxGTK-2.4.1-r1.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.4.1-r1.ebuild,v 1.10 2004/04/26 14:43:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.4.1-r1.ebuild,v 1.11 2004/06/24 00:19:16 agriffis Exp $
inherit eutils
@@ -55,9 +55,9 @@ src_compile() {
# gtk2.
- if [ `use odbc` ] && [ ! `use gtk2` ]; then
+ if use odbc && ! use gtk2; then
myconf="${myconf} --with-odbc"
- elif [ `use odbc` ] && [ `use gtk2` ]; then
+ elif use odbc && use gtk2; then
ewarn ""
einfo "you cannot specify both odbc and gtk2"
einfo "Choosing gtk2 over odbc"
diff --git a/x11-libs/wxGTK/wxGTK-2.5.1.ebuild b/x11-libs/wxGTK/wxGTK-2.5.1.ebuild
index cca44647e88f..6970e2bb2d7c 100644
--- a/x11-libs/wxGTK/wxGTK-2.5.1.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.5.1.ebuild,v 1.1 2004/06/22 21:45:50 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.5.1.ebuild,v 1.2 2004/06/24 00:19:16 agriffis Exp $
DESCRIPTION="GTK+ version of wxWindows, a cross-platform C++ GUI toolkit."
SRC_URI="mirror://sourceforge/wxwindows/${P}.tar.bz2"
@@ -49,10 +49,13 @@ src_compile() {
# bug #20116 - liquidx@gentoo.org (07 May 2003)
use gtk2 && myconf="${myconf} --enable-gtk2"
- # only allow unicode if using gtk2
- [ -n "`use gtk2`" -a -n "`use unicode`" ] && myconf="${myconf} --enable-unicode"
- # only enable odbc if unicode is not enabled.
- [ -n "`use gtk2`" -a -n "`use unicode`" ] || myconf="${myconf} `use_with odbc`"
+ if use gtk2 && use unicode; then
+ # only allow unicode if using gtk2
+ myconf="${myconf} --enable-unicode"
+ else
+ # only enable odbc if unicode is not enabled.
+ myconf="${myconf} `use_with odbc`"
+ fi
econf ${myconf}
emake || die "make failed"