summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2011-11-28 23:47:18 +0000
committerDavide Pesavento <pesa@gentoo.org>2011-11-28 23:47:18 +0000
commit064574c7df2c22be9dedb22a9cef984cabf92099 (patch)
treea86de9f8d7e7276a4c56e3890582eaf865aac5e0 /x11-libs
parentRemove Qt 4.7.3 (diff)
downloadgentoo-2-064574c7df2c22be9dedb22a9cef984cabf92099.tar.gz
gentoo-2-064574c7df2c22be9dedb22a9cef984cabf92099.tar.bz2
gentoo-2-064574c7df2c22be9dedb22a9cef984cabf92099.zip
Remove Qt 4.7.3
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-assistant/ChangeLog5
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.7.3.ebuild115
2 files changed, 4 insertions, 116 deletions
diff --git a/x11-libs/qt-assistant/ChangeLog b/x11-libs/qt-assistant/ChangeLog
index cd785cb0c1e8..80ed19d48aba 100644
--- a/x11-libs/qt-assistant/ChangeLog
+++ b/x11-libs/qt-assistant/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/qt-assistant
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.113 2011/11/26 19:57:56 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.114 2011/11/28 23:47:18 pesa Exp $
+
+ 28 Nov 2011; Davide Pesavento <pesa@gentoo.org> -qt-assistant-4.7.3.ebuild:
+ Remove Qt 4.7.3
26 Nov 2011; Robin H. Johnson <robbat2@gentoo.org> Manifest:
Bug 385719: upstream altered qt-everywhere-opensource-src-4.7.4.tar.gz, mass
diff --git a/x11-libs/qt-assistant/qt-assistant-4.7.3.ebuild b/x11-libs/qt-assistant/qt-assistant-4.7.3.ebuild
deleted file mode 100644
index 41cbbbba6174..000000000000
--- a/x11-libs/qt-assistant/qt-assistant-4.7.3.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.7.3.ebuild,v 1.2 2011/05/12 19:11:59 grobian Exp $
-
-EAPI="3"
-inherit qt4-build
-
-DESCRIPTION="The assistant help module for the Qt toolkit"
-SLOT="4"
-KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~ppc-macos"
-IUSE="compat doc +glib qt3support trace"
-SRC_URI+=" compat? ( ftp://ftp.qt.nokia.com/qt/source/${PN}-qassistantclient-library-compat-src-4.6.3.tar.gz )"
-
-DEPEND="~x11-libs/qt-gui-${PV}[aqua=,debug=,glib=,qt3support=,trace?]
- ~x11-libs/qt-sql-${PV}[aqua=,debug=,qt3support=,sqlite]
- ~x11-libs/qt-webkit-${PV}[aqua=,debug=]
- ~x11-libs/qt-declarative-${PV}[debug=,qt3support=]"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- # Pixeltool isn't really assistant related, but it relies on
- # the assistant libraries. doc/qch/
- QT4_TARGET_DIRECTORIES="
- tools/assistant
- tools/pixeltool
- tools/qdoc3"
- QT4_EXTRACT_DIRECTORIES="
- tools/
- demos/
- examples/
- src/
- include/
- doc/"
-
- use trace && QT4_TARGET_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
- tools/qttracereplay"
- QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
- ${QT4_EXTRACT_DIRECTORIES}"
- qt4-build_pkg_setup
-}
-
-src_unpack() {
- qt4-build_src_unpack
- # compat version
- # http://labs.qt.nokia.com/2010/06/22/qt-assistant-compat-version-available-as-extra-source-package/
- if use compat; then
- unpack "${PN}"-qassistantclient-library-compat-src-4.6.3.tar.gz
- mv "${WORKDIR}"/"${PN}"-qassistantclient-library-compat-version-4.6.3 \
- "${S}"/tools/assistant/compat ||
- die "moving compat to the right place failed"
- tar xzf "${FILESDIR}"/"${PN}"-4.7-include.tar.gz -C "${S}"/include/ ||
- die "unpacking the include files failed"
- fi
-}
-
-src_prepare() {
- qt4-build_src_prepare
- if use compat; then
- epatch "${FILESDIR}"/"${PN}"-4.7-fix-compat.patch
- fi
-}
-
-src_configure() {
- myconf="${myconf} -no-xkb -no-fontconfig -no-xrender -no-xrandr
- -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
- -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
- -no-libmng -no-libjpeg -no-openssl -system-zlib -no-phonon
- -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
- -no-fontconfig -no-multimedia -no-svg $(qt_use qt3support)"
- ! use glib && myconf="${myconf} -no-glib"
- qt4-build_src_configure
-}
-
-src_compile() {
- # help libQtHelp find freshly built libQtCLucene (bug #289811)
- export LD_LIBRARY_PATH="${S}/lib:${QTLIBDIR}"
- export DYLD_LIBRARY_PATH="${S}/lib:${S}/lib/QtHelp.framework"
-
- qt4-build_src_compile
-
- # ugly hack to build docs
- cd "${S}"
- qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" projects.pro || die
- emake qch_docs || die "emake qch_docs failed"
- if use doc; then
- emake docs || die "emake docs failed"
- fi
- qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" projects.pro || die
-}
-
-src_install() {
- qt4-build_src_install
- cd "${S}"
- emake INSTALL_ROOT="${D}" install_qchdocs \
- || die "failed to install qch docs"
- if use doc; then
- emake INSTALL_ROOT="${D}" install_htmldocs \
- || die "failed to install htmldocs"
- fi
- dobin "${S}"/bin/qdoc3 || die "Failed to install qdoc3"
- # install correct assistant icon, bug 241208
- dodir /usr/share/pixmaps/ || die "dodir failed"
- insinto /usr/share/pixmaps/
- doins tools/assistant/tools/assistant/images/assistant.png ||
- die "doins failed"
- # Note: absolute image path required here!
- make_desktop_entry "${EPREFIX}"/usr/bin/assistant Assistant \
- "${EPREFIX}"/usr/share/pixmaps/assistant.png 'Qt;Development;GUIDesigner' ||
- die "make_desktop_entry failed"
-
- if use compat; then
- insinto /usr/share/qt4/mkspecs/features || die "insinto failed"
- doins tools/assistant/compat/features/assistant.prf || die "doins failed"
- fi
-}