summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-07-16 21:18:18 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-07-16 21:18:18 +0000
commit058b8c322d4affb2b04b8cfed4f7274115d645a3 (patch)
tree3a8315cf1982e568db10425976937ef0aef75163 /x11-libs
parentfixing slots (other kde-base pacakgse had it through the kde-dist eclass alre... (diff)
downloadgentoo-2-058b8c322d4affb2b04b8cfed4f7274115d645a3.tar.gz
gentoo-2-058b8c322d4affb2b04b8cfed4f7274115d645a3.tar.bz2
gentoo-2-058b8c322d4affb2b04b8cfed4f7274115d645a3.zip
Add --without-qt to configure. (Should fix bug #5074) QT2 is only needed to build an example program (examples/qt-viewer.cc).
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pango/ChangeLog12
-rw-r--r--x11-libs/pango/files/digest-pango-1.0.3-r11
-rw-r--r--x11-libs/pango/pango-1.0.3-r1.ebuild58
3 files changed, 70 insertions, 1 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index 8d7259f2560e..a29e11b43adf 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for x11-libs/pango
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.8 2002/07/16 00:00:40 owen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.9 2002/07/16 21:18:18 stroke Exp $
+
+
+*pango-1.0.3-r1 (16 Jul 2002)
+
+ 16 Jul 2002; Gabriele Giorgetti <stroke@gentoo.org> pango-1.0.3-r1:
+
+ Add --without-qt to configure. (Should fix bug #5074)
+ QT2 is only needed to build an example program
+ (examples/qt-viewer.cc).
+
*pango-1.0.3 (15 Jun 2002)
diff --git a/x11-libs/pango/files/digest-pango-1.0.3-r1 b/x11-libs/pango/files/digest-pango-1.0.3-r1
new file mode 100644
index 000000000000..37bdaa2586a0
--- /dev/null
+++ b/x11-libs/pango/files/digest-pango-1.0.3-r1
@@ -0,0 +1 @@
+MD5 5bb1904c4a7837ec5b8007501646302d pango-1.0.3.tar.bz2 763585
diff --git a/x11-libs/pango/pango-1.0.3-r1.ebuild b/x11-libs/pango/pango-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..4d43715cab74
--- /dev/null
+++ b/x11-libs/pango/pango-1.0.3-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.0.3-r1.ebuild,v 1.1 2002/07/16 21:18:18 stroke Exp $
+
+
+inherit debug
+inherit libtool
+
+SLOT="1"
+KEYWORDS="x86 ppc"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Text rendering and Layout library"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.0/${P}.tar.bz2"
+HOMEPAGE="http://www.pango.org/"
+LICENSE="LGPL-2.1"
+
+RDEPEND="virtual/x11
+ >=dev-libs/glib-2.0.4
+ >=media-libs/freetype-2.0.9"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )"
+
+
+src_compile() {
+ elibtoolize
+ local myconf
+ use doc && myconf="--enable-gtk-doc" || myconf="--disable-gtk-doc"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} \
+ --without-qt \
+ --enable-debug || die
+ # turn on debug again, glib dislikes not having it.
+ emake || make || die "paralell make and serial make failed"
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+ rm ${D}/etc/pango/pango.modules
+
+
+ dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS NEWS.pre-1-3 TODO*
+}
+
+pkg_postinst() {
+ pango-querymodules >/etc/pango/pango.modules
+}
+