summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2006-08-01 01:59:32 +0000
committerOlivier Fisette <ribosome@gentoo.org>2006-08-01 01:59:32 +0000
commitc25f8c9bd81014e41976baedb23c701250c54f05 (patch)
tree4a775e94a64ef16f3ed2bb0372f4ea05bacc0d53 /x11-libs/xview
parentFixed typo of eclass variable names (diff)
downloadgentoo-2-c25f8c9bd81014e41976baedb23c701250c54f05.tar.gz
gentoo-2-c25f8c9bd81014e41976baedb23c701250c54f05.tar.bz2
gentoo-2-c25f8c9bd81014e41976baedb23c701250c54f05.zip
Added dependencies on Lucida Bright and Sun Cursor fonts. (Fixes bug #67924.)
(Portage version: 2.1-r1)
Diffstat (limited to 'x11-libs/xview')
-rw-r--r--x11-libs/xview/ChangeLog8
-rw-r--r--x11-libs/xview/files/digest-xview-3.2-r66
-rw-r--r--x11-libs/xview/xview-3.2-r6.ebuild96
3 files changed, 109 insertions, 1 deletions
diff --git a/x11-libs/xview/ChangeLog b/x11-libs/xview/ChangeLog
index 4e4017dcd369..0bb854b73843 100644
--- a/x11-libs/xview/ChangeLog
+++ b/x11-libs/xview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/xview
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xview/ChangeLog,v 1.20 2006/03/16 06:24:52 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xview/ChangeLog,v 1.21 2006/08/01 01:59:32 ribosome Exp $
+
+*xview-3.2-r6 (01 Aug 2006)
+
+ 01 Aug 2006; Olivier Fisette <ribosome@gentoo.org> +xview-3.2-r6.ebuild:
+ Added dependencies on Lucida Bright and Sun Cursor fonts. (Fixes bug
+ #67924.) These fonts are no longer provided by virtual/x11.
16 Mar 2006; Donnie Berkholz <spyderous@gentoo.org>; xview-3.2.ebuild,
xview-3.2-r1.ebuild, xview-3.2-r3.ebuild, xview-3.2-r5.ebuild:
diff --git a/x11-libs/xview/files/digest-xview-3.2-r6 b/x11-libs/xview/files/digest-xview-3.2-r6
new file mode 100644
index 000000000000..f3a34206ae99
--- /dev/null
+++ b/x11-libs/xview/files/digest-xview-3.2-r6
@@ -0,0 +1,6 @@
+MD5 f804d91f5b154f95872a23e86d1a621e xview-3.2-gcc-4.1-v0.1.patch.bz2 8018
+RMD160 0387c073d7f4c8303467f3065ba2a573fdb6710e xview-3.2-gcc-4.1-v0.1.patch.bz2 8018
+SHA256 2b26f10122535eff43a4f87fc97ffb54eac88c312a3688b05bce806ce9a273ba xview-3.2-gcc-4.1-v0.1.patch.bz2 8018
+MD5 a61e7ce82cac041a2c613041dc003de5 xview-3.2p1.4-18c.tar.gz 3377010
+RMD160 2d77c7988a483871e0f316ccb03d3b82e9978c45 xview-3.2p1.4-18c.tar.gz 3377010
+SHA256 3bf4b77257881e7146b35fe674e4d4c4f2708cb58b947a17f099d12b166a60c5 xview-3.2p1.4-18c.tar.gz 3377010
diff --git a/x11-libs/xview/xview-3.2-r6.ebuild b/x11-libs/xview/xview-3.2-r6.ebuild
new file mode 100644
index 000000000000..62d6cbfa3695
--- /dev/null
+++ b/x11-libs/xview/xview-3.2-r6.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xview/xview-3.2-r6.ebuild,v 1.1 2006/08/01 01:59:32 ribosome Exp $
+
+inherit eutils
+
+DESCRIPTION="The X Window-System-based Visual/Integrated Environment for Workstations"
+HOMEPAGE="http://physionet.caregroup.harvard.edu/physiotools/xview/"
+
+MY_PN="${P}p1.4-18c"
+GCC_PATCHVER="0.1"
+
+# This is our compound patch derived from debian. We use it because:
+# * xview is a contribution made by Sun Microsystems (?) to the X community, but
+# fixes for it don't appear to be around other than in the other free distributions.
+# * It does little harm, only some defaults are changed which we can redefine anyway
+#SRC_PATCH="${PN}_3.2p1.4-16woody2.diff"
+
+# We use the xview tarball available from the X organization, but xfree86 appears
+# to be up and available more often so we use that (it's their primary mirror).
+SRC_URI="http://physionet.caregroup.harvard.edu/physiotools/xview/${MY_PN}.tar.gz
+ mirror://gentoo/${P}-gcc-4.1-v${GCC_PATCHVER}.patch.bz2"
+ #mirror://debian/pool/main/x/xview/${SRC_PATCH}.gz
+S=${WORKDIR}/${MY_PN}
+LICENSE="sun-openlook"
+SLOT="0"
+KEYWORDS="-alpha -amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="|| ( ( x11-libs/libXpm
+ x11-proto/xextproto
+ )
+ virtual/x11
+ )
+ media-fonts/font-bh-75dpi
+ media-fonts/font-sun-misc"
+
+DEPEND="${RDEPEND}
+ || ( ( app-text/rman
+ x11-misc/gccmakedep
+ )
+ virtual/x11
+ )"
+
+src_unpack() {
+ unpack $A
+ cd "${S}"
+ epatch "${FILESDIR}"/CAN-2005-0076.patch
+ epatch "${FILESDIR}"/lseek.diff
+ epatch "${DISTDIR}"/${P}-gcc-4.1-v${GCC_PATCHVER}.patch.bz2
+
+ # Do not build xgettext and msgfmt since they are provided by the gettext
+ # package. Using the programs provided by xview breaks many packages
+ # including vim, grep and binutils.
+ sed -e 's/MSG_UTIL = xgettext msgfmt/#MSG_UTIL = xgettext msgfmt/' \
+ -i util/Imakefile || die "gettext sed failed"
+
+ # (#120910) Look for imake in the right place
+ sed -i -e 's:\/X11::' imake || die "imake sed failed"
+}
+
+src_compile() {
+ # Create the makefile
+ imake -DUseInstalled -I${S}/config -I/usr/X11R6/lib/X11/config \
+ || die "imake failed"
+
+ # This is crazy and I know it, but wait till you read the code in
+ # Build-LinuxXView.bash.
+ OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash libs \
+ || die "building libs failed"
+ OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash clients \
+ || die "building clients failed"
+ OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash contrib \
+ || die "building contrib failed"
+ OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash olvwm \
+ || die "building olvwm failed"
+}
+
+src_install() {
+ DESTDIR=${D} OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instlibs \
+ || die "installing libs failed"
+ DESTDIR=${D} OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instclients \
+ || die "installing clients failed"
+ DESTDIR=${D} OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instcontrib \
+ || die "installing contrib failed"
+ DESTDIR=${D} OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instolvwm \
+ || die "installing olvwm failed"
+ cd ${D}/usr
+ ln -s X11R6 openwin
+
+ # The rest of the docs is already installed
+ cd ${S}/doc
+ dodoc README xview-info olgx_api.txt olgx_api.ps sel_api.txt \
+ dnd_api.txt whats_new.ps bugform config/usenixws/paper.ps
+ rm -rf ${D}/usr/X11R6/share/doc/xview && rm -rf ${D}/usr/X11R6/share/doc
+}