summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-01-05 16:43:09 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-01-05 16:43:09 +0000
commitf1de6de4a39091533015fa05a648d44afdcd0177 (patch)
treec7540739dad18267799fd6e2b1688f9b2a162e05 /x11-libs/xpyb
parentRemove old version. (diff)
downloadgentoo-2-f1de6de4a39091533015fa05a648d44afdcd0177.tar.gz
gentoo-2-f1de6de4a39091533015fa05a648d44afdcd0177.tar.bz2
gentoo-2-f1de6de4a39091533015fa05a648d44afdcd0177.zip
Revision bump since the patch was bad idea.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/xpyb')
-rw-r--r--x11-libs/xpyb/ChangeLog7
-rw-r--r--x11-libs/xpyb/xpyb-1.2-r1.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/x11-libs/xpyb/ChangeLog b/x11-libs/xpyb/ChangeLog
index 7796d5f3c45b..677ec17183af 100644
--- a/x11-libs/xpyb/ChangeLog
+++ b/x11-libs/xpyb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/xpyb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpyb/ChangeLog,v 1.9 2010/01/03 21:32:55 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpyb/ChangeLog,v 1.10 2010/01/05 16:43:09 scarabeus Exp $
+
+*xpyb-1.2-r1 (05 Jan 2010)
+
+ 05 Jan 2010; Tomáš Chvátal <scarabeus@gentoo.org> +xpyb-1.2-r1.ebuild:
+ Revision bump since the patch was bad idea.
*xpyb-1.2 (03 Jan 2010)
diff --git a/x11-libs/xpyb/xpyb-1.2-r1.ebuild b/x11-libs/xpyb/xpyb-1.2-r1.ebuild
new file mode 100644
index 000000000000..401e6e1357ea
--- /dev/null
+++ b/x11-libs/xpyb/xpyb-1.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpyb/xpyb-1.2-r1.ebuild,v 1.1 2010/01/05 16:43:09 scarabeus Exp $
+
+inherit x-modular
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/xpyb"
+SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+DESCRIPTION="XCB-based Python bindings for the X Window System"
+HOMEPAGE="http://xcb.freedesktop.org/"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="selinux"
+
+RDEPEND=">=x11-libs/libxcb-1.1
+ >=dev-lang/python-2.5"
+DEPEND="${RDEPEND}
+ >=x11-proto/xcb-proto-1.2"
+
+DOCS="NEWS README"
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable selinux xselinux)"
+}
+
+src_unpack() {
+ x-modular_src_unpack
+
+ eautoreconf
+}