summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2009-07-21 20:49:28 +0000
committerMarkus Ullmann <jokey@gentoo.org>2009-07-21 20:49:28 +0000
commitce9658239ef6cfe930a22e9b34cfac5ae23c153e (patch)
tree7e85dee6ab786d5d1c0f01d2215904327f5bc3af /x11-libs/wxGTK
parentamd64 stable, bug 278485 (diff)
downloadgentoo-2-ce9658239ef6cfe930a22e9b34cfac5ae23c153e.tar.gz
gentoo-2-ce9658239ef6cfe930a22e9b34cfac5ae23c153e.tar.bz2
gentoo-2-ce9658239ef6cfe930a22e9b34cfac5ae23c153e.zip
Add patch to fix slot b0rkage
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/wxGTK')
-rw-r--r--x11-libs/wxGTK/ChangeLog8
-rw-r--r--x11-libs/wxGTK/files/wxGTK-2.8.10.1-slot-bake-b0rkage.patch18
-rw-r--r--x11-libs/wxGTK/wxGTK-2.8.10.1-r2.ebuild160
3 files changed, 185 insertions, 1 deletions
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index d43539536ef0..86cb2a2ec30c 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.230 2009/07/21 17:59:15 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.231 2009/07/21 20:49:28 jokey Exp $
+
+*wxGTK-2.8.10.1-r2 (21 Jul 2009)
+
+ 21 Jul 2009; Markus Ullmann <jokey@gentoo.org> +wxGTK-2.8.10.1-r2.ebuild,
+ +files/wxGTK-2.8.10.1-slot-bake-b0rkage.patch:
+ Add patch to fix slot b0rkage
21 Jul 2009; Tobias Klausmann <klausman@gentoo.org>
wxGTK-2.6.4.0-r5.ebuild:
diff --git a/x11-libs/wxGTK/files/wxGTK-2.8.10.1-slot-bake-b0rkage.patch b/x11-libs/wxGTK/files/wxGTK-2.8.10.1-slot-bake-b0rkage.patch
new file mode 100644
index 000000000000..f8d8c457db2e
--- /dev/null
+++ b/x11-libs/wxGTK/files/wxGTK-2.8.10.1-slot-bake-b0rkage.patch
@@ -0,0 +1,18 @@
+diff -urN ./wxPython-src-2.8.10.1.orig/build/bakefiles/wxpresets/presets/wx.bkl ./wxPython-src-2.8.10.1/build/bakefiles/wxpresets/presets/wx.bkl
+--- ./wxPython-src-2.8.10.1.orig/build/bakefiles/wxpresets/presets/wx.bkl 2007-07-04 21:24:53.000000000 +0200
++++ ./wxPython-src-2.8.10.1/build/bakefiles/wxpresets/presets/wx.bkl 2009-07-21 22:25:53.558360790 +0200
+@@ -51,12 +51,12 @@
+ <set var="__wx_included_impl">0</set>
+
+ <if cond="FORMAT in ['autoconf','gnu']">
+- <include file="wx_unix.bkl"/>
++ <include file="wx28_unix.bkl"/>
+ <set var="__wx_included_impl">1</set>
+ </if>
+
+ <if cond="FORMAT!='autoconf' and PLATFORM_WIN32=='1'">
+- <include file="wx_win32.bkl"/>
++ <include file="wx28_win32.bkl"/>
+ <set var="__wx_included_impl">1</set>
+ </if>
+
diff --git a/x11-libs/wxGTK/wxGTK-2.8.10.1-r2.ebuild b/x11-libs/wxGTK/wxGTK-2.8.10.1-r2.ebuild
new file mode 100644
index 000000000000..8543d611c500
--- /dev/null
+++ b/x11-libs/wxGTK/wxGTK-2.8.10.1-r2.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.8.10.1-r2.ebuild,v 1.1 2009/07/21 20:49:28 jokey Exp $
+
+EAPI="2"
+
+inherit eutils versionator flag-o-matic
+
+DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit."
+HOMEPAGE="http://wxwidgets.org/"
+
+BASE_PV="$(get_version_component_range 1-3)"
+BASE_P="${PN}-${BASE_PV}"
+
+# we use the wxPython tarballs because they include the full wxGTK sources and
+# docs, and are released more frequently than wxGTK.
+SRC_URI="mirror://sourceforge/wxpython/wxPython-src-${PV}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="X doc debug gnome gstreamer odbc opengl pch sdl"
+
+RDEPEND="
+ dev-libs/expat
+ odbc? ( dev-db/unixODBC )
+ sdl? ( media-libs/libsdl )
+ X? (
+ >=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.4
+ media-libs/jpeg
+ media-libs/tiff
+ x11-libs/libSM
+ x11-libs/libXinerama
+ x11-libs/libXxf86vm
+ gnome? ( gnome-base/libgnomeprintui )
+ gstreamer? (
+ >=gnome-base/gconf-2.0
+ >=media-libs/gstreamer-0.10 )
+ opengl? ( virtual/opengl )
+ )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ X? (
+ x11-proto/xproto
+ x11-proto/xineramaproto
+ x11-proto/xf86vidmodeproto
+ )"
+
+PDEPEND=">=app-admin/eselect-wxwidgets-0.7"
+
+SLOT="2.8"
+LICENSE="wxWinLL-3
+ GPL-2
+ odbc? ( LGPL-2 )
+ doc? ( wxWinFDL-3 )"
+
+S="${WORKDIR}/wxPython-src-${PV}"
+
+src_prepare() {
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.6.3-unicode-odbc.patch
+ epatch "${FILESDIR}"/${PN}-2.8.10-collision.patch
+ epatch "${FILESDIR}"/${PN}-2.8.7-mmedia.patch # Bug #174874
+ epatch "${FILESDIR}"/${PN}-2.8.10.1-slot-bake-b0rkage.patch # hidden renames in src_install, wtf
+ # this version only:
+ epatch "${FILESDIR}"/${P}-CVE-2009-2369.patch # Bug #277722
+}
+
+src_configure() {
+ local myconf
+
+ append-flags -fno-strict-aliasing
+
+ # X independent options
+ myconf="--enable-compat26
+ --enable-shared
+ --enable-unicode
+ --with-regex=builtin
+ --with-zlib=sys
+ --with-expat=sys
+ $(use_enable debug)
+ $(use_enable pch precomp-headers)
+ $(use_with sdl)"
+
+ use odbc \
+ && myconf="${myconf} --with-odbc=sys" \
+ || myconf="${myconf} $(use_with odbc)"
+
+ # wxGTK options
+ # --enable-graphics_ctx - needed for webkit, editra
+ # --without-gnomevfs - bug #203389
+
+ use X && \
+ myconf="${myconf}
+ --enable-graphics_ctx
+ --enable-gui
+ --with-libpng=sys
+ --with-libxpm=sys
+ --with-libjpeg=sys
+ --with-libtiff=sys
+ $(use_enable gstreamer mediactrl)
+ $(use_enable opengl)
+ $(use_with opengl)
+ $(use_with gnome gnomeprint)
+ --without-gnomevfs"
+
+ # wxBase options
+ use X || \
+ myconf="${myconf}
+ --disable-gui"
+
+ mkdir "${S}"/wxgtk_build
+ cd "${S}"/wxgtk_build
+
+ ECONF_SOURCE="${S}" econf ${myconf} || die "configure failed."
+}
+
+src_compile() {
+ cd "${S}"/wxgtk_build
+
+ emake || die "make failed."
+
+ if [[ -d contrib/src ]]; then
+ cd contrib/src
+ emake || die "make contrib failed."
+ fi
+}
+
+src_install() {
+ cd "${S}"/wxgtk_build
+
+ emake DESTDIR="${D}" install || die "install failed."
+
+ if [[ -d contrib/src ]]; then
+ cd contrib/src
+ emake DESTDIR="${D}" install || die "install contrib failed."
+ fi
+
+ cd "${S}"/docs
+ dodoc changes.txt readme.txt todo30.txt
+ newdoc base/readme.txt base_readme.txt
+ newdoc gtk/readme.txt gtk_readme.txt
+
+ if use doc; then
+ dohtml -r "${S}"/docs/html/*
+ fi
+
+ # We don't want this
+ rm "${D}"usr/share/locale/it/LC_MESSAGES/wxmsw.mo
+}
+
+pkg_postinst() {
+ has_version app-admin/eselect-wxwidgets \
+ && eselect wxwidgets update
+}
+
+pkg_postrm() {
+ has_version app-admin/eselect-wxwidgets \
+ && eselect wxwidgets update
+}