summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-02-07 20:59:29 +0000
committerNick Hadaway <raker@gentoo.org>2003-02-07 20:59:29 +0000
commit9c3a56c057b4333a742278f8361ac1466e07d9fa (patch)
treeb019c6a95974863e5bb63e6b6484d4eeccda5777 /x11-libs/wxGTK/wxGTK-2.4.0.ebuild
parentAdded hppa to keywords. (diff)
downloadgentoo-2-9c3a56c057b4333a742278f8361ac1466e07d9fa.tar.gz
gentoo-2-9c3a56c057b4333a742278f8361ac1466e07d9fa.tar.bz2
gentoo-2-9c3a56c057b4333a742278f8361ac1466e07d9fa.zip
enabled a workaround for odbc/gtk2 conflict.
Diffstat (limited to 'x11-libs/wxGTK/wxGTK-2.4.0.ebuild')
-rw-r--r--x11-libs/wxGTK/wxGTK-2.4.0.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/x11-libs/wxGTK/wxGTK-2.4.0.ebuild b/x11-libs/wxGTK/wxGTK-2.4.0.ebuild
index b4ccdac7343a..76a8b7c197ba 100644
--- a/x11-libs/wxGTK/wxGTK-2.4.0.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.4.0.ebuild,v 1.5 2003/01/22 03:22:32 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.4.0.ebuild,v 1.6 2003/02/07 20:59:29 raker Exp $
DESCRIPTION="GTK+ version of wxWindows, a cross-platform C++ GUI toolkit."
SRC_URI="mirror://sourceforge/wxwindows/${P}.tar.bz2"
@@ -50,9 +50,16 @@ src_compile() {
&& myconf="${myconf} --enable-static" \
|| myconf="${myconf} --disable-static"
- use odbc \
- && myconf="${myconf} --with-odbc" \
- || myconf="${myconf} --without-odbc"
+ if [ `use odbc` ] && [ ! `use gtk2` ]; then
+ myconf="${myconf} --with-odbc"
+ elif [ `use odbc` ] && [ `use gtk2` ]; then
+ einfo "you cannot specify both odbc and gtk2"
+ einfo "Choosing gtk2 over odbc"
+ einfo "re-run with USE="-gtk2" to enable odbc"
+ myconf="${myconf} --without-odbc"
+ else
+ myconf="${myconf} --without-odbc"
+ fi
use opengl \
&& myconf="${myconf} --with-opengl" \