summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2007-08-19 23:20:57 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2007-08-19 23:20:57 +0000
commita8860d764d2e820d729ba1f54bb666bb0279f9cc (patch)
tree5fc843658ee051ad9dfbc18826cbbbaefd817f92 /x11-libs/vte
parentcompiz adjust kde deps (diff)
downloadgentoo-2-a8860d764d2e820d729ba1f54bb666bb0279f9cc.tar.gz
gentoo-2-a8860d764d2e820d729ba1f54bb666bb0279f9cc.tar.bz2
gentoo-2-a8860d764d2e820d729ba1f54bb666bb0279f9cc.zip
bump to 0.16.8
(Portage version: 2.1.3.5)
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/ChangeLog16
-rw-r--r--x11-libs/vte/files/digest-vte-0.16.83
-rw-r--r--x11-libs/vte/vte-0.16.8.ebuild55
3 files changed, 73 insertions, 1 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index f5bbd50346ec..1ba612f5daf1 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for x11-libs/vte
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.166 2007/08/11 21:11:42 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.167 2007/08/19 23:20:56 eva Exp $
+
+*vte-0.16.8 (19 Aug 2007)
+
+ 19 Aug 2007; Gilles Dartiguelongue <eva@gentoo.org> +vte-0.16.8.ebuild:
+ bump to 0.16.8
+ - Quick followup release with no code changes, to fix missing documentation
+ index in the tarball.
+ - Bug 337252 – ALT + Arrow keys don't work in irssi through gnome-terminal
+ Patch by James Bowes
+ - Bug 448259 – Mapping for Ctrl-_ Patch by Andrey Melnikov.
+ - Bug 449809 – use python-config to get python includes.
+ Patch by Sebastien Bacher.
+ - Bug 450745 – VTE's response to CSI 2 1 t incorrectly formatted.
+ Patch by Dale Sedivec.
11 Aug 2007; Mart Raudsepp <leio@gentoo.org>
-files/vte-0.11.13-memory_fix.patch, -files/vte-0.12-nonls.patch,
diff --git a/x11-libs/vte/files/digest-vte-0.16.8 b/x11-libs/vte/files/digest-vte-0.16.8
new file mode 100644
index 000000000000..984a0a297eef
--- /dev/null
+++ b/x11-libs/vte/files/digest-vte-0.16.8
@@ -0,0 +1,3 @@
+MD5 65344de3023c41c8dda2b35a415bf969 vte-0.16.8.tar.bz2 1112410
+RMD160 dc6a5b95596d02c5e55ecbb9e1e58bc64a02e9a8 vte-0.16.8.tar.bz2 1112410
+SHA256 1dc06ad4224c18061b000de0435b81b7c249215da4163edecb62a8d46090098f vte-0.16.8.tar.bz2 1112410
diff --git a/x11-libs/vte/vte-0.16.8.ebuild b/x11-libs/vte/vte-0.16.8.ebuild
new file mode 100644
index 000000000000..7d8bdaf161ad
--- /dev/null
+++ b/x11-libs/vte/vte-0.16.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.16.8.ebuild,v 1.1 2007/08/19 23:20:56 eva Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Gnome terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+# pcre is broken in this release
+IUSE="debug doc python opengl"
+
+RDEPEND=">=dev-libs/glib-2.9
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.1
+ >=media-libs/freetype-2.0.2
+ media-libs/fontconfig
+ sys-libs/ncurses
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )
+ python? (
+ >=dev-python/pygtk-2.4
+ >=dev-lang/python-2.2
+ )
+ x11-libs/libX11
+ virtual/xft"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="$(use_enable debug) $(use_enable python) \
+ $(use_with opengl glX) --with-xft2 --with-pangox"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch ${FILESDIR}/${PN}-0.13.2-no-lazy-bindings.patch
+
+ # Fix LINGUAS handling, remove when upstream fixes their po/Makefile.in.in
+ intltoolize --force || die
+
+ eautoreconf
+}