summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-04-27 19:25:43 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-04-27 19:25:43 +0000
commita5d4fb42c5b4d82d5ca7a6d07868207ee6c6f7fd (patch)
tree0fb1d3cc8f1bcb8b07dd092805f9ae886b0414da /x11-libs/vte
parentStable on sparc (diff)
downloadgentoo-2-a5d4fb42c5b4d82d5ca7a6d07868207ee6c6f7fd.tar.gz
gentoo-2-a5d4fb42c5b4d82d5ca7a6d07868207ee6c6f7fd.tar.bz2
gentoo-2-a5d4fb42c5b4d82d5ca7a6d07868207ee6c6f7fd.zip
version bump from upstream for minor fixes
(Portage version: 2.1.2.5)
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/ChangeLog7
-rw-r--r--x11-libs/vte/files/digest-vte-0.16.33
-rw-r--r--x11-libs/vte/vte-0.16.3.ebuild52
3 files changed, 61 insertions, 1 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index 495243206c1f..060bb14446d6 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/vte
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.146 2007/04/17 03:58:26 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.147 2007/04/27 19:25:43 compnerd Exp $
+
+*vte-0.16.3 (27 Apr 2007)
+
+ 27 Apr 2007; Saleem Abdulrasool <compnerd@gentoo.org> +vte-0.16.3.ebuild:
+ Version bump from upstream with minor fixes
*vte-0.16.1 (17 Apr 2007)
diff --git a/x11-libs/vte/files/digest-vte-0.16.3 b/x11-libs/vte/files/digest-vte-0.16.3
new file mode 100644
index 000000000000..345cd0d891ce
--- /dev/null
+++ b/x11-libs/vte/files/digest-vte-0.16.3
@@ -0,0 +1,3 @@
+MD5 a35cb0694159a9782fe43f49215c1bf5 vte-0.16.3.tar.bz2 1099965
+RMD160 2ad0dd17aa35796283be53004acee5b5a3109bca vte-0.16.3.tar.bz2 1099965
+SHA256 2d1c59a75e5b205e70c17000909d535ce9ec24cafce882bdbef17022e7422ac6 vte-0.16.3.tar.bz2 1099965
diff --git a/x11-libs/vte/vte-0.16.3.ebuild b/x11-libs/vte/vte-0.16.3.ebuild
new file mode 100644
index 000000000000..55842eb026ec
--- /dev/null
+++ b/x11-libs/vte/vte-0.16.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.16.3.ebuild,v 1.1 2007/04/27 19:25:43 compnerd Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Xft powered terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+# pcre is broken in this release
+IUSE="debug doc python opengl"
+
+RDEPEND=">=dev-libs/glib-2.9
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.1
+ >=media-libs/freetype-2.0.2
+ media-libs/fontconfig
+ sys-libs/ncurses
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )
+ python? (
+ >=dev-python/pygtk-2.4
+ >=dev-lang/python-2.2
+ )
+ || ( x11-libs/libX11 virtual/x11 )
+ virtual/xft"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="$(use_enable debug) $(use_enable python) \
+ $(use_with opengl glX) --with-xft2 --with-pangox"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch ${FILESDIR}/${PN}-0.13.2-no-lazy-bindings.patch
+ cd ${S}/gnome-pty-helper
+ eautomake
+}