summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-10-20 07:28:40 +0000
committerPacho Ramos <pacho@gentoo.org>2012-10-20 07:28:40 +0000
commit2403da745d5ac43b6514638cb0e1fb5f39702f1c (patch)
treea0401961d74340ead86be3f0046d1022e27f3a38 /x11-libs/vte
parentMove x11-wm/razorqt and x11-misc/lightdm-razorqt-greeter to new locations in ... (diff)
downloadgentoo-2-2403da745d5ac43b6514638cb0e1fb5f39702f1c.tar.gz
gentoo-2-2403da745d5ac43b6514638cb0e1fb5f39702f1c.tar.bz2
gentoo-2-2403da745d5ac43b6514638cb0e1fb5f39702f1c.zip
Version bump.
(Portage version: 2.1.11.24/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/ChangeLog7
-rw-r--r--x11-libs/vte/vte-0.34.1.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index 1c16a98fcedf..8e1fce93db90 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/vte
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.343 2012/10/11 11:25:30 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.344 2012/10/20 07:28:40 pacho Exp $
+
+*vte-0.34.1 (20 Oct 2012)
+
+ 20 Oct 2012; Pacho Ramos <pacho@gentoo.org> +vte-0.34.1.ebuild:
+ Version bump.
11 Oct 2012; Markus Meier <maekke@gentoo.org> vte-0.28.2-r204.ebuild:
arm stable, bug #427802
diff --git a/x11-libs/vte/vte-0.34.1.ebuild b/x11-libs/vte/vte-0.34.1.ebuild
new file mode 100644
index 000000000000..0f9bf19de59d
--- /dev/null
+++ b/x11-libs/vte/vte-0.34.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.34.1.ebuild,v 1.1 2012/10/20 07:28:40 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="Library providing a virtual terminal emulator widget."
+HOMEPAGE="https://live.gnome.org/Terminal/VTE"
+
+LICENSE="LGPL-2+"
+SLOT="2.90"
+IUSE="debug glade +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+PDEPEND="x11-libs/gnome-pty-helper"
+RDEPEND=">=dev-libs/glib-2.31.13:2
+ >=x11-libs/gtk+-3.1.9:3[introspection?]
+ >=x11-libs/pango-1.22.0
+
+ sys-libs/ncurses
+ x11-libs/libX11
+ x11-libs/libXft
+
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Python bindings are via gobject-introspection
+ # Ex: from gi.repository import Vte
+ # Do not disable gnome-pty-helper, bug #401389
+ G2CONF="${G2CONF}
+ --disable-deprecation
+ --disable-static
+ $(use_enable debug)
+ $(use_enable glade glade-catalogue)
+ $(use_enable introspection)"
+
+ if [[ ${CHOST} == *-interix* ]]; then
+ G2CONF="${G2CONF} --disable-Bsymbolic"
+
+ # interix stropts.h is empty...
+ export ac_cv_header_stropts_h=no
+ fi
+
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=663779
+ epatch "${FILESDIR}/${PN}-0.30.1-alt-meta.patch"
+
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ rm -v "${ED}usr/libexec/gnome-pty-helper" || die
+}