summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-02-03 14:15:44 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-02-03 14:15:44 +0000
commitce3f9459e20d47dca8ce896fa1c97da161379ef1 (patch)
tree77bb0d3b8b20c45cb8e1ecc5c1b8d44f4d507858 /x11-libs/vdpau-video
parentversion bump (diff)
downloadgentoo-2-ce3f9459e20d47dca8ce896fa1c97da161379ef1.tar.gz
gentoo-2-ce3f9459e20d47dca8ce896fa1c97da161379ef1.tar.bz2
gentoo-2-ce3f9459e20d47dca8ce896fa1c97da161379ef1.zip
version bump
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/vdpau-video')
-rw-r--r--x11-libs/vdpau-video/ChangeLog10
-rw-r--r--x11-libs/vdpau-video/vdpau-video-0.7.3_pre6.ebuild41
2 files changed, 49 insertions, 2 deletions
diff --git a/x11-libs/vdpau-video/ChangeLog b/x11-libs/vdpau-video/ChangeLog
index 61c333ce5ceb..bb2a4da87b3c 100644
--- a/x11-libs/vdpau-video/ChangeLog
+++ b/x11-libs/vdpau-video/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/vdpau-video
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vdpau-video/ChangeLog,v 1.8 2010/12/24 15:49:21 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vdpau-video/ChangeLog,v 1.9 2011/02/03 14:15:44 aballier Exp $
+
+*vdpau-video-0.7.3_pre6 (03 Feb 2011)
+
+ 03 Feb 2011; Alexis Ballier <aballier@gentoo.org>
+ +vdpau-video-0.7.3_pre6.ebuild:
+ version bump
*vdpau-video-0.7.3_pre2 (24 Dec 2010)
diff --git a/x11-libs/vdpau-video/vdpau-video-0.7.3_pre6.ebuild b/x11-libs/vdpau-video/vdpau-video-0.7.3_pre6.ebuild
new file mode 100644
index 000000000000..aa6abe1412ab
--- /dev/null
+++ b/x11-libs/vdpau-video/vdpau-video-0.7.3_pre6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vdpau-video/vdpau-video-0.7.3_pre6.ebuild,v 1.1 2011/02/03 14:15:44 aballier Exp $
+
+EAPI="2"
+inherit autotools
+
+MY_P=${P/_/.}
+DESCRIPTION="VDPAU Backend for Video Acceleration (VA) API"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
+SRC_URI="http://www.splitted-desktop.com/~gbeauchesne/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opengl"
+
+RDEPEND="x11-libs/libva[opengl?]
+ opengl? ( virtual/opengl )
+ x11-libs/libvdpau"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable opengl glx)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc NEWS README AUTHORS
+ find "${D}" -name '*.la' -delete
+}