summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-02-27 13:47:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-02-27 13:47:23 +0000
commit4a473a3fa3623542612fe998485aa5bda69f9b36 (patch)
tree91d9f80c0c2679cf4f7fdb904a610a6668473ebe /x11-libs/vdpau-video
parentversion bump (diff)
downloadgentoo-2-4a473a3fa3623542612fe998485aa5bda69f9b36.tar.gz
gentoo-2-4a473a3fa3623542612fe998485aa5bda69f9b36.tar.bz2
gentoo-2-4a473a3fa3623542612fe998485aa5bda69f9b36.zip
version bump
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/vdpau-video')
-rw-r--r--x11-libs/vdpau-video/ChangeLog7
-rw-r--r--x11-libs/vdpau-video/vdpau-video-0.7.3.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/x11-libs/vdpau-video/ChangeLog b/x11-libs/vdpau-video/ChangeLog
index 7bc021a92d6b..d099123fc42c 100644
--- a/x11-libs/vdpau-video/ChangeLog
+++ b/x11-libs/vdpau-video/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/vdpau-video
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vdpau-video/ChangeLog,v 1.10 2011/02/03 14:17:01 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vdpau-video/ChangeLog,v 1.11 2011/02/27 13:47:23 aballier Exp $
+
+*vdpau-video-0.7.3 (27 Feb 2011)
+
+ 27 Feb 2011; Alexis Ballier <aballier@gentoo.org> +vdpau-video-0.7.3.ebuild:
+ version bump
03 Feb 2011; Alexis Ballier <aballier@gentoo.org> -vdpau-video-0.7.2.ebuild,
-vdpau-video-0.7.3_pre2.ebuild, -files/vdpau-video-nogl.patch:
diff --git a/x11-libs/vdpau-video/vdpau-video-0.7.3.ebuild b/x11-libs/vdpau-video/vdpau-video-0.7.3.ebuild
new file mode 100644
index 000000000000..845281eed53b
--- /dev/null
+++ b/x11-libs/vdpau-video/vdpau-video-0.7.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vdpau-video/vdpau-video-0.7.3.ebuild,v 1.1 2011/02/27 13:47:23 aballier Exp $
+
+EAPI="2"
+inherit autotools
+
+MY_P=${P/_/.}
+DESCRIPTION="VDPAU Backend for Video Acceleration (VA) API"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
+SRC_URI="http://www.splitted-desktop.com/~gbeauchesne/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opengl"
+
+RDEPEND="x11-libs/libva[opengl?]
+ opengl? ( virtual/opengl )
+ x11-libs/libvdpau"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable opengl glx)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc NEWS README AUTHORS
+ find "${D}" -name '*.la' -delete
+}