summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-03-29 19:41:06 +0000
committerAron Griffis <agriffis@gentoo.org>2004-03-29 19:41:06 +0000
commitb5be5469c9fc4af56f370fa77c079e4722924f78 (patch)
tree855103f1575d952509aad92910a69f40c8c16ab1 /x11-libs/rep-gtk
parentAdded blocker on >=gcc-3.3.2 (Manifest recommit) (diff)
downloadgentoo-2-b5be5469c9fc4af56f370fa77c079e4722924f78.tar.gz
gentoo-2-b5be5469c9fc4af56f370fa77c079e4722924f78.tar.bz2
gentoo-2-b5be5469c9fc4af56f370fa77c079e4722924f78.zip
Fix bug 45646 by syncing up rep-gtk headers with gtk+; only applies when >=gtk+-2.4 is installed. Thanks to Olivier Bulteel for the fix. Add metadata.xml naming myself as maintainer
Diffstat (limited to 'x11-libs/rep-gtk')
-rw-r--r--x11-libs/rep-gtk/ChangeLog8
-rw-r--r--x11-libs/rep-gtk/files/rep-gtk-0.18-gtk24.patch38
-rw-r--r--x11-libs/rep-gtk/metadata.xml9
-rw-r--r--x11-libs/rep-gtk/rep-gtk-0.18.ebuild16
4 files changed, 66 insertions, 5 deletions
diff --git a/x11-libs/rep-gtk/ChangeLog b/x11-libs/rep-gtk/ChangeLog
index e1dc833d9d5c..4b75a8c36abd 100644
--- a/x11-libs/rep-gtk/ChangeLog
+++ b/x11-libs/rep-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/rep-gtk
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/ChangeLog,v 1.21 2004/02/29 15:04:38 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/ChangeLog,v 1.22 2004/03/29 19:41:05 agriffis Exp $
+
+ 29 Mar 2004; Aron Griffis <agriffis@gentoo.org> metadata.xml,
+ rep-gtk-0.18.ebuild, files/rep-gtk-0.18-gtk24.patch:
+ Fix bug 45646 by syncing up rep-gtk headers with gtk+; only applies when
+ >=gtk+-2.4 is installed. Thanks to Olivier Bulteel for the fix. Add
+ metadata.xml naming myself as maintainer
27 Feb 2004; Sven Blumenstein <bazik@gentoo.org> rep-gtk-0.17-r1.ebuild:
Stable on sparc. Forgot to commit :)
diff --git a/x11-libs/rep-gtk/files/rep-gtk-0.18-gtk24.patch b/x11-libs/rep-gtk/files/rep-gtk-0.18-gtk24.patch
new file mode 100644
index 000000000000..5ae02b56ad4c
--- /dev/null
+++ b/x11-libs/rep-gtk/files/rep-gtk-0.18-gtk24.patch
@@ -0,0 +1,38 @@
+Only in rep-gtk-0.18-gtk2_patched: config.h
+diff -aur rep-gtk-0.18/gtk-compat.c rep-gtk-0.18-gtk2_patched/gtk-compat.c
+--- rep-gtk-0.18/gtk-compat.c 2002-07-12 00:19:22.000000000 -0400
++++ rep-gtk-0.18-gtk2_patched/gtk-compat.c 2004-03-27 00:59:32.109529224 -0500
+@@ -64,7 +64,7 @@
+
+ GtkWidget*
+ gtk_radio_menu_item_new_with_label_from_widget (GtkRadioMenuItem *group,
+- gchar *label)
++ const gchar *label)
+ {
+ GSList *g = group? gtk_radio_menu_item_group (group) : NULL;
+ return gtk_radio_menu_item_new_with_label (g, label);
+@@ -72,7 +72,7 @@
+
+ GtkWidget*
+ gtk_radio_menu_item_new_with_mnemonic_from_widget (GtkRadioMenuItem *group,
+- gchar *label)
++ const gchar *label)
+ {
+ GSList *g = group? gtk_radio_menu_item_group (group) : NULL;
+ return gtk_radio_menu_item_new_with_mnemonic (g, label);
+diff -aur rep-gtk-0.18/rep-gtk.h rep-gtk-0.18-gtk2_patched/rep-gtk.h
+--- rep-gtk-0.18/rep-gtk.h 2003-02-12 03:51:45.000000000 -0500
++++ rep-gtk-0.18-gtk2_patched/rep-gtk.h 2004-03-27 00:59:35.512011968 -0500
+@@ -291,10 +291,10 @@
+
+ GtkWidget*
+ gtk_radio_menu_item_new_with_label_from_widget (GtkRadioMenuItem *group,
+- gchar *label);
++ const gchar *label);
+ GtkWidget*
+ gtk_radio_menu_item_new_with_mnemonic_from_widget (GtkRadioMenuItem *group,
+- gchar *label);
++ const gchar *label);
+ GtkWidget* gtk_radio_menu_item_new_from_widget (GtkRadioMenuItem *group);
+ GtkWidget* gtk_pixmap_new_interp (char *file, GtkWidget *intended_parent);
+
diff --git a/x11-libs/rep-gtk/metadata.xml b/x11-libs/rep-gtk/metadata.xml
new file mode 100644
index 000000000000..a5a4c727a5cf
--- /dev/null
+++ b/x11-libs/rep-gtk/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<maintainer>
+ <email>agriffis@gentoo.org</email>
+ <name>Aron Griffis</name>
+</maintainer>
+</pkgmetadata>
diff --git a/x11-libs/rep-gtk/rep-gtk-0.18.ebuild b/x11-libs/rep-gtk/rep-gtk-0.18.ebuild
index 1d45fc1454be..31c1a7c922ee 100644
--- a/x11-libs/rep-gtk/rep-gtk-0.18.ebuild
+++ b/x11-libs/rep-gtk/rep-gtk-0.18.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/rep-gtk-0.18.ebuild,v 1.3 2004/02/22 16:01:50 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/rep-gtk-0.18.ebuild,v 1.4 2004/03/29 19:41:06 agriffis Exp $
inherit eutils
@@ -25,8 +25,17 @@ DEPEND="virtual/glibc
>=sys-devel/automake-1.6.1-r5
>=dev-libs/librep-0.13"
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+
+ # Fix for bug 45646 to sync up rep-gtk headers with gtk+
+ if has_version '>=x11-libs/gtk+-2.4'; then
+ epatch ${FILESDIR}/rep-gtk-0.18-gtk24.patch
+ fi
+}
+src_compile() {
./configure --host=${CHOST} \
--prefix=/usr \
--libexecdir=/usr/lib \
@@ -39,7 +48,6 @@ src_compile() {
}
src_install() {
-
make install \
host_type=${CHOST} \
installdir=${D}/usr/lib/rep/${CHOST} || die